aboutsummaryrefslogtreecommitdiff
path: root/devel/ioncube/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:30:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:30:22 +0000
commitc8d49aa884128f78548ef4e64d010d578e374d3d (patch)
treee7b2796aeb6783f529eb1343886b3f8598ee8a4c /devel/ioncube/Makefile
parent1428d6519b158771de764f146d75c2127308711d (diff)
downloadports-c8d49aa884128f78548ef4e64d010d578e374d3d.tar.gz
ports-c8d49aa884128f78548ef4e64d010d578e374d3d.zip
The ionCube Loader is a free application that runs the files
encoded by the ionCube PHP Encoder, while enhancing the running speed of PHP applications. Benefits: - Enables users to run files encoded by the ionCube PHP Encoder WWW: http://www.ioncube.com/ PR: ports/144096 Submitted by: Svyatoslav Lempert <svyatoslav.lempert at gmail.com>
Notes
Notes: svn path=/head/; revision=250788
Diffstat (limited to 'devel/ioncube/Makefile')
-rw-r--r--devel/ioncube/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
new file mode 100644
index 000000000000..6143184d0bca
--- /dev/null
+++ b/devel/ioncube/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ioncube
+# Date created: Fri Feb 12 21:43:10 CET 2010
+# Whom: Svyatoslav Lempert <svyatoslav.lempert@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ioncube
+DISTVERSION= 3.3.10
+CATEGORIES= devel
+MASTER_SITES= http://downloads2.ioncube.com/loader_downloads/ \
+ http://downloads.ioncube.com/loader_downloads/
+DISTFILES= ${PORTNAME}_loaders_fre_${VER}_${ARCH_DIST}${EXTRACT_SUFX}
+
+MAINTAINER= svyatoslav.lempert@.gmail.com
+COMMENT= An ionCube loader for PHP code
+
+ONLY_FOR_ARCHS= i386 amd64
+NO_BUILD= yes
+USE_PHP= yes
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700055
+VER= 6
+.else
+VER= 7
+.endif
+
+.if ${ARCH} == i386
+ARCH_DIST= x86
+.else
+ARCH_DIST= x86-64
+.endif
+
+.if ${PHP_VER} >= 5
+PHP_INSTVER= 5.2
+.else
+PHP_INSTVER= 4.4
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}/ioncube/
+ ${INSTALL_DATA} ${WRKDIR}/ioncube/ioncube_loader_fre_${PHP_INSTVER}.so \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}/ioncube/ioncube_loader.so
+ ${INSTALL_DATA} ${WRKDIR}/ioncube/ioncube_loader_fre_${PHP_INSTVER}_ts.so \
+ ${PREFIX}/lib/php/${PHP_EXT_DIR}/ioncube/ioncube_loader_ts.so
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>