aboutsummaryrefslogtreecommitdiff
path: root/devel/jakarta-commons-io
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-02-14 15:46:38 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-02-14 15:46:38 +0000
commit5fc6e0805d69e6e6619398699a984743489cfa5e (patch)
tree9128fd254b54788657a0d4a616f9d3b13326ddb3 /devel/jakarta-commons-io
parent02b8202b8f30d70bbba3a398da81b0f68375b1d5 (diff)
downloadports-5fc6e0805d69e6e6619398699a984743489cfa5e.tar.gz
ports-5fc6e0805d69e6e6619398699a984743489cfa5e.zip
Commons IO is a library of utilities to assist with developing IO functionality.
There are three main areas included: * Utility classes - with static methods to perform common tasks * Filters - various implementations of file filters * Streams - useful stream, reader and writer implementations WWW: http://jakarta.apache.org/commons/io/ PR: 93322 Submitted by: Michael Winking <mwfp@foldl.net>
Notes
Notes: svn path=/head/; revision=156034
Diffstat (limited to 'devel/jakarta-commons-io')
-rw-r--r--devel/jakarta-commons-io/Makefile54
-rw-r--r--devel/jakarta-commons-io/distinfo4
-rw-r--r--devel/jakarta-commons-io/pkg-descr9
3 files changed, 67 insertions, 0 deletions
diff --git a/devel/jakarta-commons-io/Makefile b/devel/jakarta-commons-io/Makefile
new file mode 100644
index 000000000000..b1f38a54e418
--- /dev/null
+++ b/devel/jakarta-commons-io/Makefile
@@ -0,0 +1,54 @@
+# Ports collection makefile for: Jakarta Commons IO
+# Date created: 14 Feb 2006
+# Whom: Michael Winking <mwfp@foldl.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-io
+PORTVERSION= 1.1
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= commons/io/source
+PKGNAMEPREFIX= jakarta-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= mwfp@foldl.net
+COMMENT= A collection of I/O utilities for Java
+
+BUILD_DEPENDS= ${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+USE_ANT= yes
+
+MAKE_ARGS= -cp ${JAVAJARDIR}/junit.jar
+ALL_TARGET= dist
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= LICENSE.txt NOTICE.txt RELEASE-NOTES.txt docs
+ALL_TARGET+= javadoc
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}-${PORTVERSION}.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/build/dist-build/${PORTNAME}-${PORTVERSION} && ${FIND} docs \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${INSTALL_DATA} ${WRKSRC}/LICENSE.txt \
+ ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/NOTICE.txt \
+ ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/RELEASE-NOTES.txt \
+ ${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/jakarta-commons-io/distinfo b/devel/jakarta-commons-io/distinfo
new file mode 100644
index 000000000000..a67e947e4a9f
--- /dev/null
+++ b/devel/jakarta-commons-io/distinfo
@@ -0,0 +1,4 @@
+MD5 (commons-io-1.1-src.tar.gz) = 0a39b54885b86dc42169ffd761caf414
+SHA256 (commons-io-1.1-src.tar.gz) =
+375983a026c86afee9b07405a616b3614de3f844b2530d54a5f12c06a666b92c
+SIZE (commons-io-1.1-src.tar.gz) = 197922
diff --git a/devel/jakarta-commons-io/pkg-descr b/devel/jakarta-commons-io/pkg-descr
new file mode 100644
index 000000000000..d0a656697763
--- /dev/null
+++ b/devel/jakarta-commons-io/pkg-descr
@@ -0,0 +1,9 @@
+Commons IO is a library of utilities to assist with developing IO functionality.
+
+There are three main areas included:
+
+ * Utility classes - with static methods to perform common tasks
+ * Filters - various implementations of file filters
+ * Streams - useful stream, reader and writer implementations
+
+WWW: http://jakarta.apache.org/commons/io/