aboutsummaryrefslogtreecommitdiff
path: root/devel/jakelib2
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-14 21:08:49 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-14 21:08:49 +0000
commit71af53a84011054d3dbbb78ce5cafdee3f331195 (patch)
tree75b61e5c8a9489f507cf817fd647005a67f2be22 /devel/jakelib2
parentd0a77e7957dfc2ac374a45b583346697d9bee42b (diff)
downloadports-71af53a84011054d3dbbb78ce5cafdee3f331195.tar.gz
ports-71af53a84011054d3dbbb78ce5cafdee3f331195.zip
USE_LIBTOOL instead of local patch
Notes
Notes: svn path=/head/; revision=133361
Diffstat (limited to 'devel/jakelib2')
-rw-r--r--devel/jakelib2/Makefile1
-rw-r--r--devel/jakelib2/files/patch-ltmain.sh15
2 files changed, 1 insertions, 15 deletions
diff --git a/devel/jakelib2/Makefile b/devel/jakelib2/Makefile
index a3352d05cfaa..19e6ce20c4cc 100644
--- a/devel/jakelib2/Makefile
+++ b/devel/jakelib2/Makefile
@@ -17,6 +17,7 @@ COMMENT= A cross platform C++ class library with a Java-like API
LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc
+USE_LIBTOOL_VER=15
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
diff --git a/devel/jakelib2/files/patch-ltmain.sh b/devel/jakelib2/files/patch-ltmain.sh
deleted file mode 100644
index 128873800355..000000000000
--- a/devel/jakelib2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Fri Oct 24 09:34:59 2003
-+++ ltmain.sh Fri Oct 24 09:35:12 2003
-@@ -4175,10 +4175,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"