aboutsummaryrefslogtreecommitdiff
path: root/devel/jansson
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2010-01-30 15:52:15 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2010-01-30 15:52:15 +0000
commit193e21c3884a94b8f4a2aae8c3080bccc42a0eda (patch)
treefe89874f561847868c15a989c0b253d01a5e6d87 /devel/jansson
parentfc3f47f07f4be045007b673deb34c5ba98ac6b9e (diff)
downloadports-193e21c3884a94b8f4a2aae8c3080bccc42a0eda.tar.gz
ports-193e21c3884a94b8f4a2aae8c3080bccc42a0eda.zip
Yet another JSON library in C.
Notes
Notes: svn path=/head/; revision=248846
Diffstat (limited to 'devel/jansson')
-rw-r--r--devel/jansson/Makefile20
-rw-r--r--devel/jansson/distinfo3
-rw-r--r--devel/jansson/files/patch-src_utf.h11
-rw-r--r--devel/jansson/pkg-descr14
-rw-r--r--devel/jansson/pkg-plist6
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/jansson/Makefile b/devel/jansson/Makefile
new file mode 100644
index 000000000000..a505aa48c79e
--- /dev/null
+++ b/devel/jansson/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: jansson
+# Date created: January 30 2010
+# Whom: vanilla@
+#
+# $FreeBSD$
+#
+
+PORTNAME= jansson
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://www.digip.org/jansson/releases/
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= A C library for encoding, decoding and manipulating JSON data
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+
+.include <bsd.port.mk>
diff --git a/devel/jansson/distinfo b/devel/jansson/distinfo
new file mode 100644
index 000000000000..65512113e05f
--- /dev/null
+++ b/devel/jansson/distinfo
@@ -0,0 +1,3 @@
+MD5 (jansson-1.2.tar.gz) = 492b42d1b3f2e212e77bef31db879ed7
+SHA256 (jansson-1.2.tar.gz) = 82de835e6c2a5896b1e9ed4d7bc8b025f28cad8592d6ec0e4044fbdbcbd3a67d
+SIZE (jansson-1.2.tar.gz) = 347315
diff --git a/devel/jansson/files/patch-src_utf.h b/devel/jansson/files/patch-src_utf.h
new file mode 100644
index 000000000000..b8b5aa14468b
--- /dev/null
+++ b/devel/jansson/files/patch-src_utf.h
@@ -0,0 +1,11 @@
+--- src/utf.h.orig 2010-01-30 20:53:52.000000000 +0800
++++ src/utf.h 2010-01-30 20:54:05.000000000 +0800
+@@ -8,6 +8,8 @@
+ #ifndef UTF_H
+ #define UTF_H
+
++#include <sys/types.h>
++
+ int utf8_encode(int codepoint, char *buffer, int *size);
+
+ int utf8_check_first(char byte);
diff --git a/devel/jansson/pkg-descr b/devel/jansson/pkg-descr
new file mode 100644
index 000000000000..54a482c4b78b
--- /dev/null
+++ b/devel/jansson/pkg-descr
@@ -0,0 +1,14 @@
+Jansson is a C library for encoding, decoding and manipulating JSON
+data. Its main features and design principles are:
+
+- Simple and intuitive API and data model
+
+- Comprehensive documentation
+
+- No dependencies on other libraries
+
+- Full Unicode support (UTF-8)
+
+- Extensive test suite
+
+WWW: http://www.digip.org/jansson/
diff --git a/devel/jansson/pkg-plist b/devel/jansson/pkg-plist
new file mode 100644
index 000000000000..f426a4a6921d
--- /dev/null
+++ b/devel/jansson/pkg-plist
@@ -0,0 +1,6 @@
+include/jansson.h
+lib/libjansson.a
+lib/libjansson.la
+lib/libjansson.so
+lib/libjansson.so.2
+libdata/pkgconfig/jansson.pc