aboutsummaryrefslogtreecommitdiff
path: root/devel/jenkins/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2011-03-06 09:59:52 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2011-03-06 09:59:52 +0000
commit1fa77d6c199dc9475f2f862d2c913c56d2debb59 (patch)
tree74d52d53e67a52119f66d5e5be2253d45ea689a4 /devel/jenkins/Makefile
parent7c19c8a3cd0a8dce98bfd6a95ce075855c12c8e5 (diff)
downloadports-1fa77d6c199dc9475f2f862d2c913c56d2debb59.tar.gz
ports-1fa77d6c199dc9475f2f862d2c913c56d2debb59.zip
Add jenkins 1.399, open-source continuous integration server.
This port is mostly copied and modified from www/hudson, and many thanks to dougb for the rc script.
Notes
Notes: svn path=/head/; revision=270362
Diffstat (limited to 'devel/jenkins/Makefile')
-rw-r--r--devel/jenkins/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/devel/jenkins/Makefile b/devel/jenkins/Makefile
new file mode 100644
index 000000000000..20bdfdacabb3
--- /dev/null
+++ b/devel/jenkins/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: jenkins
+# Date created: 2011-03-03
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jenkins
+PORTVERSION= 1.399
+CATEGORIES= devel java
+MASTER_SITES= http://mirrors.jenkins-ci.org/war/${PORTVERSION}/
+DISTNAME= jenkins
+EXTRACT_SUFX= .war
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Open-source continuous integration server
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+FETCH_ARGS= -Fpr
+NO_BUILD= yes
+
+USE_RC_SUBR= jenkins
+
+JENKINS_HOME?= ${PREFIX}/jenkins
+JENKINS_USER?= jenkins
+JENKINS_GROUP?= jenkins
+JENKINS_LOG_FILE?= /var/log/jenkins.log
+
+.if ${JENKINS_USER} == "jenkins"
+USERS= jenkins
+.endif
+.if ${JENKINS_GROUP} == "jenkins"
+GROUPS= jenkins
+.endif
+
+PLIST_FILES= %%DATADIR%%/${DISTNAME}${EXTRACT_SUFX}
+PLIST_DIRS= %%DATADIR%%
+SUB_LIST+= JENKINS_HOME=${JENKINS_HOME} JENKINS_USER=${JENKINS_USER} JENKINS_GROUP=${JENKINS_GROUP} JAVA_HOME=${JAVA_HOME} JENKINS_LOG_FILE=${JENKINS_LOG_FILE}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} "${DATADIR}"
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} ${DATADIR}/
+
+.include <bsd.port.post.mk>