aboutsummaryrefslogtreecommitdiff
path: root/devel/kdebindings4-python-pykde4
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-01-30 14:27:27 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-01-30 14:27:27 +0000
commitafb550e3cf83ca6a9d25a40d91f5208b3c36f9f2 (patch)
treefb95bc5acb82022c6c68c02f6e263d6524f02ae6 /devel/kdebindings4-python-pykde4
parent258a4596278aa7d7052491adbf5e259c8c73465f (diff)
downloadports-afb550e3cf83ca6a9d25a40d91f5208b3c36f9f2.tar.gz
ports-afb550e3cf83ca6a9d25a40d91f5208b3c36f9f2.zip
The KDE FreeBSD team is proud to announce the release of SIP-4.10 and
PyQt-4.7 for FreeBSD. The official update notes can be found at http://www.riverbankcomputing.com We'd like to say thanks to all helpers, testers and submitters.
Notes
Notes: svn path=/head/; revision=248842
Diffstat (limited to 'devel/kdebindings4-python-pykde4')
-rw-r--r--devel/kdebindings4-python-pykde4/Makefile1
-rw-r--r--devel/kdebindings4-python-pykde4/files/patch-python__pykde4__CMakeLists.txt10
-rw-r--r--devel/kdebindings4-python-pykde4/files/patch-python__pykde4__sip__kdecore__typedefs.sip93
3 files changed, 104 insertions, 0 deletions
diff --git a/devel/kdebindings4-python-pykde4/Makefile b/devel/kdebindings4-python-pykde4/Makefile
index 289f815ba6db..a5641ec7ea69 100644
--- a/devel/kdebindings4-python-pykde4/Makefile
+++ b/devel/kdebindings4-python-pykde4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdebindings
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= devel kde python
PKGNAMESUFFIX= -kde
diff --git a/devel/kdebindings4-python-pykde4/files/patch-python__pykde4__CMakeLists.txt b/devel/kdebindings4-python-pykde4/files/patch-python__pykde4__CMakeLists.txt
new file mode 100644
index 000000000000..582596d7bbd9
--- /dev/null
+++ b/devel/kdebindings4-python-pykde4/files/patch-python__pykde4__CMakeLists.txt
@@ -0,0 +1,10 @@
+--- ./python/pykde4/CMakeLists.txt.orig 2010-01-28 00:00:42.991544204 +0300
++++ ./python/pykde4/CMakeLists.txt 2010-01-28 00:01:04.122014998 +0300
+@@ -211,6 +211,7 @@
+ # Install the .sip files for anyone that wants to build bindings on top of PyKDE4.
+ # (Don't forget the / at the end of sip/.)
+ INSTALL(DIRECTORY sip/ DESTINATION ${SIP_DEFAULT_SIP_DIR}/PyKDE4
++ PATTERN "*.orig" EXCLUDE
+ PATTERN "*~" EXCLUDE # This sucks, why can't I just whitelist what I _do_ want?
+ PATTERN ".svn" EXCLUDE
+ PATTERN "*.in" EXCLUDE)
diff --git a/devel/kdebindings4-python-pykde4/files/patch-python__pykde4__sip__kdecore__typedefs.sip b/devel/kdebindings4-python-pykde4/files/patch-python__pykde4__sip__kdecore__typedefs.sip
new file mode 100644
index 000000000000..e3670005e402
--- /dev/null
+++ b/devel/kdebindings4-python-pykde4/files/patch-python__pykde4__sip__kdecore__typedefs.sip
@@ -0,0 +1,93 @@
+--- ./python/pykde4/sip/kdecore/typedefs.sip.orig 2009-10-02 12:21:29.000000000 +0400
++++ ./python/pykde4/sip/kdecore/typedefs.sip 2010-01-27 23:01:34.003236927 +0300
+@@ -467,90 +467,6 @@
+ };
+
+
+-template <TYPE*>
+-%MappedType QSet<TYPE*>
+-{
+-%TypeHeaderCode
+-#include <qset.h>
+-%End
+-
+-%ConvertFromTypeCode
+- // Create the list.
+- PyObject *l;
+-
+- if ((l = PyList_New(sipCpp->size())) == NULL)
+- return NULL;
+-
+- // Set the list elements.
+- QSet<TYPE*> set = *sipCpp;
+- int i = 0;
+- foreach ((TYPE *)value, set)
+- {
+- PyObject *obj = sipConvertFromNewType(value, sipType_TYPE, sipTransferObj);
+- if (obj == NULL || PyList_SET_ITEM (l, i, obj) < 0)
+- {
+- Py_DECREF(l);
+-
+- if (obj)
+- Py_DECREF(obj);
+-
+- return NULL;
+- }
+-
+- Py_DECREF(obj);
+- i++;
+- }
+-
+- return l;
+-%End
+-
+-%ConvertToTypeCode
+- // Check the type if that is all that is required.
+- if (sipIsErr == NULL)
+- {
+- if (!PyList_Check(sipPy))
+- return 0;
+- }
+-
+- // Check the type if that is all that is required.
+- if (sipIsErr == NULL)
+- {
+- if (!PyList_Check(sipPy))
+- return 0;
+-
+- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i)
+- if (!sipCanConvertToType(PyList_GET_ITEM (sipPy, i), sipType_TYPE, SIP_NOT_NONE))
+- return 0;
+- }
+-
+- QSet<TYPE*> *qs = new QSet<TYPE*>;
+-
+- for (int i = 0; i < PyList_GET_SIZE(sipPy); ++i)
+- {
+- int state;
+-
+- TYPE *t = reinterpret_cast<TYPE *>(sipConvertToType(PyList_GET_ITEM (l, i), sipType_TYPE, sipTransferObj, SIP_NOT_NONE, &state, sipIsErr));
+-
+- if (*sipIsErr)
+- {
+- sipReleaseType(t, sipType_TYPE, state);
+-
+- delete qs;
+- return 0;
+- }
+-
+- *qs << t;
+-
+- sipReleaseType(t, sipType_TYPE, state);
+- }
+-
+- *sipCppPtr = qs;
+-
+- return sipGetState(sipTransferObj);
+-%End
+-};
+-
+-
+ template <TYPE>
+ %MappedType QSet<TYPE>
+ {