aboutsummaryrefslogtreecommitdiff
path: root/devel/kdesdk3/Makefile
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2003-01-28 18:36:58 +0000
committerAlan Eldridge <alane@FreeBSD.org>2003-01-28 18:36:58 +0000
commit3c71ff78e9c867311ccd250fbafeb90640a151f4 (patch)
treeadd3e358b8ed50c1c858e55c614c22928a3549dc /devel/kdesdk3/Makefile
parentada9843b06fe8aa351a2df337c925662eba31980 (diff)
downloadports-3c71ff78e9c867311ccd250fbafeb90640a151f4.tar.gz
ports-3c71ff78e9c867311ccd250fbafeb90640a151f4.zip
update to 3.1 official release
Notes
Notes: svn path=/head/; revision=74156
Diffstat (limited to 'devel/kdesdk3/Makefile')
-rw-r--r--devel/kdesdk3/Makefile25
1 files changed, 17 insertions, 8 deletions
diff --git a/devel/kdesdk3/Makefile b/devel/kdesdk3/Makefile
index e3544857c65e..05f7723ac85e 100644
--- a/devel/kdesdk3/Makefile
+++ b/devel/kdesdk3/Makefile
@@ -17,25 +17,34 @@ MAINTAINER= kde@FreeBSD.org
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
USE_KDEBASE_VER=3
-GNU_CONFIGURE= yes
+PREFIX= ${KDE_PREFIX}
+KDE_BUILD_PLIST=yes
+
USE_BZIP2= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-MAN1= cvs2pack.1 cvsversion.1 noncvslist.1 kde-build.1
-
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-
.include <bsd.port.pre.mk>
# Doesn't compile due to C++-unsafe header sys/wait.h.
# XXX: Need to figure out when this actually happens.
.if ${OSVERSION} > 500000
-CONFIGURE_ENV= DO_NOT_COMPILE="cervisia"
-PLIST_SUB+= CERVISIA="@comment "
+WITHOUT_CERVISIA= yes
+.endif # ${OSVERSION} > 500000
+
+.if defined(WITHOUT_CERVISIA)
+DO_NOT_COMPILE+=cervisia
.else
-PLIST_SUB+= CERVISIA=""
-.endif
+PLIST_APPEND+= plist.cervisia
+.include "${FILESDIR}/manpages.mk"
+.endif # defined(WITHOUT_CERVISIA)
+
+.if defined(DO_NOT_COMPILE)
+CONFIGURE_ENV+= DO_NOT_COMPILE="${DO_NOT_COMPILE}"
+.endif # defined(DO_NOT_COMPILE)
.include <bsd.port.post.mk>