aboutsummaryrefslogtreecommitdiff
path: root/devel/kdesdk3/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-06 14:20:08 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-06 14:20:08 +0000
commit53cbaf576779525ca36755b147ba758099d24a2c (patch)
tree15b8a48c46657da86baa57457cd8c60f0d88b722 /devel/kdesdk3/Makefile
parent8cc0b5e9ad1a32c168ef02f4e7758d12288bf8e7 (diff)
downloadports-53cbaf576779525ca36755b147ba758099d24a2c.tar.gz
ports-53cbaf576779525ca36755b147ba758099d24a2c.zip
Instead, depend on it if WITH_OPTIONAL_DEPENDS is defined and ARCH is i386.
Submitted by: Simon Barner <barner@in.tum.de> Pointy hat for missing that patch while reading the mail: me
Notes
Notes: svn path=/head/; revision=115508
Diffstat (limited to 'devel/kdesdk3/Makefile')
-rw-r--r--devel/kdesdk3/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/devel/kdesdk3/Makefile b/devel/kdesdk3/Makefile
index ec66ba5f9e42..d84d501240dd 100644
--- a/devel/kdesdk3/Makefile
+++ b/devel/kdesdk3/Makefile
@@ -31,9 +31,24 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+pre-everything::
+.if !defined(WITH_OPTIONAL_DEPENDS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You may define WITH_OPTIONAL_DEPENDS (make WITH_OPTIONAL_DEPENDS=YES)"
+ @${ECHO_MSG} "to automatically build the suggested programs to complement kdesdk3."
+ @${ECHO_MSG}
+.endif
+
+# calltree is optional. It depends on valgrind, which is i386 only.
+.if defined(WITH_OPTIONAL_DEPENDS) && ${ARCH} == "i386"
+RUN_DEPENDS+= calltree:${PORTSDIR}/devel/calltree
+.endif
+
pre-configure:
@${REINPLACE_CMD} -e 's|-I$$ac_db_includes|-I${LOCALBASE}/include/db4|g' \
-e 's|ac_db_name="db"|ac_db_name="db4"|g' ${WRKSRC}/configure
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>