aboutsummaryrefslogtreecommitdiff
path: root/devel/kdevelop-php/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-01-17 20:34:33 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-01-17 20:34:33 +0000
commit8021682484f3d3093af93eb5ca1a0fdfc75f4dfb (patch)
treed35910e687ed54639e71376d3150d1fa4c31b4a7 /devel/kdevelop-php/Makefile
parent461b13f7eb3aaa1a4f000048cdb3dbb1d3d586c5 (diff)
downloadports-8021682484f3d3093af93eb5ca1a0fdfc75f4dfb.tar.gz
ports-8021682484f3d3093af93eb5ca1a0fdfc75f4dfb.zip
- Update KDevelop ports to 4.6.0 [1]
- Convert LIB_DEPENDS to new style - Use options helpers - Change DIST_SUBDIR (imitate upstream, as we do it already for KDE SC) devel/kdevelop-kde4: - Remove useless LATEST_LINK - Drop deprecated sharedmime from USE_KDE4, the port is already switched to USES=shared-mime-info Submitted by: pizzamig <luca.pizzamiglio at gmail.com> via maillist [1]
Notes
Notes: svn path=/head/; revision=340104
Diffstat (limited to 'devel/kdevelop-php/Makefile')
-rw-r--r--devel/kdevelop-php/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/devel/kdevelop-php/Makefile b/devel/kdevelop-php/Makefile
index ba17cb3331c2..cf846b3f44e9 100644
--- a/devel/kdevelop-php/Makefile
+++ b/devel/kdevelop-php/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= ${KDEVELOP_VERSION:S/4./1./}
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDEVELOP_BRANCH}/kdevelop/${KDEVELOP_VERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/kdevelop/${KDEVELOP_VERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= PHP support for KDevelop
@@ -20,22 +20,13 @@ USES= cmake gmake
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= PHPDOCS NLS
-OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+OPTIONS_DEFAULT= PHPDOCS
+OPTIONS_SUB= yes
PHPDOCS_DESC= Integrate with PHP.net documentation
+PHPDOCS_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kdevphpdocs.so:${PORTSDIR}/devel/kdevelop-php-docs
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPHPDOCS}
-RUN_DEPENDS+= ${KDE4_PREFIX}/lib/kde4/kdevphpdocs.so:${PORTSDIR}/devel/kdevelop-php-docs
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DBUILD_po:BOOL=Off
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_USES= gettext
+NLS_CMAKE_OFF= -DBUILD_po:BOOL=Off
.include <bsd.port.mk>