aboutsummaryrefslogtreecommitdiff
path: root/devel/libassa
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-14 16:11:28 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-14 16:11:28 +0000
commitb46d1b73152afed816172ad8807da6b439d7f981 (patch)
treed53c7680190f978fd79c4ab8111ce12ff23baf30 /devel/libassa
parent58883911665f54613237187ee23a8038fc0f4f82 (diff)
downloadports-b46d1b73152afed816172ad8807da6b439d7f981.tar.gz
ports-b46d1b73152afed816172ad8807da6b439d7f981.zip
- Update to 3.4.1
- Replace deprecated variables (INSTALLS_SHLIB) - Pet portlint(1) for BROKEN msg - Pass maintainership to submitter PR: ports/101945 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Notes
Notes: svn path=/head/; revision=170605
Diffstat (limited to 'devel/libassa')
-rw-r--r--devel/libassa/Makefile19
-rw-r--r--devel/libassa/distinfo6
-rw-r--r--devel/libassa/files/patch-assa-IPv4Socket.cpp11
-rw-r--r--devel/libassa/files/patch-assa-UnConUDPSocket.cpp11
-rw-r--r--devel/libassa/files/patch-assa:Connector.h11
-rw-r--r--devel/libassa/files/patch-assa:Socket.cpp19
-rw-r--r--devel/libassa/files/patch-tests_charinbuffer_test.cpp11
-rw-r--r--devel/libassa/pkg-plist128
8 files changed, 88 insertions, 128 deletions
diff --git a/devel/libassa/Makefile b/devel/libassa/Makefile
index c6f990930bba..681ca45f40a4 100644
--- a/devel/libassa/Makefile
+++ b/devel/libassa/Makefile
@@ -7,34 +7,31 @@
#
PORTNAME= libassa
-PORTVERSION= 3.3.2
-PORTREVISION= 1
+PORTVERSION= 3.4.1
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= An C++ networking library and application framework
+GNU_CONFIGURE= yes
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --disable-html-docs --disable-static
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
+PLIST_SUB= ASSA_VERSION=${PORTVERSION:R}
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s: doc : :g' ${WRKSRC}/Makefile.in
-pre-configure:
- @${CP} ${LTMAIN} ${WRKSRC}
-
.include <bsd.port.pre.mk>
.if ( ${OSVERSION} < 500000 )
-BROKEN= "Compilation fails and passing -fhuge-objects does not help"
+BROKEN= compilation fails and passing -fhuge-objects does not help
.endif
.if ${ARCH} == "sparc64"
-BROKEN= "Does not build on sparc64"
+BROKEN= does not build on sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/devel/libassa/distinfo b/devel/libassa/distinfo
index 2e36c0b2e54c..7925e7bdb9da 100644
--- a/devel/libassa/distinfo
+++ b/devel/libassa/distinfo
@@ -1,3 +1,3 @@
-MD5 (libassa-3.3.2.tar.gz) = 8465e52d9ed5a760f5dd33b14ed7aca1
-SHA256 (libassa-3.3.2.tar.gz) = 7c166b372fc338c414af6210ebd8a05d32f6eb930aa0c59993da6d4d9c63ce94
-SIZE (libassa-3.3.2.tar.gz) = 545453
+MD5 (libassa-3.4.1.tar.gz) = 0845507869d2d081c5fdb21cbf306c86
+SHA256 (libassa-3.4.1.tar.gz) = b002e3b07fbc13e878e0b27ce73b402cf8d06e36a133bed326c84e9318a4a2db
+SIZE (libassa-3.4.1.tar.gz) = 555183
diff --git a/devel/libassa/files/patch-assa-IPv4Socket.cpp b/devel/libassa/files/patch-assa-IPv4Socket.cpp
deleted file mode 100644
index d7e315a2532d..000000000000
--- a/devel/libassa/files/patch-assa-IPv4Socket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- assa/IPv4Socket.cpp.orig Mon Mar 29 12:01:10 2004
-+++ assa/IPv4Socket.cpp Mon Mar 29 12:02:18 2004
-@@ -151,7 +151,7 @@
- are not guaranteed to be aligned correctly!!!
- */
- trace_with_mask("IPv4Socket::accept",SOCKTRACE);
-- size_t length = 0;
-+ socklen_t length = 0;
- int new_fd = -1;
- SA* remote_address;
-
diff --git a/devel/libassa/files/patch-assa-UnConUDPSocket.cpp b/devel/libassa/files/patch-assa-UnConUDPSocket.cpp
deleted file mode 100644
index b87f53dadaa0..000000000000
--- a/devel/libassa/files/patch-assa-UnConUDPSocket.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- assa/UnConUDPSocket.cpp.orig Mon Mar 29 12:11:09 2004
-+++ assa/UnConUDPSocket.cpp Mon Mar 29 12:11:45 2004
-@@ -34,7 +34,7 @@
- // recvfrom() returns zeroed out address structure!!!
-
- int len;
-- size_t pa_len = peer_addr_->getLength();
-+ socklen_t pa_len = peer_addr_->getLength();
- SA* pa = peer_addr_->getAddress();
-
- len = ::recvfrom(getHandler(), buf_, size_, 0, pa,
diff --git a/devel/libassa/files/patch-assa:Connector.h b/devel/libassa/files/patch-assa:Connector.h
deleted file mode 100644
index f976484c0089..000000000000
--- a/devel/libassa/files/patch-assa:Connector.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- assa/Connector.h.orig Tue Mar 1 20:40:39 2005
-+++ assa/Connector.h Tue Mar 22 20:13:07 2005
-@@ -406,7 +406,7 @@
- int error;
- int ret;
- error = ret = errno = 0;
-- size_t n = sizeof (error);
-+ socklen_t n = sizeof (error);
-
- /** Always remove IO handler first.
- */
diff --git a/devel/libassa/files/patch-assa:Socket.cpp b/devel/libassa/files/patch-assa:Socket.cpp
deleted file mode 100644
index 84665a31d0b8..000000000000
--- a/devel/libassa/files/patch-assa:Socket.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- assa/Socket.cpp.orig Fri Jul 25 08:51:00 2003
-+++ assa/Socket.cpp Mon Mar 29 12:05:59 2004
-@@ -16,6 +16,7 @@
-
- #include <sstream>
- #include <rpc/rpc.h>
-+#include <sys/ioctl.h>
-
- #include "assa/Socket.h"
-
-@@ -190,7 +191,7 @@
- int level = SOL_SOCKET;
- bool bin = false;
-
-- size_t len = sizeof (optval);
-+ socklen_t len = sizeof (optval);
- int ret;
-
- if (rcvlowat == opt_) optname = SO_RCVLOWAT;
diff --git a/devel/libassa/files/patch-tests_charinbuffer_test.cpp b/devel/libassa/files/patch-tests_charinbuffer_test.cpp
new file mode 100644
index 000000000000..cad5bf51c248
--- /dev/null
+++ b/devel/libassa/files/patch-tests_charinbuffer_test.cpp
@@ -0,0 +1,11 @@
+--- tests/charinbuffer_test.cpp.orig Sat Aug 12 23:02:38 2006
++++ tests/charinbuffer_test.cpp Sat Aug 12 23:03:00 2006
+@@ -596,7 +596,7 @@
+ IPv4Socket& s = *this;
+
+ if (state () == Task2::start) {
+- Assure_exit (s.write (&REQUEST [m_idx], 1) == 1);
++ Assure_exit (s.write (&((REQUEST.c_str())[m_idx]), 1) == 1);
+ s << flush;
+ DL((APP,"<== Sent \"%c\" to Loopback\n", REQUEST [m_idx] ));
+
diff --git a/devel/libassa/pkg-plist b/devel/libassa/pkg-plist
index 4c1469f15b59..639c3955c67f 100644
--- a/devel/libassa/pkg-plist
+++ b/devel/libassa/pkg-plist
@@ -1,63 +1,67 @@
bin/assa-genesis
-include/assa/Acceptor.h
-include/assa/Address.h
-include/assa/Assa.h
-include/assa/Assert.h
-include/assa/AutoPtr.h
-include/assa/CharInBuffer.h
-include/assa/CmdLineOpts.h
-include/assa/CommonUtils.h
-include/assa/ConUDPSocket.h
-include/assa/Connector.h
-include/assa/Destroyer.h
-include/assa/EventHandler.h
-include/assa/FdSet.h
-include/assa/FileLogger.h
-include/assa/Fork.h
-include/assa/GenServer.h
-include/assa/Handlers.h
-include/assa/INETAddress.h
-include/assa/IPv4Socket.h
-include/assa/IdSet.h
-include/assa/IniFile.h
-include/assa/LogMask.h
-include/assa/Logger.h
-include/assa/Logger_Impl.h
-include/assa/MaskSet.h
-include/assa/MemDump.h
-include/assa/PidFileLock.h
-include/assa/Pipe.h
-include/assa/PriorityQueue.h
-include/assa/PriorityQueue_Heap.h
-include/assa/PriorityQueue_Impl.h
-include/assa/PriorityQueue_STLPQ.h
-include/assa/Reactor.h
-include/assa/Regexp.h
-include/assa/RemoteLogger.h
-include/assa/Repository.h
-include/assa/Semaphore.h
-include/assa/ServiceHandler.h
-include/assa/SigAction.h
-include/assa/SigHandler.h
-include/assa/SigHandlers.h
-include/assa/SigHandlersList.h
-include/assa/SigSet.h
-include/assa/Singleton.h
-include/assa/Socket.h
-include/assa/Socketbuf.h
-include/assa/StdOutLogger.h
-include/assa/Streambuf.h
-include/assa/TimeVal.h
-include/assa/Timer.h
-include/assa/TimerCountdown.h
-include/assa/TimerQueue.h
-include/assa/UDPSocket.h
-include/assa/UNIXAddress.h
-include/assa/UnConUDPSocket.h
-include/assa/xdrIOBuffer.h
-lib/libassa.a
-lib/libassa.la
-lib/libassa.so
-lib/libassa.so.3
-libdata/pkgconfig/assa.pc
-@dirrm include/assa
+include/assa-%%ASSA_VERSION%%/assa/Acceptor.h
+include/assa-%%ASSA_VERSION%%/assa/Address.h
+include/assa-%%ASSA_VERSION%%/assa/Assa.h
+include/assa-%%ASSA_VERSION%%/assa/Assure.h
+include/assa-%%ASSA_VERSION%%/assa/AutoPtr.h
+include/assa-%%ASSA_VERSION%%/assa/CharInBuffer.h
+include/assa-%%ASSA_VERSION%%/assa/CmdLineOpts.h
+include/assa-%%ASSA_VERSION%%/assa/CommonUtils.h
+include/assa-%%ASSA_VERSION%%/assa/ConUDPSocket.h
+include/assa-%%ASSA_VERSION%%/assa/Connector.h
+include/assa-%%ASSA_VERSION%%/assa/Destroyer.h
+include/assa-%%ASSA_VERSION%%/assa/EventHandler.h
+include/assa-%%ASSA_VERSION%%/assa/FdSet.h
+include/assa-%%ASSA_VERSION%%/assa/FileLogger.h
+include/assa-%%ASSA_VERSION%%/assa/Fork.h
+include/assa-%%ASSA_VERSION%%/assa/GenServer.h
+include/assa-%%ASSA_VERSION%%/assa/Handlers.h
+include/assa-%%ASSA_VERSION%%/assa/INETAddress.h
+include/assa-%%ASSA_VERSION%%/assa/IPv4Socket.h
+include/assa-%%ASSA_VERSION%%/assa/IdSet.h
+include/assa-%%ASSA_VERSION%%/assa/IniFile.h
+include/assa-%%ASSA_VERSION%%/assa/LogMask.h
+include/assa-%%ASSA_VERSION%%/assa/Logger.h
+include/assa-%%ASSA_VERSION%%/assa/Logger_Impl.h
+include/assa-%%ASSA_VERSION%%/assa/MaskSet.h
+include/assa-%%ASSA_VERSION%%/assa/MemDump.h
+include/assa-%%ASSA_VERSION%%/assa/PidFileLock.h
+include/assa-%%ASSA_VERSION%%/assa/Pipe.h
+include/assa-%%ASSA_VERSION%%/assa/PriorityQueue.h
+include/assa-%%ASSA_VERSION%%/assa/PriorityQueue_Heap.h
+include/assa-%%ASSA_VERSION%%/assa/PriorityQueue_Impl.h
+include/assa-%%ASSA_VERSION%%/assa/PriorityQueue_STLPQ.h
+include/assa-%%ASSA_VERSION%%/assa/Reactor.h
+include/assa-%%ASSA_VERSION%%/assa/Regexp.h
+include/assa-%%ASSA_VERSION%%/assa/RemoteLogger.h
+include/assa-%%ASSA_VERSION%%/assa/Repository.h
+include/assa-%%ASSA_VERSION%%/assa/Semaphore.h
+include/assa-%%ASSA_VERSION%%/assa/ServiceHandler.h
+include/assa-%%ASSA_VERSION%%/assa/SigAction.h
+include/assa-%%ASSA_VERSION%%/assa/SigHandler.h
+include/assa-%%ASSA_VERSION%%/assa/SigHandlers.h
+include/assa-%%ASSA_VERSION%%/assa/SigHandlersList.h
+include/assa-%%ASSA_VERSION%%/assa/SigSet.h
+include/assa-%%ASSA_VERSION%%/assa/Singleton.h
+include/assa-%%ASSA_VERSION%%/assa/Socket.h
+include/assa-%%ASSA_VERSION%%/assa/Socketbuf.h
+include/assa-%%ASSA_VERSION%%/assa/StdOutLogger.h
+include/assa-%%ASSA_VERSION%%/assa/Streambuf.h
+include/assa-%%ASSA_VERSION%%/assa/TimeVal.h
+include/assa-%%ASSA_VERSION%%/assa/Timer.h
+include/assa-%%ASSA_VERSION%%/assa/TimerCountdown.h
+include/assa-%%ASSA_VERSION%%/assa/TimerQueue.h
+include/assa-%%ASSA_VERSION%%/assa/UDPSocket.h
+include/assa-%%ASSA_VERSION%%/assa/UNIXAddress.h
+include/assa-%%ASSA_VERSION%%/assa/UnConUDPSocket.h
+include/assa-%%ASSA_VERSION%%/assa/XDRHack.h
+include/assa-%%ASSA_VERSION%%/assa/xdrIOBuffer.h
+lib/libassa-%%ASSA_VERSION%%.a
+lib/libassa-%%ASSA_VERSION%%.la
+lib/libassa-%%ASSA_VERSION%%.so
+lib/libassa-%%ASSA_VERSION%%.so.4
+@comment For non-standard prefixes
+@unexec rm -f %D/libdata/ldconfig/libassa 2>/dev/null || true
+libdata/pkgconfig/assa-%%ASSA_VERSION%%.pc
+@dirrm include/assa-%%ASSA_VERSION%%/assa
+@dirrm include/assa-%%ASSA_VERSION%%