aboutsummaryrefslogtreecommitdiff
path: root/devel/libbfd/Makefile
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2004-12-27 22:58:17 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2004-12-27 22:58:17 +0000
commit9b9c4750c17c7969fcc0a3469b59fa6001c053ed (patch)
tree60374ce55097d84a3300b719af42889be1d6b0a1 /devel/libbfd/Makefile
parenta9d1923fb02dc87dd3392dd036ea70a5128589f9 (diff)
downloadports-9b9c4750c17c7969fcc0a3469b59fa6001c053ed.tar.gz
ports-9b9c4750c17c7969fcc0a3469b59fa6001c053ed.zip
Upgrade to binutils 2.15.
Revert from USE_LIBTOOL to binutil's own libtool, as libtool13 could not grok the --without-pic option, and the configure script is not prepared to handle libtool15 (yet) which in turn could have understood --without-pic. Sigh. At least, that way we can avoid the overhead of building all the unneeded shared libs. Still, libtool insists on installing libbfd.la. As this file is really small, I give in, and added it to pkg-plist.
Notes
Notes: svn path=/head/; revision=125296
Diffstat (limited to 'devel/libbfd/Makefile')
-rw-r--r--devel/libbfd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/libbfd/Makefile b/devel/libbfd/Makefile
index 6ac4e291f7c0..273f2ee3ac3a 100644
--- a/devel/libbfd/Makefile
+++ b/devel/libbfd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libbfd
-PORTVERSION= 2.14
+PORTVERSION= 2.15
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -19,16 +19,16 @@ WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}/bfd
USE_BZIP2= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-install-libbfd \
--enable-commonbfdlib \
--disable-nls \
+ --without-pic \
--enable-targets=all
.if (${MACHINE_ARCH} == "amd64")
CONFIGURE_ARGS+= --host=x86_64-portbld-freebsd${OSREL}
.endif
-USE_LIBTOOL_VER=13
-
INFO= bfd
.include <bsd.port.pre.mk>