aboutsummaryrefslogtreecommitdiff
path: root/devel/libbinio
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-09 20:13:31 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-09 20:13:31 +0000
commitdfc8eb9877f48daf01d813c9bab19f3352a6fefe (patch)
tree8fe9abc2498070ff61851b9a925655f45eaef4b3 /devel/libbinio
parent08e0bed4301982f5cf6004718b09ab0169fdfc20 (diff)
downloadports-dfc8eb9877f48daf01d813c9bab19f3352a6fefe.tar.gz
ports-dfc8eb9877f48daf01d813c9bab19f3352a6fefe.zip
The binary I/O stream class library presents a platform-independent way to
access binary data streams in C++. The library is hardware independent in the form that it transparently converts between the different forms of machine-internal binary data representation. It further employs no special I/O protocol and can be used on arbitrary binary data sources. WWW: http://libbinio.sourceforge.net/ PR: ports/80727 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=134945
Diffstat (limited to 'devel/libbinio')
-rw-r--r--devel/libbinio/Makefile33
-rw-r--r--devel/libbinio/distinfo2
-rw-r--r--devel/libbinio/pkg-descr14
-rw-r--r--devel/libbinio/pkg-plist7
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/libbinio/Makefile b/devel/libbinio/Makefile
new file mode 100644
index 000000000000..369beb48b150
--- /dev/null
+++ b/devel/libbinio/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libbinio
+# Date created: 10 August 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbinio
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Binary I/O stream class library
+
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS\ =\).*|\1 src|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/libbinio/distinfo b/devel/libbinio/distinfo
new file mode 100644
index 000000000000..755d5da543c7
--- /dev/null
+++ b/devel/libbinio/distinfo
@@ -0,0 +1,2 @@
+MD5 (libbinio-1.3.tar.gz) = 2bee4db14e3b3ef45a58291b7c9b5898
+SIZE (libbinio-1.3.tar.gz) = 434702
diff --git a/devel/libbinio/pkg-descr b/devel/libbinio/pkg-descr
new file mode 100644
index 000000000000..943899aaf6cc
--- /dev/null
+++ b/devel/libbinio/pkg-descr
@@ -0,0 +1,14 @@
+The binary I/O stream class library presents a platform-independent way to
+access binary data streams in C++.
+
+The library is hardware independent in the form that it transparently
+converts between the different forms of machine-internal binary data
+representation.
+
+It further employs no special I/O protocol and can be used on arbitrary
+binary data sources.
+
+WWW: http://libbinio.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/devel/libbinio/pkg-plist b/devel/libbinio/pkg-plist
new file mode 100644
index 000000000000..4ca7f6b1ea4a
--- /dev/null
+++ b/devel/libbinio/pkg-plist
@@ -0,0 +1,7 @@
+include/binfile.h
+include/binio.h
+include/binstr.h
+include/binwrap.h
+lib/libbinio.a
+lib/libbinio.so
+lib/libbinio.so.1