aboutsummaryrefslogtreecommitdiff
path: root/devel/libbonobo
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 08:17:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 08:17:54 +0000
commit733a797267565d94dce80b6d18897644fabd5898 (patch)
tree9fb91cd8d0331979a3ec6294bbbd185304cb185e /devel/libbonobo
parent800004803b57bdb5c1c7145f734469b475ae50c9 (diff)
downloadports-733a797267565d94dce80b6d18897644fabd5898.tar.gz
ports-733a797267565d94dce80b6d18897644fabd5898.zip
- Update to 1.115.0 (version found in the GNOME2 beta4);
- use USE_LIBTOOL.
Notes
Notes: svn path=/head/; revision=58152
Diffstat (limited to 'devel/libbonobo')
-rw-r--r--devel/libbonobo/Makefile6
-rw-r--r--devel/libbonobo/distinfo2
-rw-r--r--devel/libbonobo/files/patch-ltmain.sh45
3 files changed, 4 insertions, 49 deletions
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index 39b81ce26573..c3b3772c7089 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libbonobo
-PORTVERSION= 1.113.0
+PORTVERSION= 1.115.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta4
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -20,7 +20,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -pthread"
diff --git a/devel/libbonobo/distinfo b/devel/libbonobo/distinfo
index 17034cbb021b..1b695b2de518 100644
--- a/devel/libbonobo/distinfo
+++ b/devel/libbonobo/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libbonobo-1.113.0.tar.bz2) = 931f66d92ae6463a351a7e8e0603cd0e
+MD5 (gnome2/libbonobo-1.115.0.tar.bz2) = 57b7e361bf2c1e87d20292e21f1a65b5
diff --git a/devel/libbonobo/files/patch-ltmain.sh b/devel/libbonobo/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/devel/libbonobo/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"