aboutsummaryrefslogtreecommitdiff
path: root/devel/libcapsinetwork
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-07-13 04:25:21 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-07-13 04:25:21 +0000
commit9ae37e59383bec1f864f019c12b326fd555375d6 (patch)
tree4b7a66972ffd104173fa322e97822314d9a1e921 /devel/libcapsinetwork
parentf172aa69269016623bbbd10758cc2fb4a98facc4 (diff)
downloadports-9ae37e59383bec1f864f019c12b326fd555375d6.tar.gz
ports-9ae37e59383bec1f864f019c12b326fd555375d6.zip
Update to 0.1.1.
Notes
Notes: svn path=/head/; revision=62889
Diffstat (limited to 'devel/libcapsinetwork')
-rw-r--r--devel/libcapsinetwork/Makefile7
-rw-r--r--devel/libcapsinetwork/distinfo2
-rw-r--r--devel/libcapsinetwork/files/patch-listener.cc12
-rw-r--r--devel/libcapsinetwork/files/patch-ltmain.sh35
-rw-r--r--devel/libcapsinetwork/pkg-plist13
5 files changed, 56 insertions, 13 deletions
diff --git a/devel/libcapsinetwork/Makefile b/devel/libcapsinetwork/Makefile
index 10f9d17956ec..7b1ab37abcda 100644
--- a/devel/libcapsinetwork/Makefile
+++ b/devel/libcapsinetwork/Makefile
@@ -6,17 +6,14 @@
#
PORTNAME= libcapsinetwork
-PORTVERSION= 0.0.13
+PORTVERSION= 0.1.1
CATEGORIES= devel net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= petef@FreeBSD.org
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-post-patch:
- @${PERL} -pi -e 's!CC!CXX!g; s!CXX=!CXX?=!; s!CFLAGS=!CFLAGS+=!; \
- s!/usr/local!${PREFIX}!' ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/devel/libcapsinetwork/distinfo b/devel/libcapsinetwork/distinfo
index bc45ad4f8b2c..a3132e8b78e8 100644
--- a/devel/libcapsinetwork/distinfo
+++ b/devel/libcapsinetwork/distinfo
@@ -1 +1 @@
-MD5 (libcapsinetwork-0.0.13.tar.gz) = 9180719a119d79fe5f6b0deefa0ac8da
+MD5 (libcapsinetwork-0.1.1.tar.gz) = 828a0cb9ceb7c8d6ad3d29371942c4c6
diff --git a/devel/libcapsinetwork/files/patch-listener.cc b/devel/libcapsinetwork/files/patch-listener.cc
new file mode 100644
index 000000000000..e29d42ae5f19
--- /dev/null
+++ b/devel/libcapsinetwork/files/patch-listener.cc
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- listener.cc.orig Sat Jul 13 00:06:34 2002
++++ listener.cc Sat Jul 13 00:06:36 2002
+@@ -14,6 +14,7 @@
+ // the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ // Boston, MA 02111-1307, USA.
+
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/devel/libcapsinetwork/files/patch-ltmain.sh b/devel/libcapsinetwork/files/patch-ltmain.sh
new file mode 100644
index 000000000000..e689847f16a5
--- /dev/null
+++ b/devel/libcapsinetwork/files/patch-ltmain.sh
@@ -0,0 +1,35 @@
+$FreeBSD$
+
+--- ltmain.sh.orig Thu Nov 22 05:43:58 2001
++++ ltmain.sh Fri Dec 7 07:18:03 2001
+@@ -944,6 +944,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
+@@ -2408,6 +2409,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4175,10 +4179,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libcapsinetwork/pkg-plist b/devel/libcapsinetwork/pkg-plist
index 57b47d69b947..8d37c8b62c45 100644
--- a/devel/libcapsinetwork/pkg-plist
+++ b/devel/libcapsinetwork/pkg-plist
@@ -1,7 +1,6 @@
-include/libcapsi_network/listener.h
-include/libcapsi_network/server.h
-include/libcapsi_network/socket.h
-lib/libcapsi_network.so
-lib/libcapsi_network.so.0
-lib/libcapsi_network.so.0.0.13
-@dirrm include/libcapsi_network
+include/libcapsinetwork/listener.h
+include/libcapsinetwork/socket.h
+lib/libcapsinetwork.a
+lib/libcapsinetwork.so
+lib/libcapsinetwork.so.0
+@dirrm include/libcapsinetwork