aboutsummaryrefslogtreecommitdiff
path: root/devel/libccid
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /devel/libccid
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'devel/libccid')
-rw-r--r--devel/libccid/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index b88f04c8560a..482a037378ba 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -23,10 +23,10 @@ GNU_CONFIGURE= yes
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --enable-usbdropdir=${PREFIX}/lib/pcsc/drivers \
--enable-ccidtwindir=${PREFIX}/lib/pcsc/drivers/serial
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
- LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
PLIST_SUB= VER=${PORTVERSION}