aboutsummaryrefslogtreecommitdiff
path: root/devel/libcfg
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel/libcfg
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
downloadports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.tar.gz
ports-36aec2ee4d4789c8cc6ad940264e1a101d8a7977.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299101
Diffstat (limited to 'devel/libcfg')
-rw-r--r--devel/libcfg/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/devel/libcfg/Makefile b/devel/libcfg/Makefile
index df84df804838..51954d63e2a7 100644
--- a/devel/libcfg/Makefile
+++ b/devel/libcfg/Makefile
@@ -34,12 +34,11 @@ INSTALL_TARGET+= install-man
PORTDOCS= *
-OPTIONS= EXAMPLES "Install examples" off \
- HTMLDOCS "Install html documentation" off
+OPTIONS_DEFINE= EXAMPLES DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
PLIST_SUB+= EXAMPLES=""
.else
PLIST_SUB+= EXAMPLES="@comment "
@@ -50,21 +49,19 @@ CFLAGS+= -fPIC
.endif
post-install:
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/doc/examples/example.* ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for FILE in AUTHORS README TODO
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
-.if defined(WITH_HTMLDOCS)
@${MKDIR} ${DOCSDIR}/html
@for FILE in ${WRKSRC}/doc/html/*; do \
${INSTALL_DATA} $${FILE} ${DOCSDIR}/html; \
done
.endif
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>