aboutsummaryrefslogtreecommitdiff
path: root/devel/libcheck
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-04-07 04:09:47 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-04-07 04:09:47 +0000
commit10404459710cdd7890b71f697c05e1f4de398125 (patch)
treeab23d2cb5d98fcef801c651284c5a06d77a78c18 /devel/libcheck
parentbfd6a2d349d40ad133a4c21f5aff517501ba3b4b (diff)
downloadports-10404459710cdd7890b71f697c05e1f4de398125.tar.gz
ports-10404459710cdd7890b71f697c05e1f4de398125.zip
- USE_LDCONFIG to install shared libs.
- Use INFO instead of install-info in pkg-plist. - Patch to install into libdata/pkgconfig instead of lib/pkgconfig. - Fix and sort pkg-plist. PR: ports/121746 Submitted by: myself Approved by: gabor (mentor), mikeh (maintainer)
Notes
Notes: svn path=/head/; revision=210700
Diffstat (limited to 'devel/libcheck')
-rw-r--r--devel/libcheck/Makefile7
-rw-r--r--devel/libcheck/files/patch-Makefile.in12
-rw-r--r--devel/libcheck/pkg-plist54
3 files changed, 38 insertions, 35 deletions
diff --git a/devel/libcheck/Makefile b/devel/libcheck/Makefile
index cb6182686bc1..6e4d8346bb55 100644
--- a/devel/libcheck/Makefile
+++ b/devel/libcheck/Makefile
@@ -8,9 +8,7 @@
PORTNAME= libcheck
PORTVERSION= 0.9.5
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= check
-DISTNAME= check-${PORTVERSION}
+MASTER_SITES= SF/check
MAINTAINER= mikeh@FreeBSD.org
COMMENT= A unit test framework for C
@@ -18,8 +16,11 @@ COMMENT= A unit test framework for C
GNU_CONFIGURE= yes
PLIST_SUB= CHECK_VERSION=${PORTVERSION}
USE_GMAKE= yes
+USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/check-${PORTVERSION}
EXAMPLESDIR= ${PREFIX}/share/examples/check-${PORTVERSION}
+INFO= check
+
.include <bsd.port.mk>
diff --git a/devel/libcheck/files/patch-Makefile.in b/devel/libcheck/files/patch-Makefile.in
index 5d83b9a308b2..fece711eb6fd 100644
--- a/devel/libcheck/files/patch-Makefile.in
+++ b/devel/libcheck/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Nov 21 18:19:11 2006
-+++ Makefile.in Fri Dec 1 21:41:18 2006
+--- Makefile.in.old 2008-04-03 00:51:55.000000000 -0300
++++ Makefile.in 2008-04-03 00:52:21.000000000 -0300
@@ -38,8 +38,8 @@
host_triplet = @host@
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
@@ -11,7 +11,7 @@
build-aux/compile build-aux/config.guess build-aux/config.sub \
build-aux/depcomp build-aux/install-sh build-aux/ltmain.sh \
build-aux/mdate-sh build-aux/missing build-aux/texinfo.tex
-@@ -203,8 +203,8 @@
+@@ -203,11 +203,11 @@
ChangeLog.bak
EXTRA_DIST = SVNChangeLog ChangeLogOld check.pc.in $(m4data_DATA)
@@ -21,4 +21,8 @@
+doc_DATA = SVNChangeLog ChangeLog ChangeLogOld NEWS README
m4datadir = $(datadir)/aclocal
m4data_DATA = check.m4
- pcdatadir = $(libdir)/pkgconfig
+-pcdatadir = $(libdir)/pkgconfig
++pcdatadir = $(prefix)/libdata/pkgconfig
+ pcdata_DATA = check.pc
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/devel/libcheck/pkg-plist b/devel/libcheck/pkg-plist
index d29bec6a59af..92f2b813e29a 100644
--- a/devel/libcheck/pkg-plist
+++ b/devel/libcheck/pkg-plist
@@ -1,39 +1,37 @@
include/check.h
-info/check.info
lib/libcheck.so.0
lib/libcheck.so
lib/libcheck.la
lib/libcheck.a
-lib/pkgconfig/check.pc
-@dirrm lib/pkgconfig
+libdata/pkgconfig/check.pc
share/aclocal/check.m4
-%%EXAMPLESDIR%%/Makefile.am
-%%EXAMPLESDIR%%/README
-%%EXAMPLESDIR%%/configure.ac
-%%EXAMPLESDIR%%/src/Makefile.am
-%%EXAMPLESDIR%%/src/main.c
-%%EXAMPLESDIR%%/src/money.c
-%%EXAMPLESDIR%%/src/money.h
-%%EXAMPLESDIR%%/src/money.1.h
-%%EXAMPLESDIR%%/src/money.2.h
-%%EXAMPLESDIR%%/src/money.1.c
-%%EXAMPLESDIR%%/src/money.3.c
-%%EXAMPLESDIR%%/src/money.4.c
-%%EXAMPLESDIR%%/src/money.5.c
-%%EXAMPLESDIR%%/src/money.6.c
-@dirrm %%EXAMPLESDIR%%/src
-%%EXAMPLESDIR%%/tests/Makefile.am
-%%EXAMPLESDIR%%/tests/check_money.c
-%%EXAMPLESDIR%%/tests/check_money.1.c
-%%EXAMPLESDIR%%/tests/check_money.2.c
-%%EXAMPLESDIR%%/tests/check_money.3.c
-%%EXAMPLESDIR%%/tests/check_money.6.c
-%%EXAMPLESDIR%%/tests/check_money.7.c
-@dirrm %%EXAMPLESDIR%%/tests
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile.am
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/configure.ac
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/Makefile.am
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/main.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.1.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.2.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.1.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.3.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.4.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.5.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/src/money.6.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/Makefile.am
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/check_money.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/check_money.1.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/check_money.2.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/check_money.3.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/check_money.6.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tests/check_money.7.c
%%PORTDOCS%%%%DOCSDIR%%/SVNChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/ChangeLogOld
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-@dirrm %%PORTDOCS%%%%DOCSDIR%%
-@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/src
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/tests
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%