aboutsummaryrefslogtreecommitdiff
path: root/devel/libcheck
diff options
context:
space:
mode:
authorMike Heffner <mikeh@FreeBSD.org>2003-12-05 00:46:02 +0000
committerMike Heffner <mikeh@FreeBSD.org>2003-12-05 00:46:02 +0000
commit600301e7c10baa7937938a47a16b196e8be2a226 (patch)
tree54ace08a6d14a2c6bbd04dd40c70420082608bb3 /devel/libcheck
parent50011ebbc24e57dd4e37c7f9df7211dab7d09397 (diff)
downloadports-600301e7c10baa7937938a47a16b196e8be2a226.tar.gz
ports-600301e7c10baa7937938a47a16b196e8be2a226.zip
Add libcheck 0.8.4, a unit test framework for C.
PR: 59280 Submitted by: mikeh@FreeBSD.org
Notes
Notes: svn path=/head/; revision=95085
Diffstat (limited to 'devel/libcheck')
-rw-r--r--devel/libcheck/Makefile20
-rw-r--r--devel/libcheck/distinfo1
-rw-r--r--devel/libcheck/pkg-descr24
-rw-r--r--devel/libcheck/pkg-plist16
4 files changed, 61 insertions, 0 deletions
diff --git a/devel/libcheck/Makefile b/devel/libcheck/Makefile
new file mode 100644
index 000000000000..9a58fc98d934
--- /dev/null
+++ b/devel/libcheck/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: libcheck
+# Date created: December 4, 2003
+# Whom: mikeh@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libcheck
+PORTVERSION= 0.8.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= check
+DISTNAME= check-${PORTVERSION}
+
+MAINTAINER= mikeh@FreeBSD.org
+COMMENT= A unit test framework for C
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libcheck/distinfo b/devel/libcheck/distinfo
new file mode 100644
index 000000000000..86b1f2d833bd
--- /dev/null
+++ b/devel/libcheck/distinfo
@@ -0,0 +1 @@
+MD5 (check-0.8.4.tar.gz) = 2869c0fb14b9e277931dbe3df22de1ab
diff --git a/devel/libcheck/pkg-descr b/devel/libcheck/pkg-descr
new file mode 100644
index 000000000000..77296e616a9d
--- /dev/null
+++ b/devel/libcheck/pkg-descr
@@ -0,0 +1,24 @@
+Check is a unit test framework for C. It features a simple interface
+for defining unit tests, putting little in the way of the
+developer. Tests are run in a separate address space, so Check can
+catch both assertion failures and code errors that cause segmentation
+faults or other signals. The output from unit tests can be used within
+source code editors and IDEs.
+
+Check was inspired by similar frameworks that currently exist for most
+programming languages; the most famous example being JUnit for Java
+(www.junit.org). There is a list of unit test frameworks for multiple
+languages at www.xprogramming.com/software.htm . Unit testing has a
+long history as part of formal quality assurance methodologies, but
+has recently been associated with the lightweight methodology called
+Extreme Programming. In that methodology, the characteristic practice
+involves interspersing unit test writing with coding (" test a little,
+code a little"). While the incremental unit test/code approach is
+indispensable to Extreme Programming, it is also applicable, and
+perhaps indispensable, outside of that methodology.
+
+
+WWW: http://check.sourceforge.net
+
+- Mike
+mikeh@FreeBSD.org
diff --git a/devel/libcheck/pkg-plist b/devel/libcheck/pkg-plist
new file mode 100644
index 000000000000..0b1975e018d6
--- /dev/null
+++ b/devel/libcheck/pkg-plist
@@ -0,0 +1,16 @@
+include/check.h
+lib/libcheck.a
+share/aclocal/check.m4
+share/doc/check-0.8.4/COPYING
+share/doc/check-0.8.4/ChangeLog
+share/doc/check-0.8.4/ChangeLogOld
+share/doc/check-0.8.4/NEWS
+share/doc/check-0.8.4/README
+share/doc/check-0.8.4/examples/Makefile.am.money
+share/doc/check-0.8.4/examples/check_money.c
+share/doc/check-0.8.4/examples/configure.in.money
+share/doc/check-0.8.4/examples/money.c
+share/doc/check-0.8.4/examples/money.h
+share/doc/check-0.8.4/tutorial.lyx
+@dirrm share/doc/check-0.8.4/examples
+@dirrm share/doc/check-0.8.4