aboutsummaryrefslogtreecommitdiff
path: root/devel/libcheck
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-02-01 21:53:46 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-02-01 21:53:46 +0000
commit696ef88dadeef8f13ffdf8f50e2c839c7377c211 (patch)
tree0efec895903691a071eb7dcc341c53d0cb879459 /devel/libcheck
parent65613c73262957a815138370dbef2c4ecaefd54c (diff)
downloadports-696ef88dadeef8f13ffdf8f50e2c839c7377c211.tar.gz
ports-696ef88dadeef8f13ffdf8f50e2c839c7377c211.zip
- Update to 0.9.9
Notes
Notes: svn path=/head/; revision=311402
Diffstat (limited to 'devel/libcheck')
-rw-r--r--devel/libcheck/Makefile37
-rw-r--r--devel/libcheck/distinfo4
-rw-r--r--devel/libcheck/files/patch-Makefile.in33
-rw-r--r--devel/libcheck/files/patch-doc-Makefile.in26
-rw-r--r--devel/libcheck/pkg-plist1
5 files changed, 24 insertions, 77 deletions
diff --git a/devel/libcheck/Makefile b/devel/libcheck/Makefile
index 0a9159b04158..fda3ac23456b 100644
--- a/devel/libcheck/Makefile
+++ b/devel/libcheck/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: libcheck
-# Date created: December 4, 2003
-# Whom: mikeh@FreeBSD.org
-#
+# Created by: mikeh@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= libcheck
-PORTVERSION= 0.9.8
+PORTVERSION= 0.9.9
CATEGORIES= devel
MASTER_SITES= SF/check/check/${PORTVERSION}
DISTNAME= check-${PORTVERSION}
@@ -14,31 +10,40 @@ DISTNAME= check-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A unit test framework for C
+LICENSE= LGPL21
+
OPTIONS_DEFINE= DOCS EXAMPLES
+#CONFIGURE_ARGS= --docdir=${DOCSDIR}
GNU_CONFIGURE= yes
-PLIST_SUB= CHECK_VERSION=${PORTVERSION}
USE_GMAKE= yes
USE_LDCONFIG= yes
-DOCSDIR= ${PREFIX}/share/doc/check-${PORTVERSION}
-EXAMPLESDIR= ${PREFIX}/share/examples/check-${PORTVERSION}
+#DOCSDIR= ${PREFIX}/share/doc/check
+#EXAMPLESDIR= ${PREFIX}/share/examples/check
INFO= check
+MAN1= checkmk.1
.include <bsd.port.options.mk>
post-patch:
-.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} \
- -e '/^install-data-am:/ s/ install-docDATA//' \
- ${WRKSRC}/Makefile.in
+ -e 's|COPYING.LESSER||' \
+ -e '/^docdir = / s|$$(PACKAGE)|${PORTNAME}|' \
+ -e '/^pcdatadir = / s|(libdir)/pkgconfig|(exec_prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} \
+ -e '/^exampledir = / s|(docdir)/example|(datadir)/examples/${PORTNAME}|' \
+ -e '/^example[a-z]*dir = / s|(docdir)/example/|(exampledir)/|' \
+ ${WRKSRC}/doc/Makefile.in
+.if empty(PORT_OPTIONS:MDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s| install-docDATA||' ${WRKSRC}/Makefile.in
.endif
.if empty(PORT_OPTIONS:MEXAMPLES)
@${REINPLACE_CMD} \
- -e '/^install-data-am:/ s/ install-exampleDATA//' \
- -e '/^install-data-am:/ s/ install-examplesrcDATA//' \
- -e '/install-exampletestsDATA/ s/install-exampletestsDATA//' \
- ${WRKSRC}/doc/Makefile.in
+ -e '/^install-data-am:/ s| install-exampleDATA install-examplesrcDATA||' \
+ -e 's|install-exampletestsDATA ||' \
+ ${WRKSRC}/doc/Makefile.in
.endif
.include <bsd.port.mk>
diff --git a/devel/libcheck/distinfo b/devel/libcheck/distinfo
index 53a041ae47bc..7897269b7c45 100644
--- a/devel/libcheck/distinfo
+++ b/devel/libcheck/distinfo
@@ -1,2 +1,2 @@
-SHA256 (check-0.9.8.tar.gz) = 82acf956bb07584ffea2bf04d5989fe939c3e74ecf93133a21037fd0f7996a7f
-SIZE (check-0.9.8.tar.gz) = 558943
+SHA256 (check-0.9.9.tar.gz) = 1a7a9abb9d051e1b9da4149ce651436a29e20135a40bdb202bd7b2bef3878ac9
+SIZE (check-0.9.9.tar.gz) = 602679
diff --git a/devel/libcheck/files/patch-Makefile.in b/devel/libcheck/files/patch-Makefile.in
deleted file mode 100644
index 8426e771c49e..000000000000
--- a/devel/libcheck/files/patch-Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.in.orig 2008-12-29 22:07:02.000000000 +0800
-+++ Makefile.in 2009-01-07 09:00:25.456715144 +0800
-@@ -36,7 +36,7 @@
- DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
- $(srcdir)/Makefile.in $(srcdir)/check.pc.in \
- $(srcdir)/config.h.in $(top_srcdir)/configure AUTHORS \
-- COPYING.LESSER ChangeLog INSTALL NEWS THANKS TODO \
-+ ChangeLog INSTALL NEWS THANKS TODO \
- build-aux/compile build-aux/config.guess build-aux/config.sub \
- build-aux/depcomp build-aux/install-sh build-aux/ltmain.sh \
- build-aux/mdate-sh build-aux/missing build-aux/texinfo.tex
-@@ -174,7 +174,7 @@
- builddir = @builddir@
- datadir = @datadir@
- datarootdir = @datarootdir@
--docdir = $(datadir)/doc/$(PACKAGE)
-+docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
- dvidir = @dvidir@
- exec_prefix = @exec_prefix@
- host = @host@
-@@ -211,10 +211,10 @@
- ChangeLog.bak
-
- EXTRA_DIST = SVNChangeLog ChangeLogOld check.pc.in $(m4data_DATA)
--doc_DATA = SVNChangeLog ChangeLog ChangeLogOld NEWS README COPYING.LESSER
-+doc_DATA = SVNChangeLog ChangeLog ChangeLogOld NEWS README
- m4datadir = $(datadir)/aclocal
- m4data_DATA = check.m4
--pcdatadir = $(libdir)/pkgconfig
-+pcdatadir = $(exec_prefix)/libdata/pkgconfig
- pcdata_DATA = check.pc
- ACLOCAL_AMFLAGS = -I m4
- all: config.h
diff --git a/devel/libcheck/files/patch-doc-Makefile.in b/devel/libcheck/files/patch-doc-Makefile.in
deleted file mode 100644
index f7b46c43c15b..000000000000
--- a/devel/libcheck/files/patch-doc-Makefile.in
+++ /dev/null
@@ -1,26 +0,0 @@
---- doc/Makefile.in.orig 2008-12-29 22:19:19.000000000 +0800
-+++ doc/Makefile.in 2009-01-07 09:04:30.205795824 +0800
-@@ -159,7 +159,7 @@
- builddir = @builddir@
- datadir = @datadir@
- datarootdir = @datarootdir@
--docdir = $(datadir)/doc/$(PACKAGE)
-+docdir = $(prefix)/share/examples/${PACKAGE}-${VERSION}
- dvidir = @dvidir@
- exec_prefix = @exec_prefix@
- host = @host@
-@@ -227,11 +227,11 @@
-
-
- # install money example
--exampledir = $(docdir)/example
-+exampledir = $(docdir)
- example_DATA = $(example_docs)
--examplesrcdir = $(docdir)/example/src
-+examplesrcdir = $(exampledir)/src
- examplesrc_DATA = $(example_src_docs)
--exampletestsdir = $(docdir)/example/tests
-+exampletestsdir = $(exampledir)/tests
- exampletests_DATA = $(example_tests_docs)
- all: all-am
-
diff --git a/devel/libcheck/pkg-plist b/devel/libcheck/pkg-plist
index cddda4ab3646..b40a8da83c9b 100644
--- a/devel/libcheck/pkg-plist
+++ b/devel/libcheck/pkg-plist
@@ -1,3 +1,4 @@
+bin/checkmk
include/check.h
lib/libcheck.a
lib/libcheck.la