aboutsummaryrefslogtreecommitdiff
path: root/devel/libchipcard/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-04-20 12:42:06 +0000
commit384c2bae3b94d68ec15491eba4dc6c00acfb93ea (patch)
treefa1875a4f3aa5c20bbc367e43e857f6c786b914f /devel/libchipcard/Makefile
parent2a7193c97879226f0631d791aecbcac01770058f (diff)
downloadports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.tar.gz
ports-384c2bae3b94d68ec15491eba4dc6c00acfb93ea.zip
pcsc-lite:
- Upgrade to 1.2.9.b.7 - Use libtool15 - make hier(7)-compliant by moving the pcsc/drivers to lib/pcsc/drivers - Compile with USB support per default. Use WITHOUT_USB to disable usb support - Chase libusb shared library version (Forgotten by leeym) Based on: PR 76068 Reviewed by: maintainer, sem (earlier patch) ifd-devkit: - Chase pcsclite sharedlibrary version ifd-gempc410: - Unbreak by updating to 0.9.3 - Move library to lib/pcsc/drivers - Chase pcsclite sharedlibrary version NOTE: This was not tested, I don't own the specific hardware ifd-gpr400: - Chase pcsclite sharedlibrary version - Fix build with new pcsc-lite - Chase new pcsclite drivers location ifd-slb_rf60: - Chase pcsclite sharedlibrary version ifd-test: - Chase pcsclite sharedlibrary version - Fix build with new pcsclite libchipcard: - Update to 0.9.1[1] - Chase pcsclite shared library version - Fix build with new pcsclite [1]PR: 78815 [1]Submitted by: lofi opensc: - Chase pcsclite shared library version - Fix build on CURRENT opensc-esteid - Chase pcsclite shared library version - Fix build with new pcsclite p5-PCSC-Card: - Update to 1.4.2 - Chase pcsclite shared library version - Fix build with new pcsclite ruby-pcsc-lite - Mark broken, does not compile with new pcsc-lite Maintainer will work on new version Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=133752
Diffstat (limited to 'devel/libchipcard/Makefile')
-rw-r--r--devel/libchipcard/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
index 3cb64698fa4b..9e5dc3d8ccdb 100644
--- a/devel/libchipcard/Makefile
+++ b/devel/libchipcard/Makefile
@@ -1,13 +1,12 @@
# Ports collection makefile for: LibChipCard
# Date created: 19 January 2003
-# Whom: Martin Preuss<martin@libchipcard.de>
+# Whom: Martin Preuss <martin@libchipcard.de>
#
# $FreeBSD$
#
PORTNAME= libchipcard
-PORTVERSION= 0.8
-PORTREVISION= 1
+PORTVERSION= 0.9.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= libchipcard
@@ -15,7 +14,7 @@ MASTER_SITE_SUBDIR= libchipcard
MAINTAINER= martin@libchipcard.de
COMMENT= "A library for easy access to chipcards"
-LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USE_GMAKE= yes
USE_OPENSSL= yes
@@ -30,6 +29,12 @@ MAN1= ctfstool.1 chipcardd.1 geldkarte.1 hbcicard.1 \
kvkd.1 memcard.1 libchipcard-config.1 readertest.1
MAN5= libchipcard.conf.5 chipcardc.conf.5 chipcardd.conf.5
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,LPCSTR,LPCTSTR," ${WRKSRC}/src/libchipcard/engine/reader/ctdriver_pcsc.h
+ ${REINPLACE_CMD} -e "s,libpcsclite.so.0,libpcsclite.so.1,; \
+ s,/usr/local/pcsc/include,${LOCALBASE}/include/PCSC," ${WRKSRC}/configure
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/freebsd/chipcardd.sh ${PREFIX}/etc/rc.d