aboutsummaryrefslogtreecommitdiff
path: root/devel/libchipcard
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-02-17 23:56:56 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-02-17 23:56:56 +0000
commitb8980341895fd597b544b990f185b4fe48ecdec8 (patch)
tree2ec9cf1ed5e9828128633f639a799ac504147812 /devel/libchipcard
parent8873f425a75ad5ebed0262aed4a637a97f1d4031 (diff)
downloadports-b8980341895fd597b544b990f185b4fe48ecdec8.tar.gz
ports-b8980341895fd597b544b990f185b4fe48ecdec8.zip
Add libchipcard, a library for access to chipcards
PR: 47228 Submitted by: Martin Preuss <martin@libchipcard.de>
Notes
Notes: svn path=/head/; revision=75750
Diffstat (limited to 'devel/libchipcard')
-rw-r--r--devel/libchipcard/Makefile33
-rw-r--r--devel/libchipcard/distinfo1
-rw-r--r--devel/libchipcard/pkg-descr6
-rw-r--r--devel/libchipcard/pkg-message9
-rw-r--r--devel/libchipcard/pkg-plist58
5 files changed, 107 insertions, 0 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
new file mode 100644
index 000000000000..916955355a41
--- /dev/null
+++ b/devel/libchipcard/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: LibChipCard
+# Date created: 19 January 2003
+# Whom: Martin Preuss<martin@libchipcard.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libchipcard
+PORTVERSION= 0.7.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libchipcard
+
+MAINTAINER= martin@libchipcard.de
+COMMENT= "A library for easy access to chipcards."
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= ctfstool.1 chipcardd.1 geldkarte.1 hbcicard.1
+MAN5= libchipcard.conf.5 chipcardc.conf.5 chipcardd.conf.5
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/freebsd/chipcardd.sh ${PREFIX}/etc/rc.d
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},' ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/libchipcard/distinfo b/devel/libchipcard/distinfo
new file mode 100644
index 000000000000..5b07b5506184
--- /dev/null
+++ b/devel/libchipcard/distinfo
@@ -0,0 +1 @@
+MD5 (libchipcard-0.7.5.tar.gz) = efb4f3de16e17ba801bd28e49252a692
diff --git a/devel/libchipcard/pkg-descr b/devel/libchipcard/pkg-descr
new file mode 100644
index 000000000000..bfa18dcc232c
--- /dev/null
+++ b/devel/libchipcard/pkg-descr
@@ -0,0 +1,6 @@
+Libchipcard allows easy access to smart cards. It provides basic access
+to memory and processor cards and has special support for German medical
+cards, German "Geldkarten" and HBCI (homebanking) cards (both type 0 and
+type 1).
+It accesses the readers via CTAPI or PC/SC interfaces and has successfully
+been tested with Towitoko, Kobil and Reiner-SCT readers.
diff --git a/devel/libchipcard/pkg-message b/devel/libchipcard/pkg-message
new file mode 100644
index 000000000000..a857a0b9da99
--- /dev/null
+++ b/devel/libchipcard/pkg-message
@@ -0,0 +1,9 @@
+***********************************************************************
+* *
+* You need to setup the following configurations files before using *
+* LibChipCard: *
+* - %%PREFIX%%/etc/chipcardc.conf (client configuration) *
+* - %%PREFIX%%/etc/chipcardd.conf (daemon configuration) *
+* I have installed example files (filenames above+".example"). *
+* *
+***********************************************************************
diff --git a/devel/libchipcard/pkg-plist b/devel/libchipcard/pkg-plist
new file mode 100644
index 000000000000..c39e12f81541
--- /dev/null
+++ b/devel/libchipcard/pkg-plist
@@ -0,0 +1,58 @@
+bin/cardcommander
+bin/ctfstool
+bin/geldkarte
+bin/hbcicard
+bin/libchipcard-config
+bin/memcard
+bin/readertest
+etc/chipcardc.conf.example
+etc/chipcardd.conf.example
+etc/rc.d/chipcardd.sh
+include/chameleon/chameleon.h
+include/chameleon/conf.h
+include/chameleon/cryp.h
+include/chameleon/debug.h
+include/chameleon/directory.h
+include/chameleon/error.h
+include/chameleon/inetaddr.h
+include/chameleon/inetsocket.h
+include/chameleon/ipcmessage.h
+include/chameleon/ipcmessagelayer.h
+include/chameleon/ipcservicelayer.h
+include/chameleon/ipctransportlayer.h
+include/chameleon/libloader.h
+include/chameleon/logger.h
+include/chipcard/ctcard.h
+include/chipcard/ctcommand.h
+include/chipcard/ctcore_public.h
+include/chipcard/ctdatacache.h
+include/chipcard/cterror.h
+include/chipcard/ctfilesystem2.h
+include/chipcard/ctgeldkarte.h
+include/chipcard/ctkvkcard.h
+include/chipcard/ctmemorycard.h
+include/chipcard/ctmisc.h
+include/chipcard/ctpointer.h
+include/chipcard/ctprocessorcard.h
+include/chipcard/cttlv.h
+include/chipcard/ctversion.h
+include/chipcard.h
+include/chipcard/hbcicard.h
+include/chipcard/libchipcard.h
+include/chipcard/rsacard.h
+include/ctversion.h
+lib/libchipcard.la
+lib/libchipcard.so
+lib/libchipcard.so.16
+sbin/chipcardd
+sbin/kvkd
+share/aclocal/libchipcard.m4
+share/libchipcard/commands/ctcard.cmd
+share/libchipcard/commands/ctgeldkarte.cmd
+share/libchipcard/commands/ctkvkcard.cmd
+share/libchipcard/commands/ctmemorycard.cmd
+share/libchipcard/commands/ctprocessorcard.cmd
+share/libchipcard/commands/hbcicard.cmd
+share/libchipcard/commands/rsacard.cmd
+@dirrm share/libchipcard/commands
+@dirrm share/libchipcard