aboutsummaryrefslogtreecommitdiff
path: root/devel/libdasm
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-01 11:17:28 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-01 11:17:28 +0000
commiteda0ab97e840f22ffc9e10ad24be8b043b32ea03 (patch)
tree9d8462554bc213c8c60bd0ce52ee499ce43f66ab /devel/libdasm
parent4bb173357e6b7554bf5344a2d9c037158965d7e6 (diff)
downloadports-eda0ab97e840f22ffc9e10ad24be8b043b32ea03.tar.gz
ports-eda0ab97e840f22ffc9e10ad24be8b043b32ea03.zip
libdasm is a C-library that tries to provide simple and convenient
way to disassemble Intel x86 raw opcode bytes (machine code). It can parse and print out opcodes in AT&T and Intel syntax. WWW: http://www.nologin.net/main.pl?action=codeView&codeId=49& PR: ports/95048 Submitted by: Antoine Brodin <antoine.brodin@laposte.net>
Notes
Notes: svn path=/head/; revision=158533
Diffstat (limited to 'devel/libdasm')
-rw-r--r--devel/libdasm/Makefile50
-rw-r--r--devel/libdasm/distinfo3
-rw-r--r--devel/libdasm/pkg-descr5
-rw-r--r--devel/libdasm/pkg-plist11
4 files changed, 69 insertions, 0 deletions
diff --git a/devel/libdasm/Makefile b/devel/libdasm/Makefile
new file mode 100644
index 000000000000..e6c8a9bb3a0c
--- /dev/null
+++ b/devel/libdasm/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: libdasm
+# Date created: 28 March 2006
+# Whom: Antoine Brodin <antoine.brodin@laposte.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdasm
+PORTVERSION= 1.4
+CATEGORIES= devel
+MASTER_SITES= http://www.klake.org/~jt/misc/
+
+MAINTAINER= antoine.brodin@laposte.net
+COMMENT= A simple x86 disassembly library
+
+INSTALLS_SHLIB= yes
+
+.if !defined(WITHOUT_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC -DPIC
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -E 's,^(CC|CFLAGS|PREFIX).*=,\1 ?=,; \
+ s,libdasm.so.1.0,libdasm.so.1,g; \
+ s,cp ,${INSTALL_DATA} ,g' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/examples/Makefile
+
+post-install:
+.if !defined(WITHOUT_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/README.txt ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/das.c ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/simple.c ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/HISTORY.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libdasm/distinfo b/devel/libdasm/distinfo
new file mode 100644
index 000000000000..7554bd4cb7d9
--- /dev/null
+++ b/devel/libdasm/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdasm-1.4.tar.gz) = bc13927d718edf8db7e5e3a7631b03dc
+SHA256 (libdasm-1.4.tar.gz) = 182603e7581e34c013c82811b0dcd4f7fc49f0e493d5e7ea1935a42408565d1f
+SIZE (libdasm-1.4.tar.gz) = 69303
diff --git a/devel/libdasm/pkg-descr b/devel/libdasm/pkg-descr
new file mode 100644
index 000000000000..327325d1eeae
--- /dev/null
+++ b/devel/libdasm/pkg-descr
@@ -0,0 +1,5 @@
+libdasm is a C-library that tries to provide simple and convenient
+way to disassemble Intel x86 raw opcode bytes (machine code). It
+can parse and print out opcodes in AT&T and Intel syntax.
+
+WWW: http://www.nologin.net/main.pl?action=codeView&codeId=49&
diff --git a/devel/libdasm/pkg-plist b/devel/libdasm/pkg-plist
new file mode 100644
index 000000000000..27c9455fd190
--- /dev/null
+++ b/devel/libdasm/pkg-plist
@@ -0,0 +1,11 @@
+include/libdasm.h
+lib/libdasm.a
+lib/libdasm.so
+lib/libdasm.so.1
+%%EXAMPLES%%%%EXAMPLESDIR%%/README.txt
+%%EXAMPLES%%%%EXAMPLESDIR%%/das.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/simple.c
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/HISTORY.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%