aboutsummaryrefslogtreecommitdiff
path: root/devel/libdisasm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-18 10:10:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-18 10:10:56 +0000
commit07e3dedf9702916653e21b54aa9500286ff0f7f2 (patch)
tree12bfc097b7925766095973a6d62526a695de510a /devel/libdisasm
parentb2320580f5d85f574e82082b533602a163f218d3 (diff)
downloadports-07e3dedf9702916653e21b54aa9500286ff0f7f2.tar.gz
ports-07e3dedf9702916653e21b54aa9500286ff0f7f2.zip
The libdisasm library provides basic disassembly of Intel x86
instructions from a binary stream. The intent is to provide an easy to use disassembler which can be called from any application; the disassembly can be produced in AT&T syntax and Intel syntax, as well as in an intermediate format which includes detailed instruction and operand type information. WWW: http://bastard.sourceforge.net/libdisasm.html PR: ports/108067 Submitted by: Lutz Boehne <lboehne at damogran.de>
Notes
Notes: svn path=/head/; revision=182713
Diffstat (limited to 'devel/libdisasm')
-rw-r--r--devel/libdisasm/Makefile57
-rw-r--r--devel/libdisasm/distinfo3
-rw-r--r--devel/libdisasm/files/patch-Makefile33
-rw-r--r--devel/libdisasm/pkg-descr8
-rw-r--r--devel/libdisasm/pkg-plist7
5 files changed, 108 insertions, 0 deletions
diff --git a/devel/libdisasm/Makefile b/devel/libdisasm/Makefile
new file mode 100644
index 000000000000..cf617fff6d10
--- /dev/null
+++ b/devel/libdisasm/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: libdisasm
+# Date created: 18 January 2006
+# Whom: Lutz Boehne <lboehne@damogran.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdisasm
+PORTVERSION= 0.21
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bastard
+DISTNAME= libdisasm-0.21-pre3
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lboehne@damogran.de
+COMMENT= The Bastard Disassembly Environment x86 disassembler library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's, make, gmake,' ${WRKSRC}/Makefile
+.if ${OSVERSION} < 500000
+ ${REINPLACE_CMD} -e 's, -Wno-strict-aliasing,,' ${WRKSRC}/libdisasm/Makefile
+.endif
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${DATADIR}/doc
+DOCS= libdisasm.txt
+.endif
+
+MAN3= x86_disasm.3 x86_format_insn.3 x86_init.3
+MAN7= libdisasm.7
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libdisasm/libdisasm.so ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libdisasm/libdisasm.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libdisasm/libdis.h ${PREFIX}/include
+ ${MKDIR} ${PREFIX}/share/${PORTNAME}/data
+ ${INSTALL_DATA} ${WRKSRC}/libdisasm/ia32_opcode.dat ${DATADIR}/data
+.if !defined(NOPORTDOCS)
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
+.endif
+.for i in ${MAN3}
+ ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man3
+.endfor
+.for i in ${MAN7}
+ ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man7
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/devel/libdisasm/distinfo b/devel/libdisasm/distinfo
new file mode 100644
index 000000000000..cd7fdf559bc9
--- /dev/null
+++ b/devel/libdisasm/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdisasm-0.21-pre3.tgz) = c3313485ec8cebb7646518a10c3101dc
+SHA256 (libdisasm-0.21-pre3.tgz) = f56a4a07ee8107815e87af3bd7da6348dea91f16ab40a0d90d5a028ef556be90
+SIZE (libdisasm-0.21-pre3.tgz) = 198158
diff --git a/devel/libdisasm/files/patch-Makefile b/devel/libdisasm/files/patch-Makefile
new file mode 100644
index 000000000000..e5f699a27fd8
--- /dev/null
+++ b/devel/libdisasm/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.old Sat Apr 29 02:16:24 2006
++++ Makefile Thu Jan 18 01:01:08 2007
+@@ -48,7 +48,7 @@
+ # ============================================================================
+ # TARGETS
+
+-all: $(LIBDIS) $(X86DIS) $(TESTDIS) swig-modules
++all: $(LIBDIS)
+ dummy: x86dis libdisasm test dist swig-modules install clean
+
+ # ------------------------------------------------------- LIBDIS
+@@ -86,15 +86,15 @@
+ cd swig && make clean
+
+ # ------------------------------------------------------- INSTALL
+-install: $(LIBDIS) $(X86DIS)
++install: $(LIBDIS)
+ #swig-install
+ # install bindistrib files to INSTALL_LOC
+ cd libdisasm && make install
+- cd x86dis && make install
+- cd man && make install
+- cd doc && make install
+- cd perl && make install
+- cd swig && make install
++ #cd x86dis && make install
++ #cd man && make install
++ #cd doc && make install
++ #cd perl && make install
++ #cd swig && make install
+
+ uninstall:
+ cd libdisasm && make uninstall
diff --git a/devel/libdisasm/pkg-descr b/devel/libdisasm/pkg-descr
new file mode 100644
index 000000000000..b353c448404d
--- /dev/null
+++ b/devel/libdisasm/pkg-descr
@@ -0,0 +1,8 @@
+The libdisasm library provides basic disassembly of Intel x86
+instructions from a binary stream. The intent is to provide an easy to
+use disassembler which can be called from any application; the
+disassembly can be produced in AT&T syntax and Intel syntax, as well as
+in an intermediate format which includes detailed instruction and
+operand type information.
+
+WWW: http://bastard.sourceforge.net/libdisasm.html
diff --git a/devel/libdisasm/pkg-plist b/devel/libdisasm/pkg-plist
new file mode 100644
index 000000000000..8ac20216c697
--- /dev/null
+++ b/devel/libdisasm/pkg-plist
@@ -0,0 +1,7 @@
+include/libdis.h
+lib/libdisasm.a
+lib/libdisasm.so
+%%DATADIR%%/data/ia32_opcode.dat
+%%DATADIR%%/doc
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%