aboutsummaryrefslogtreecommitdiff
path: root/devel/libdlna
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2008-03-22 10:54:23 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2008-03-22 10:54:23 +0000
commit950ad5bc316aac3ce16a2ba21cc8f01f51d67826 (patch)
tree8f89e23279688dbc44090f2f05067f04a0c0ffc5 /devel/libdlna
parent5654e4adb1c91eb41a86e1312d785e05b6db9d1c (diff)
downloadports-950ad5bc316aac3ce16a2ba21cc8f01f51d67826.tar.gz
ports-950ad5bc316aac3ce16a2ba21cc8f01f51d67826.zip
The proprietary configure script wasn't able to find pthread under 6.x,
therefore it failed to build. This patch adds ${PTHREAD_LIBS} to LDFLAGS to fix this port under 6.x. Notified by: pointyhat (via pav)
Notes
Notes: svn path=/head/; revision=209572
Diffstat (limited to 'devel/libdlna')
-rw-r--r--devel/libdlna/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/libdlna/Makefile b/devel/libdlna/Makefile
index e4128f4f81ea..4022ddf098a8 100644
--- a/devel/libdlna/Makefile
+++ b/devel/libdlna/Makefile
@@ -15,8 +15,7 @@ MASTER_SITES= http://libdlna.geexbox.org/releases/ \
MAINTAINER= malus.x@gmail.com
COMMENT= Reference DLNA open-source implementation
-LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg \
- avformat:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= avcodec:${PORTSDIR}/multimedia/ffmpeg
HAS_CONFIGURE= yes
USE_BZIP2= yes
@@ -24,10 +23,13 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-optimize
-CONFIGURE_ENV+= LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-optimize \
+ --includedir=${LOCALBASE}/include \
+ --libdir=${LOCALBASE}/lib
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}"
CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
post-patch:
@${REINPLACE_CMD} -e \