aboutsummaryrefslogtreecommitdiff
path: root/devel/libdouble-conversion
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-05-24 07:11:09 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-05-24 07:11:09 +0000
commitc83c0f08d83d201a3dcb7e2e98f3eaea30b00e4d (patch)
tree1527cb2b1f46461d0af5b747aa65fc6fd73ecf6f /devel/libdouble-conversion
parent4d373dd3345a7ca361f3337ba6f2bce024648308 (diff)
downloadports-c83c0f08d83d201a3dcb7e2e98f3eaea30b00e4d.tar.gz
ports-c83c0f08d83d201a3dcb7e2e98f3eaea30b00e4d.zip
1: Stageify.
2: sort pkg-plist. 3: convert to USES. Approved by: portmgr@
Notes
Notes: svn path=/head/; revision=354990
Diffstat (limited to 'devel/libdouble-conversion')
-rw-r--r--devel/libdouble-conversion/Makefile6
-rw-r--r--devel/libdouble-conversion/files/patch-Makefile.in39
-rw-r--r--devel/libdouble-conversion/pkg-plist17
3 files changed, 50 insertions, 12 deletions
diff --git a/devel/libdouble-conversion/Makefile b/devel/libdouble-conversion/Makefile
index 2ba8fa3e4d2c..b4f956af5c8f 100644
--- a/devel/libdouble-conversion/Makefile
+++ b/devel/libdouble-conversion/Makefile
@@ -3,16 +3,17 @@
PORTNAME= libdouble-conversion
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GH
MAINTAINER= waitman@waitman.net
COMMENT= Binary-decimal and decimal-binary routines for IEEE doubles
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_AUTOTOOLS= libtool
+USES= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -21,5 +22,4 @@ GH_ACCOUNT= waitman
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= e9b9e5a
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/libdouble-conversion/files/patch-Makefile.in b/devel/libdouble-conversion/files/patch-Makefile.in
new file mode 100644
index 000000000000..44da8cb2466d
--- /dev/null
+++ b/devel/libdouble-conversion/files/patch-Makefile.in
@@ -0,0 +1,39 @@
+--- Makefile.in.orig 2014-05-24 01:53:08.831304467 +0800
++++ Makefile.in 2014-05-24 01:53:59.915300970 +0800
+@@ -15,21 +15,21 @@ distclean:
+ rm -f src/Makefile
+
+ install:
+- ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.so.0 @prefix@/lib
+- ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.so @prefix@/lib
+- ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.la @prefix@/lib
+- ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.a @prefix@/lib
+- mkdir -p @prefix@/include/double-conversion
+- ${INSTALL} -m 0644 -g wheel -o root src/bignum-dtoa.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/double-conversion.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/strtod.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/bignum.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/fast-dtoa.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/utils.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/cached-powers.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/fixed-dtoa.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/diy-fp.h @prefix@/include/double-conversion/
+- ${INSTALL} -m 0644 -g wheel -o root src/ieee.h @prefix@/include/double-conversion/
++ ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.so.0 $(DESTDIR)@prefix@/lib
++ ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.so $(DESTDIR)@prefix@/lib
++ ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.la $(DESTDIR)@prefix@/lib
++ ${INSTALL} -m 0755 -g wheel -o root src/.libs/libdouble-conversion.a $(DESTDIR)@prefix@/lib
++ mkdir -p $(DESTDIR)@prefix@/include/double-conversion
++ ${INSTALL} -m 0644 -g wheel -o root src/bignum-dtoa.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/double-conversion.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/strtod.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/bignum.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/fast-dtoa.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/utils.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/cached-powers.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/fixed-dtoa.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/diy-fp.h $(DESTDIR)@prefix@/include/double-conversion/
++ ${INSTALL} -m 0644 -g wheel -o root src/ieee.h $(DESTDIR)@prefix@/include/double-conversion/
+
+ deinstall:
+ rm -f @prefix@/lib/libdouble-conversion.so.0
diff --git a/devel/libdouble-conversion/pkg-plist b/devel/libdouble-conversion/pkg-plist
index e16638db031a..e78a85af3f31 100644
--- a/devel/libdouble-conversion/pkg-plist
+++ b/devel/libdouble-conversion/pkg-plist
@@ -1,15 +1,14 @@
-lib/libdouble-conversion.so.0
-lib/libdouble-conversion.so
-lib/libdouble-conversion.la
-lib/libdouble-conversion.a
include/double-conversion/bignum-dtoa.h
-include/double-conversion/double-conversion.h
-include/double-conversion/strtod.h
include/double-conversion/bignum.h
-include/double-conversion/fast-dtoa.h
-include/double-conversion/utils.h
include/double-conversion/cached-powers.h
-include/double-conversion/fixed-dtoa.h
include/double-conversion/diy-fp.h
+include/double-conversion/double-conversion.h
+include/double-conversion/fast-dtoa.h
+include/double-conversion/fixed-dtoa.h
include/double-conversion/ieee.h
+include/double-conversion/strtod.h
+include/double-conversion/utils.h
+lib/libdouble-conversion.a
+lib/libdouble-conversion.so
+lib/libdouble-conversion.so.0
@dirrm include/double-conversion