aboutsummaryrefslogtreecommitdiff
path: root/devel/libexecinfo
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-08-10 15:07:26 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-08-10 15:07:26 +0000
commite99c8ea14de43dcffffdd14ba03793d8d67b7a3a (patch)
treefb8d1e5d148be869a7ba462c1c46d0fbc87abcac /devel/libexecinfo
parenta3570688110e2fa4bbebeabcae757b868288540c (diff)
downloadports-e99c8ea14de43dcffffdd14ba03793d8d67b7a3a.tar.gz
ports-e99c8ea14de43dcffffdd14ba03793d8d67b7a3a.zip
Add libexecinfo 1.0, a library for inspecting program's backtrace.
Notes
Notes: svn path=/head/; revision=86721
Diffstat (limited to 'devel/libexecinfo')
-rw-r--r--devel/libexecinfo/Makefile25
-rw-r--r--devel/libexecinfo/distinfo1
-rw-r--r--devel/libexecinfo/files/patch-Makefile14
-rw-r--r--devel/libexecinfo/pkg-descr6
-rw-r--r--devel/libexecinfo/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/libexecinfo/Makefile b/devel/libexecinfo/Makefile
new file mode 100644
index 000000000000..6b2b2df0b281
--- /dev/null
+++ b/devel/libexecinfo/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libexecinfo
+# Date created: 10 August 2003
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libexecinfo
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= https://demo.portaone.com/~sobomax/freestuff/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A library for inspecting program's backtrace
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+MAKE_FLAGS= LIBDIR=${PREFIX}/lib \
+ INCLUDEDIR=${PREFIX}/include
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/libexecinfo/distinfo b/devel/libexecinfo/distinfo
new file mode 100644
index 000000000000..c8357419b5d7
--- /dev/null
+++ b/devel/libexecinfo/distinfo
@@ -0,0 +1 @@
+MD5 (libexecinfo-1.0.tar.bz2) = 745579b7705227c5c79cd7af391a005b
diff --git a/devel/libexecinfo/files/patch-Makefile b/devel/libexecinfo/files/patch-Makefile
new file mode 100644
index 000000000000..693544c52748
--- /dev/null
+++ b/devel/libexecinfo/files/patch-Makefile
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile 2003/08/10 05:00:23 1.1
++++ Makefile 2003/08/10 05:00:34
+@@ -28,6 +28,8 @@
+
+ SRCS= stacktraverse.c stacktraverse.h execinfo.c execinfo.h
+
++INCS= execinfo.h
++
+ SHLIB_MAJOR= 1
+ SHLIB_MINOR= 0
+
diff --git a/devel/libexecinfo/pkg-descr b/devel/libexecinfo/pkg-descr
new file mode 100644
index 000000000000..30af30956be2
--- /dev/null
+++ b/devel/libexecinfo/pkg-descr
@@ -0,0 +1,6 @@
+This is a quick-n-dirty BSD licensed clone of backtrace facility found
+in the GNU libc, mainly intended for porting linuxish code to BSD
+platforms, however it can be used at any platform which has a gcc
+compiler.
+
+WWW: http://www.gnu.org/manual/glibc-2.2.3/html_chapter/libc_33.html
diff --git a/devel/libexecinfo/pkg-plist b/devel/libexecinfo/pkg-plist
new file mode 100644
index 000000000000..dfdb2ee4386a
--- /dev/null
+++ b/devel/libexecinfo/pkg-plist
@@ -0,0 +1,5 @@
+include/execinfo.h
+lib/libexecinfo.a
+lib/libexecinfo.so
+lib/libexecinfo.so.1
+share/doc/libexecinfo/README