aboutsummaryrefslogtreecommitdiff
path: root/devel/libgetline
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-02 14:27:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-12-02 14:27:51 +0000
commitbdfdbc8164b8061a68324f1dd791bb41227bfea5 (patch)
tree46072fd5e1f23630567254982770df296e1360a8 /devel/libgetline
parent1f97a6b4f1e879d19903d1e5302fee862060cae5 (diff)
downloadports-bdfdbc8164b8061a68324f1dd791bb41227bfea5.tar.gz
ports-bdfdbc8164b8061a68324f1dd791bb41227bfea5.zip
- Add LICENSE
- Support STAGEDIR - While I'm here: - Do not use hardcoded DISTNAME and WRKSRC - Remove leading indefinite article from COMMENT PR: ports/184430 Submitted by: Rodrigo Osorio <rodrigo@bebik.net> (maintainer)
Notes
Notes: svn path=/head/; revision=335491
Diffstat (limited to 'devel/libgetline')
-rw-r--r--devel/libgetline/Makefile21
-rw-r--r--devel/libgetline/files/patch-ab24
-rw-r--r--devel/libgetline/pkg-plist1
3 files changed, 24 insertions, 22 deletions
diff --git a/devel/libgetline/Makefile b/devel/libgetline/Makefile
index 1b6b6d318008..6158bf7b77e6 100644
--- a/devel/libgetline/Makefile
+++ b/devel/libgetline/Makefile
@@ -5,16 +5,27 @@ PORTNAME= getline
PORTVERSION= 3.9
CATEGORIES= devel
MASTER_SITES= http://rodrigo.osorio.free.fr/freebsd/distfiles/
-DISTNAME= ${PORTNAME}-39-src
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}-src
MAINTAINER= rodrigo@bebik.net
-COMMENT= A small, portable, and easy to use command line library
+COMMENT= Small, portable, and easy to use command line library
-MAN3= getline.3
+LICENSE= BSD
-WRKSRC= ${WRKDIR}/getline-39
+WRKSRC= ${WRKDIR}/${DISTNAME:S/-src//}
USE_LDCONFIG= yes
-NO_STAGE= yes
+MAKE_ENV+= AR="${AR}"
+MAKE_ENV+= CC="${CC}"
+MAKE_ENV+= INSTALL="${INSTALL}"
+MAKE_ENV+= LN="${LN}"
+MAKE_ENV+= RANLIB="${RANLIB}"
+MAKE_ENV+= INST_INCDIR="${STAGEDIR}${PREFIX}/include"
+MAKE_ENV+= INST_LIBDIR="${STAGEDIR}${PREFIX}/lib"
+MAKE_ENV+= INST_MANDIR="${STAGEDIR}${PREFIX}/man"
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgetline.so
+
.include <bsd.port.mk>
diff --git a/devel/libgetline/files/patch-ab b/devel/libgetline/files/patch-ab
index 79abd6fab478..941433da6499 100644
--- a/devel/libgetline/files/patch-ab
+++ b/devel/libgetline/files/patch-ab
@@ -1,25 +1,12 @@
---- Makefile Thu Jan 15 02:16:07 1998
-+++ Makefile Sun Mar 21 18:04:04 1999
-@@ -1,46 +1,54 @@
+--- Makefile
++++ Makefile
+@@ -1,46 +1,43 @@
-#CC = gcc
-#CFLAGS = -Wall -DPOSIX
+PREFIX?= /usr/local
-
--CC= cc
--CFLAGS = -v -DPOSIX
-+AR= /usr/bin/ar
-+CC= /usr/bin/cc
-+INSTALL= /usr/bin/install
-+LN= /bin/ln
-+RANLIB= /usr/bin/ranlib
-+
+CFLAGS= -DPOSIX -O
+LDFLAGS=
+
-+INST_INCDIR= $(PREFIX)/include
-+INST_LIBDIR= $(PREFIX)/lib
-+INST_MANDIR= $(PREFIX)/man
-+
+SHLIB_VERSION = 1
+SHLIB_CFLAGS = -fpic -DPIC
+SHLIB_LDFLAGS = -shared
@@ -32,6 +19,9 @@
+testgl: libgetline.a testgl.o
+ $(CC) $(LDFLAGS) $(CFLAGS) -o testgl testgl.o -L$(INST_MANDIR) -lgetline
+-CC= cc
+-CFLAGS = -v -DPOSIX
+-
-LDFLAGS=
-INSTALL_PATH=/usr/local
-INST_LIBDIR=$(INSTALL_PATH)/lib
@@ -84,7 +74,7 @@
+ [ -d $(INST_LIBDIR) ] || $(INSTALL) -d $(INST_LIBDIR)
+ $(INSTALL) -c -g bin -o bin -m 644 libgetline.a libgetline.so.1 \
+ $(INST_LIBDIR)
-+ $(LN) -fs $(INST_LIBDIR)/libgetline.so.$(SHLIB_VERSION) \
++ $(LN) -fs libgetline.so.$(SHLIB_VERSION) \
+ $(INST_LIBDIR)/libgetline.so
+ [ -d $(INST_MANDIR)/man3 ] || $(INSTALL) -d $(INST_MANDIR)/man3
+ $(INSTALL) -c -g bin -o bin -m 644 getline.3 $(INST_MANDIR)/man3
diff --git a/devel/libgetline/pkg-plist b/devel/libgetline/pkg-plist
index 08bfddd9c3e4..ce761eb86b24 100644
--- a/devel/libgetline/pkg-plist
+++ b/devel/libgetline/pkg-plist
@@ -2,3 +2,4 @@ include/getline.h
lib/libgetline.a
lib/libgetline.so
lib/libgetline.so.1
+man/man3/getline.3.gz