aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /devel/libglade2/Makefile
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadports-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
ports-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Notes
Notes: svn path=/head/; revision=314632
Diffstat (limited to 'devel/libglade2/Makefile')
-rw-r--r--devel/libglade2/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index c35ccb33e9ba..9c4ac1599bd2 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: libglade2
-# Date created: 18 August 1999
-# Whom: Ade Lovett <ade@lovett.com>
-#
+# Created by: Ade Lovett <ade@lovett.com>
# $FreeBSD$
# $MCom: ports/devel/libglade2/Makefile,v 1.26 2007/08/01 16:13:48 mezz Exp $
-#
PORTNAME= libglade2
PORTVERSION= 2.6.4
@@ -26,7 +22,8 @@ RUN_DEPENDS= xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack libxml2 gtk20 referencehack
+USES= pathfix
+USE_GNOME= libxml2 gtk20 referencehack
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc \
@@ -37,11 +34,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= XMLCATALOG="${LOCALBASE}/bin/xmlcatalog" \
CATALOG_PORTS_XML="${LOCALBASE}/share/xml/catalog.ports"
-OPTIONS= PYTHON "Use Python" on
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT=PYTHON
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON
USE_PYTHON= yes
PLIST_SUB+= PYTHON=""