aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 03:11:39 +0000
commitc4851e78e4f63338fe9a4883e5b7a0370dce27f7 (patch)
tree3910aa2e83f782cec94f15b4547dadb741cd29ce /devel/libglade2
parentf82c84522b047dd99c6f9d85ce3e07217ccce7df (diff)
downloadports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.tar.gz
ports-c4851e78e4f63338fe9a4883e5b7a0370dce27f7.zip
Presenting GNOME 2.6.0. The FreeBSD GNOME Team feels this our best release
ever. It fixes many bugs, and adds some features missing in previous FreeBSD ports. To help users upgrade from GNOME 2.4, we have constructed an upgrade FAQ at: http://www.freebsd.org/gnome/docs/faq26.html Please read it carefully. GNOME 2.6 packages are also available for all supported i386 versions of FreeBSD at: http://www.marcuscom.com/tinderbox/ The FreeBSD GNOME Team would like the thank the following users for their wonderful testing and patching efforts. We would especially like to thank Franz Klammer <klammer@webonaut.com> for his wonderful new splash screen. Without these people, our team, and our team alumni, GNOME on FreeBSD would not be possible. Jeremy Messenger <mezz7@cox.net> Khairil Yusof <kaeru@pd.jaring.my> Koop Mast <kwm@rainbow-runner.nl> Simon Barner <barner@in.tum.de> Tom McLaughlin <tmclaugh@sdf.lonestar.org> Scott Dodson <sdodson@sdodson.com> Vladimir Grebenschikov <vova@sw.ru>
Notes
Notes: svn path=/head/; revision=106172
Diffstat (limited to 'devel/libglade2')
-rw-r--r--devel/libglade2/Makefile18
-rw-r--r--devel/libglade2/distinfo4
-rw-r--r--devel/libglade2/files/patch-ab27
-rw-r--r--devel/libglade2/files/patch-doc::Makefile.in14
-rw-r--r--devel/libglade2/pkg-descr8
-rw-r--r--devel/libglade2/pkg-plist18
6 files changed, 48 insertions, 41 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index e2fc89e81c56..5fe9635d584f 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= libglade2
-PORTVERSION= 2.0.1
-PORTREVISION= 2
+PORTVERSION= 2.3.6
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.0
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.3
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -18,16 +17,23 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME glade library
BUILD_DEPENDS= ${PYEXPAT}
-RUN_DEPENDS= ${PYEXPAT}
+RUN_DEPENDS= ${PYEXPAT} \
+ xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_PYTHON= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=13
USE_GNOME= gnomehack libxml2 gtk20
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= XMLCATALOG="${LOCALBASE}/bin/xmlcatalog" \
+ CATALOG_PORTS_XML="${LOCALBASE}/share/xml/catalog.ports"
.include <bsd.port.mk>
diff --git a/devel/libglade2/distinfo b/devel/libglade2/distinfo
index ea59e843802f..1ac601a8efbc 100644
--- a/devel/libglade2/distinfo
+++ b/devel/libglade2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libglade-2.0.1.tar.bz2) = 4d93f6b01510013ae429e91af432cfe2
-SIZE (gnome2/libglade-2.0.1.tar.bz2) = 264646
+MD5 (gnome2/libglade-2.3.6.tar.bz2) = f579c881b95e6dee0f55f82940eb2004
+SIZE (gnome2/libglade-2.3.6.tar.bz2) = 343224
diff --git a/devel/libglade2/files/patch-ab b/devel/libglade2/files/patch-ab
index a7875449633e..a09056d333f5 100644
--- a/devel/libglade2/files/patch-ab
+++ b/devel/libglade2/files/patch-ab
@@ -1,20 +1,29 @@
---- Makefile.in.orig Wed Apr 3 01:58:07 2002
-+++ Makefile.in Wed Apr 3 01:59:13 2002
-@@ -34,7 +34,7 @@
- includedir = @includedir@
- oldincludedir = /usr/include
+--- Makefile.in.orig Wed Jan 14 17:20:11 2004
++++ Makefile.in Wed Jan 14 17:23:52 2004
+@@ -18,7 +18,7 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
+pkglibdir = $(prefix)/libdata/pkgconfig
pkgincludedir = $(includedir)/@PACKAGE@
top_builddir = .
-@@ -104,7 +104,7 @@
- am__include = @am__include@
- am__quote = @am__quote@
- install_sh = @install_sh@
+@@ -169,7 +169,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
-SUBDIRS = glade doc tests
+SUBDIRS = glade doc
INCLUDES = $(LIBGLADE_CFLAGS)
+@@ -188,7 +188,7 @@
+
+
+ # handling of the XML catalog
+-XMLCATALOG = /etc/xml/catalog
++XMLCATALOG = $(LOCALBASE)/share/xml/catalog.ports
+
+ xmldir = $(datadir)/xml/libglade
+ xml_DATA = glade-2.0.dtd
diff --git a/devel/libglade2/files/patch-doc::Makefile.in b/devel/libglade2/files/patch-doc::Makefile.in
deleted file mode 100644
index 4a5b4b671943..000000000000
--- a/devel/libglade2/files/patch-doc::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- doc/Makefile.in 2002/02/14 10:10:45 1.1
-+++ doc/Makefile.in 2002/02/14 10:11:18
-@@ -110,7 +110,7 @@
- # The directory containing the source code (if it contains documentation).
- DOC_SOURCE_DIR = ../glade
-
--HTML_DIR = $(datadir)/gtk-doc/html
-+HTML_DIR = $(datadir)/doc
-
- TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
-
diff --git a/devel/libglade2/pkg-descr b/devel/libglade2/pkg-descr
index dd6a386e94cd..7335dd1ea972 100644
--- a/devel/libglade2/pkg-descr
+++ b/devel/libglade2/pkg-descr
@@ -1,5 +1,3 @@
-A library that allows you to load GLADE interfaces at runtime (you don't
-have to generate stubs with GLADE before hand). This way you can change
-the look of your application without recompiling. This way you can write
-the logic behind the interface separately from the code to build the
-interface, so changing the interface is not so much of a problem.
+LibGlade allows GLADE interfaces to be handled at runtime, freeing
+GUI development from code development. This allows an interface to
+be changed without requiring a re-compilation.
diff --git a/devel/libglade2/pkg-plist b/devel/libglade2/pkg-plist
index 9581dd4b3a3a..f1b4720d65ef 100644
--- a/devel/libglade2/pkg-plist
+++ b/devel/libglade2/pkg-plist
@@ -8,20 +8,28 @@ lib/libglade-2.0.a
lib/libglade-2.0.so
lib/libglade-2.0.so.0
libdata/pkgconfig/libglade-2.0.pc
-share/doc/libglade/gladexml.html
+share/doc/libglade/GladeXML.html
+share/doc/libglade/home.png
+share/doc/libglade/index.html
+share/doc/libglade/index.sgml
+share/doc/libglade/left.png
+share/doc/libglade/libglade-Libglade-Build.html
+share/doc/libglade/libglade-Libglade-Initialisation.html
+share/doc/libglade/libglade-Libglade-SAX-Parser.html
share/doc/libglade/libglade-dtd.html
share/doc/libglade/libglade-dtd-exceptions.html
share/doc/libglade/libglade-embedding.html
share/doc/libglade/libglade-extending.html
share/doc/libglade/libglade-i18n.html
share/doc/libglade/libglade-lib.html
-share/doc/libglade/libglade-libglade-build.html
-share/doc/libglade/libglade-libglade-initialisation.html
-share/doc/libglade/libglade-libglade-sax-parser.html
share/doc/libglade/libglade-modules.html
share/doc/libglade/libglade-notes.html
-share/doc/libglade/libglade.html
+share/doc/libglade/libglade.devhelp
+share/doc/libglade/right.png
+share/doc/libglade/up.png
share/xml/libglade/glade-2.0.dtd
+@unexec %%XMLCATALOG%% --noout --del %D/share/xml/libglade/glade-2.0.dtd %%CATALOG_PORTS_XML%% || /usr/bin/true
+@exec %%XMLCATALOG%% --noout --add "system" "http://glade.gnome.org/glade-2.0.dtd" %D/share/xml/libglade/glade-2.0.dtd %%CATALOG_PORTS_XML%% || /usr/bin/true
@dirrm share/xml/libglade
@dirrm share/doc/libglade
@dirrm include/libglade-2.0/glade