aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 15:31:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-11 15:31:46 +0000
commit548387be8002521e3aa9b0c8ae2b343d9d3520eb (patch)
treeec7ba00fd2a8b535baa75d1a42a0f7d7096519e9 /devel/libglade2
parentbcbf81722c6ee8e04ddbb164394bf1905b2a3fa4 (diff)
downloadports-548387be8002521e3aa9b0c8ae2b343d9d3520eb.tar.gz
ports-548387be8002521e3aa9b0c8ae2b343d9d3520eb.zip
Use USE_REINPLACE.
Notes
Notes: svn path=/head/; revision=62815
Diffstat (limited to 'devel/libglade2')
-rw-r--r--devel/libglade2/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index 09394f337a3a..efb24b03731d 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_LIBTOOL= yes
@@ -31,7 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
- 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+ @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
.include <bsd.port.mk>