aboutsummaryrefslogtreecommitdiff
path: root/devel/libglade
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-08-22 03:54:24 +0000
committerSteve Price <steve@FreeBSD.org>1999-08-22 03:54:24 +0000
commit944e57a05fa9e1cb5743f409d6bdd2c95e7b0b65 (patch)
tree9a870518d45406938078724d61f5f14280d71c42 /devel/libglade
parente8a9c284731b7d701fd23beb995aede6a2ddcff9 (diff)
downloadports-944e57a05fa9e1cb5743f409d6bdd2c95e7b0b65.tar.gz
ports-944e57a05fa9e1cb5743f409d6bdd2c95e7b0b65.zip
Initial import of the GNOME glade library version 0.3.
A library that allows you to load GLADE interfaces at runtime (you don't have to generate stubs with GLADE before hand). This way you can change the look of your application without recompiling. This way you can write the logic behind the interface separately from the code to build the interface, so changing the interface is not so much of a problem. PR: 12781 (12 of 19) Submitted by: Ade Lovett <ade@lovett.com>
Notes
Notes: svn path=/head/; revision=20868
Diffstat (limited to 'devel/libglade')
-rw-r--r--devel/libglade/Makefile28
-rw-r--r--devel/libglade/distinfo1
-rw-r--r--devel/libglade/files/patch-aa11
-rw-r--r--devel/libglade/files/patch-ab17
-rw-r--r--devel/libglade/pkg-comment1
-rw-r--r--devel/libglade/pkg-descr5
-rw-r--r--devel/libglade/pkg-plist17
7 files changed, 80 insertions, 0 deletions
diff --git a/devel/libglade/Makefile b/devel/libglade/Makefile
new file mode 100644
index 000000000000..cf219818674c
--- /dev/null
+++ b/devel/libglade/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libglade
+# Version required: 0.3
+# Date created: 18 August 1999
+# Whom: Ade Lovett <ade@lovett.com>
+#
+# $Id$
+#
+
+DISTNAME= libglade-0.3
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/libglade
+
+MAINTAINER= ade@lovett.com
+
+LIB_DEPENDS= gnome.2:${PORTSDIR}/x11/gnomelibs \
+ xml.4:${PORTSDIR}/textproc/libxml
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_PERL5= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/devel/libglade/distinfo b/devel/libglade/distinfo
new file mode 100644
index 000000000000..33f940549b7c
--- /dev/null
+++ b/devel/libglade/distinfo
@@ -0,0 +1 @@
+MD5 (libglade-0.3.tar.gz) = aa90727305fc775374849ee2691d10d1
diff --git a/devel/libglade/files/patch-aa b/devel/libglade/files/patch-aa
new file mode 100644
index 000000000000..85ec92c1cbac
--- /dev/null
+++ b/devel/libglade/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jul 13 11:44:47 1999
++++ configure Tue Jul 13 11:46:11 1999
+@@ -2049,7 +2049,7 @@
+ test -n "$AWK" && break
+ done
+
+-GDK_KEYSYMS="`$GTK_CONFIG --prefix`/include/gdk/gdkkeysyms.h"
++GDK_KEYSYMS="`$GTK_CONFIG --prefix`/include/gtk12/gdk/gdkkeysyms.h"
+
+
+ # Extract the first word of "xml-config", so it can be a program name with args.
diff --git a/devel/libglade/files/patch-ab b/devel/libglade/files/patch-ab
new file mode 100644
index 000000000000..83ac017513a8
--- /dev/null
+++ b/devel/libglade/files/patch-ab
@@ -0,0 +1,17 @@
+--- Makefile.in.orig Mon Aug 9 05:38:39 1999
++++ Makefile.in Wed Aug 18 11:17:53 1999
+@@ -131,12 +131,12 @@
+ bin_SCRIPTS = libglade-config libglade-xgettext
+ noinst_PROGRAMS = test-libglade
+ test_libglade_LDADD = $(THE_LIBS) $(XML_LIBS)
+-SUBDIRS = intl po macros glade doc
++SUBDIRS = intl po macros glade
+
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = libglade.m4
+
+-confexecdir = $(libdir)
++confexecdir = $(prefix)/etc
+ confexec_DATA = libgladeConf.sh
+
+ test_libglade_SOURCES = test-libglade.c
diff --git a/devel/libglade/pkg-comment b/devel/libglade/pkg-comment
new file mode 100644
index 000000000000..00fc39e87a45
--- /dev/null
+++ b/devel/libglade/pkg-comment
@@ -0,0 +1 @@
+GNOME glade library
diff --git a/devel/libglade/pkg-descr b/devel/libglade/pkg-descr
new file mode 100644
index 000000000000..dd6a386e94cd
--- /dev/null
+++ b/devel/libglade/pkg-descr
@@ -0,0 +1,5 @@
+A library that allows you to load GLADE interfaces at runtime (you don't
+have to generate stubs with GLADE before hand). This way you can change
+the look of your application without recompiling. This way you can write
+the logic behind the interface separately from the code to build the
+interface, so changing the interface is not so much of a problem.
diff --git a/devel/libglade/pkg-plist b/devel/libglade/pkg-plist
new file mode 100644
index 000000000000..0f1a6859ecc2
--- /dev/null
+++ b/devel/libglade/pkg-plist
@@ -0,0 +1,17 @@
+bin/libglade-config
+bin/libglade-xgettext
+etc/libgladeConf.sh
+include/glade/glade.h
+include/glade/glade-xml.h
+include/glade/glade-build.h
+include/glade/glade-widget-tree.h
+lib/libglade.a
+lib/libglade.so
+lib/libglade.so.1
+lib/libglade-gnome.a
+lib/libglade-gnome.so
+lib/libglade-gnome.so.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+share/aclocal/libglade.m4
+@dirrm include/glade