aboutsummaryrefslogtreecommitdiff
path: root/devel/libgsf
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-22 20:56:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-22 20:56:52 +0000
commit6b8fe3db6b25f7bcd01a20760cb167db1cbb4d2e (patch)
tree89ef1f1c6a4870e8316e08015ab4ee035b7f8ab2 /devel/libgsf
parentccac9ebe1b29570efcf236b4f38e6747a4587b1d (diff)
downloadports-6b8fe3db6b25f7bcd01a20760cb167db1cbb4d2e.tar.gz
ports-6b8fe3db6b25f7bcd01a20760cb167db1cbb4d2e.zip
- Split libgsf port to two standalone ports:
* devel/libgsf is the old port minus gsf-gnome bits * devel/libgsf-gnome contains libgsf-gnome-1 library and it's header files This greatly reduces number of dependencies for ports that was using only non-gnome part of this library. - Point USE_GNOME parameter libgsf to GNOME-less port and create new parameter libgsf_gnome for libgsf-gnome port. - Convert all consumers of libgsf-gnome-1 library to depend on libgsf-gnome port (read all as: Gnumeric) PR: ports/63851 (in the spirit of) Submitted by: Sybolt de Boer <sybolt@xs4all.nl> Prodded by: lofi (KDE team) Reviewed by: marcus (GNOME team)
Notes
Notes: svn path=/head/; revision=109734
Diffstat (limited to 'devel/libgsf')
-rw-r--r--devel/libgsf/Makefile13
-rw-r--r--devel/libgsf/files/patch-gsf-gnome-Makefile.in46
-rw-r--r--devel/libgsf/pkg-plist10
3 files changed, 53 insertions, 16 deletions
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
index f6a8485a000d..55fa4cbb751e 100644
--- a/devel/libgsf/Makefile
+++ b/devel/libgsf/Makefile
@@ -7,13 +7,14 @@
PORTNAME= libgsf
PORTVERSION= 1.9.1
-CATEGORIES= devel gnome
+PORTREVISION= 1
+CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= An extensible i/o abstraction for dealing with structured file formats
+COMMENT?= An extensible i/o abstraction for dealing with structured file formats
.if !exists(/usr/lib/libbz2.so.1)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
@@ -22,11 +23,11 @@ LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
USE_BZIP2= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack libbonobo gnomevfs2
+USE_GNOME?= gnomehack glib20 libxml2
USE_LIBTOOL_VER= 13
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc --with-gnome --with-bz2
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ARGS?= --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc --without-gnome --with-bz2
+CONFIGURE_ENV?= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/devel/libgsf/files/patch-gsf-gnome-Makefile.in b/devel/libgsf/files/patch-gsf-gnome-Makefile.in
new file mode 100644
index 000000000000..4051a60c2310
--- /dev/null
+++ b/devel/libgsf/files/patch-gsf-gnome-Makefile.in
@@ -0,0 +1,46 @@
+--- gsf-gnome/Makefile.in.orig Sat May 22 18:56:24 2004
++++ gsf-gnome/Makefile.in Sat May 22 18:57:23 2004
+@@ -170,7 +170,7 @@
+
+ lib_LTLIBRARIES = $(target_libgsf_gnome)
+
+-libgsf_gnome_1_la_LIBADD = $(top_builddir)/gsf/libgsf-1.la $(LIBGSF_GNOME_LIBS)
++libgsf_gnome_1_la_LIBADD = $(LIBGSF_GNOME_LIBS)
+ libgsf_gnome_1_la_LDFLAGS = -version-info $(VERSION_INFO)
+ libgsf_gnome_1_la_SOURCES = \
+ gsf-input-gnomevfs.c \
+@@ -199,7 +199,7 @@
+ CONFIG_CLEAN_FILES =
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+
+-libgsf_gnome_1_la_DEPENDENCIES = $(top_builddir)/gsf/libgsf-1.la
++libgsf_gnome_1_la_DEPENDENCIES =
+ am_libgsf_gnome_1_la_OBJECTS = gsf-input-gnomevfs.lo \
+ gsf-output-gnomevfs.lo gsf-input-bonobo.lo gsf-output-bonobo.lo \
+ gsf-shared-bonobo-stream.lo
+--- gsf-gnome/Makefile.in.orig Sat May 22 19:26:16 2004
++++ gsf-gnome/Makefile.in Sat May 22 19:30:30 2004
+@@ -179,14 +179,15 @@
+ gsf-output-bonobo.c \
+ gsf-shared-bonobo-stream.c
+
+-
+-libgsf_gnome_1_includedir = $(includedir)/libgsf-1/gsf-gnome
+-libgsf_gnome_1_include_HEADERS = \
+- gsf-input-gnomevfs.h \
+- gsf-output-gnomevfs.h \
+- gsf-input-bonobo.h \
+- gsf-output-bonobo.h \
+- gsf-shared-bonobo-stream.h
++@WITH_LIBGSF_GNOME_FALSE@libgsf_gnome_1_includedir =
++@WITH_LIBGSF_GNOME_FALSE@libgsf_gnome_1_include_HEADERS =
++@WITH_LIBGSF_GNOME_TRUE@libgsf_gnome_1_includedir = $(includedir)/libgsf-1/gsf-gnome
++@WITH_LIBGSF_GNOME_TRUE@libgsf_gnome_1_include_HEADERS = \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-input-gnomevfs.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-output-gnomevfs.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-input-bonobo.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-output-bonobo.h \
++@WITH_LIBGSF_GNOME_TRUE@ gsf-shared-bonobo-stream.h
+
+
+ # include these just in case we are building a tarball without
diff --git a/devel/libgsf/pkg-plist b/devel/libgsf/pkg-plist
index 335520ea105b..1b59f7c061e5 100644
--- a/devel/libgsf/pkg-plist
+++ b/devel/libgsf/pkg-plist
@@ -1,8 +1,3 @@
-include/libgsf-1/gsf-gnome/gsf-input-bonobo.h
-include/libgsf-1/gsf-gnome/gsf-input-gnomevfs.h
-include/libgsf-1/gsf-gnome/gsf-output-bonobo.h
-include/libgsf-1/gsf-gnome/gsf-output-gnomevfs.h
-include/libgsf-1/gsf-gnome/gsf-shared-bonobo-stream.h
include/libgsf-1/gsf-win32/gsf-input-win32.h
include/libgsf-1/gsf-win32/gsf-output-win32.h
include/libgsf-1/gsf/gsf-doc-meta-data.h
@@ -41,11 +36,7 @@ include/libgsf-1/gsf/gsf.h
lib/libgsf-1.a
lib/libgsf-1.so
lib/libgsf-1.so.10
-lib/libgsf-gnome-1.a
-lib/libgsf-gnome-1.so
-lib/libgsf-gnome-1.so.10
libdata/pkgconfig/libgsf-1.pc
-libdata/pkgconfig/libgsf-gnome-1.pc
share/doc/gsf/api.html
share/doc/gsf/gsf-Bononbo.html
share/doc/gsf/gsf-Compression.html
@@ -80,6 +71,5 @@ share/doc/gsf/style.css
share/doc/gsf/up.png
@dirrm share/doc/gsf
@dirrm include/libgsf-1/gsf-win32
-@dirrm include/libgsf-1/gsf-gnome
@dirrm include/libgsf-1/gsf
@dirrm include/libgsf-1