aboutsummaryrefslogtreecommitdiff
path: root/devel/libgsf
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-09-11 12:12:58 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-09-11 12:12:58 +0000
commit945e7059e8faddcd4b4ab472351bb1d492be6cc0 (patch)
tree23db267ede4f8850726e89e6687c4f7b7c89b610 /devel/libgsf
parentdc7ea47235e4b28cc5dcb9e3da6181e3e5e83304 (diff)
downloadports-945e7059e8faddcd4b4ab472351bb1d492be6cc0.tar.gz
ports-945e7059e8faddcd4b4ab472351bb1d492be6cc0.zip
Add libgsf 1.3.0, an extensible i/o abstraction library for dealing with
structured file formats.
Notes
Notes: svn path=/head/; revision=66121
Diffstat (limited to 'devel/libgsf')
-rw-r--r--devel/libgsf/Makefile32
-rw-r--r--devel/libgsf/distinfo1
-rw-r--r--devel/libgsf/files/patch-configure22
-rw-r--r--devel/libgsf/pkg-comment1
-rw-r--r--devel/libgsf/pkg-descr2
-rw-r--r--devel/libgsf/pkg-plist79
6 files changed, 137 insertions, 0 deletions
diff --git a/devel/libgsf/Makefile b/devel/libgsf/Makefile
new file mode 100644
index 000000000000..d19054d11488
--- /dev/null
+++ b/devel/libgsf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libgsf
+# Date created: 11 September 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgsf
+PORTVERSION= 1.3.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= bonobo-2.0:${PORTSDIR}/devel/libbonobo \
+ gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc --with-gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+.include <bsd.port.mk>
diff --git a/devel/libgsf/distinfo b/devel/libgsf/distinfo
new file mode 100644
index 000000000000..14256a2e21eb
--- /dev/null
+++ b/devel/libgsf/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/libgsf-1.3.0.tar.bz2) = 49bae0d52e91e98a0c635b595584aa8e
diff --git a/devel/libgsf/files/patch-configure b/devel/libgsf/files/patch-configure
new file mode 100644
index 000000000000..a6571af2dadb
--- /dev/null
+++ b/devel/libgsf/files/patch-configure
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- configure 2002/09/11 10:13:57 1.1
++++ configure 2002/09/11 10:14:44
+@@ -7245,6 +7245,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8011,7 +8012,7 @@
+ else
+ echo "$as_me: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+-need_posix=yes
++need_posix=no
+ fi
+ rm -f conftest.$ac_objext conftest.$ac_ext
+ CFLAGS="$saved_CFLAGS"
diff --git a/devel/libgsf/pkg-comment b/devel/libgsf/pkg-comment
new file mode 100644
index 000000000000..959a72513e66
--- /dev/null
+++ b/devel/libgsf/pkg-comment
@@ -0,0 +1 @@
+An extensible i/o abstraction for dealing with structured file formats
diff --git a/devel/libgsf/pkg-descr b/devel/libgsf/pkg-descr
new file mode 100644
index 000000000000..258f82307aaa
--- /dev/null
+++ b/devel/libgsf/pkg-descr
@@ -0,0 +1,2 @@
+The library aims to provide an efficient extensible i/o abstraction for
+dealing with different structured file formats.
diff --git a/devel/libgsf/pkg-plist b/devel/libgsf/pkg-plist
new file mode 100644
index 000000000000..b04a0990d9f5
--- /dev/null
+++ b/devel/libgsf/pkg-plist
@@ -0,0 +1,79 @@
+include/libgsf-1/gsf-gnome/gsf-input-bonobo.h
+include/libgsf-1/gsf-gnome/gsf-input-gnomevfs.h
+include/libgsf-1/gsf-gnome/gsf-output-gnomevfs.h
+include/libgsf-1/gsf-gnome/gsf-shared-bonobo-stream.h
+include/libgsf-1/gsf/gsf-doc-meta-data.h
+include/libgsf-1/gsf/gsf-impl-utils.h
+include/libgsf-1/gsf/gsf-infile-msole.h
+include/libgsf-1/gsf/gsf-infile-msvba.h
+include/libgsf-1/gsf/gsf-infile-zip.h
+include/libgsf-1/gsf/gsf-infile.h
+include/libgsf-1/gsf/gsf-input-gzip.h
+include/libgsf-1/gsf/gsf-input-memory.h
+include/libgsf-1/gsf/gsf-input-stdio.h
+include/libgsf-1/gsf/gsf-input-textline.h
+include/libgsf-1/gsf/gsf-input.h
+include/libgsf-1/gsf/gsf-io-context.h
+include/libgsf-1/gsf/gsf-libxml.h
+include/libgsf-1/gsf/gsf-msole-metadata.h
+include/libgsf-1/gsf/gsf-outfile-msole.h
+include/libgsf-1/gsf/gsf-outfile.h
+include/libgsf-1/gsf/gsf-output-stdio.h
+include/libgsf-1/gsf/gsf-output.h
+include/libgsf-1/gsf/gsf-timestamp.h
+include/libgsf-1/gsf/gsf-utils.h
+include/libgsf-1/gsf/gsf.h
+lib/libgsf-1.a
+lib/libgsf-1.so
+lib/libgsf-1.so.4
+lib/libgsf-gnome-1.a
+lib/libgsf-gnome-1.so
+lib/libgsf-gnome-1.so.4
+libdata/pkgconfig/libgsf-1.pc
+libdata/pkgconfig/libgsf-gnome-1.pc
+share/doc/gsf/gsf-gsf-impl-utils.html
+share/doc/gsf/gsf-gsf-infile-msole.html
+share/doc/gsf/gsf-gsf-infile-zip.html
+share/doc/gsf/gsf-gsf-infile.html
+share/doc/gsf/gsf-gsf-input-gnomevfs.html
+share/doc/gsf/gsf-gsf-input-gzip.html
+share/doc/gsf/gsf-gsf-input-memory.html
+share/doc/gsf/gsf-gsf-input-stdio.html
+share/doc/gsf/gsf-gsf-input-textline.html
+share/doc/gsf/gsf-gsf-input.html
+share/doc/gsf/gsf-gsf-libxml.html
+share/doc/gsf/gsf-gsf-outfile.html
+share/doc/gsf/gsf-gsf-output.html
+share/doc/gsf/gsf-gsf-shared-memory.html
+share/doc/gsf/gsf-gsf-utils.html
+share/doc/gsf/gsf-gsf.html
+share/doc/gsf/gsf-gsfinfile.html
+share/doc/gsf/gsf-gsfinput.html
+share/doc/gsf/gsf-gsfoutput.html
+share/doc/gsf/gsf.html
+share/doc/gsf/i1970.html
+share/doc/gsf/index.html
+share/doc/gsf/index.sgml
+share/doc/gsf/r1024.html
+share/doc/gsf/r1192.html
+share/doc/gsf/r1282.html
+share/doc/gsf/r14.html
+share/doc/gsf/r1414.html
+share/doc/gsf/r1487.html
+share/doc/gsf/r1520.html
+share/doc/gsf/r171.html
+share/doc/gsf/r1713.html
+share/doc/gsf/r1757.html
+share/doc/gsf/r1879.html
+share/doc/gsf/r305.html
+share/doc/gsf/r338.html
+share/doc/gsf/r437.html
+share/doc/gsf/r530.html
+share/doc/gsf/r56.html
+share/doc/gsf/r792.html
+share/doc/gsf/r913.html
+share/doc/gsf/r931.html
+@dirrm share/doc/gsf
+@dirrm include/libgsf-1/gsf-gnome
+@dirrm include/libgsf-1/gsf
+@dirrm include/libgsf-1