aboutsummaryrefslogtreecommitdiff
path: root/devel/libkolab/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-09-11 16:46:03 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-09-11 16:46:03 +0000
commit3ba154f4ec942d4fd6a371b3ae8b4955564b9236 (patch)
treed6052bf0c8bf761e8a3365124d8693e0499b9b2f /devel/libkolab/Makefile
parentff3a5abc43762ca301861224fd2a8a8184ae64a1 (diff)
downloadports-3ba154f4ec942d4fd6a371b3ae8b4955564b9236.tar.gz
ports-3ba154f4ec942d4fd6a371b3ae8b4955564b9236.zip
Update devel/libkolab to 0.6.3.
Note, that 0.6.3 is the last version for Qt4. From 1.0.0 on libkolab uses Qt5 -- so we can't stop portscout from complaining :) While here, make stage-qa happy. > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libxerces-c-3.1.so from textproc/xerces-c3 but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libxerces-c-3.1.so:textproc/xerces-c3 > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libboost_thread.so.1.55.0 from devel/boost-libs but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libboost_thread.so:devel/boost-libs > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libboost_system.so.1.55.0 from devel/boost-libs but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libboost_system.so:devel/boost-libs > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libboost_chrono.so.1.55.0 from devel/boost-libs but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libboost_chrono.so:devel/boost-libs > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libboost_date_time.so.1.55.0 from devel/boost-libs but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libboost_date_time.so:devel/boost-libs > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libboost_atomic.so.1.55.0 from devel/boost-libs but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libboost_atomic.so:devel/boost-libs > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/libcurl.so.4 from ftp/curl but it is not declared as a dependency > Warning: you need LIB_DEPENDS+=libcurl.so:ftp/curl > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/qt4/libQtNetwork.so.4 from net/qt4-network but it is not declared as a dependency > Warning: you need USE_QT4+=network > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/qt4/libQtDBus.so.4 from devel/dbus-qt4 but it is not declared as a dependency > Warning: you need USE_QT4+=dbus > Error: /usr/local/lib/libkolab.so.0.6.3 is linked to /usr/local/lib/qt4/libQtSvg.so.4 from graphics/qt4-svg but it is not declared as a dependency > Warning: you need USE_QT4+=svg Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7856
Notes
Notes: svn path=/head/; revision=421840
Diffstat (limited to 'devel/libkolab/Makefile')
-rw-r--r--devel/libkolab/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/libkolab/Makefile b/devel/libkolab/Makefile
index 96009a65f0c9..530b2118cf85 100644
--- a/devel/libkolab/Makefile
+++ b/devel/libkolab/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libkolab
-PORTVERSION= 0.5.3
+PORTVERSION= 0.6.3
CATEGORIES= devel kde
MASTER_SITES= http://mirror.kolabsys.com/pub/releases/
@@ -12,7 +12,10 @@ COMMENT= Advanced Kolab Object Handling Library
# itself to be LGPL3-licensed (and so are all the installed headers).
LICENSE= LGPL3
-LIB_DEPENDS= libkolabxml.so:textproc/libkolabxml
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libcurl.so:ftp/curl \
+ libkolabxml.so:textproc/libkolabxml \
+ libxerces-c-3.1.so:textproc/xerces-c3
# TODO: Conditionally enable the bindings based on OPTIONs.
CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
@@ -22,7 +25,7 @@ CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
USES= cmake:outsource kde:4
USE_KDE= automoc4 kdelibs pimlibs
USE_LDCONFIG= yes
-USE_QT4= corelib gui xml \
+USE_QT4= corelib dbus gui network svg xml \
moc_build qmake_build rcc_build uic_build
PLIST_SUB= SHLIB_VER=${PORTVERSION}