aboutsummaryrefslogtreecommitdiff
path: root/devel/libmaa
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-01-26 05:39:51 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-01-26 05:39:51 +0000
commitd49664bae724c70263edf6453a30cd3407052a20 (patch)
tree4fe8db7b6ac958b5bc21d343f61b909693aafd3a /devel/libmaa
parenteda9d1c2b5f5bee5788b3be3b4d4240c65b32e2e (diff)
downloadports-d49664bae724c70263edf6453a30cd3407052a20.tar.gz
ports-d49664bae724c70263edf6453a30cd3407052a20.zip
The LIBMAA library provides many low-level data structures which are
helpful for writing compilers, including hash tables, sets, lists, debugging support, and memory management. Although LIBMAA was designed and implemented as a foundation for the Khepera Transformation System, the data structures are generally applicable to a wide range of programming problems. The memory management routines are especially helpful for improving the performance of memory-intensive applications. WWW: http://www.dict.org/
Notes
Notes: svn path=/head/; revision=206225
Diffstat (limited to 'devel/libmaa')
-rw-r--r--devel/libmaa/Makefile39
-rw-r--r--devel/libmaa/distinfo3
-rw-r--r--devel/libmaa/files/patch-getopt.c11
-rw-r--r--devel/libmaa/files/patch-strtol.c11
-rw-r--r--devel/libmaa/pkg-descr11
-rw-r--r--devel/libmaa/pkg-plist10
6 files changed, 85 insertions, 0 deletions
diff --git a/devel/libmaa/Makefile b/devel/libmaa/Makefile
new file mode 100644
index 000000000000..35433dc4e50c
--- /dev/null
+++ b/devel/libmaa/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: libmaa
+# Date created: 2008/01/26
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmaa
+PORTVERSION= 1.10.10
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dict
+DISTNAME= dictd-${PORTVERSION}
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Provides a few data structures and helpful functions
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-local-zlib --with-cflags="${CFLAGS}" \
+ --with-etcdir=${PREFIX}/etc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/dictd-${PORTVERSION}/libmaa
+ALL_TARGET= lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in COPYING.LIB README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/doc/libmaa.600dpi.ps ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libmaa/distinfo b/devel/libmaa/distinfo
new file mode 100644
index 000000000000..ebee940b22a3
--- /dev/null
+++ b/devel/libmaa/distinfo
@@ -0,0 +1,3 @@
+MD5 (dictd-1.10.10.tar.gz) = 9698b15af5919bd1c930978774310fc4
+SHA256 (dictd-1.10.10.tar.gz) = 0ec57fb93665ae539a1a12541266ca283dfa20b3597127b53de29e668fd28870
+SIZE (dictd-1.10.10.tar.gz) = 693972
diff --git a/devel/libmaa/files/patch-getopt.c b/devel/libmaa/files/patch-getopt.c
new file mode 100644
index 000000000000..6d38c71fb736
--- /dev/null
+++ b/devel/libmaa/files/patch-getopt.c
@@ -0,0 +1,11 @@
+--- getopt.c.orig 2008-01-26 13:11:10.000000000 +0800
++++ getopt.c 2008-01-26 13:14:27.000000000 +0800
+@@ -44,7 +44,7 @@
+
+ #include <stdio.h>
+
+-#ifdef __sparc__
++#if defined(__sparc) && !defined(__FreeBSD__)
+ extern int fprintf( FILE *, const char *, ... );
+ extern int strncmp( const char *, const char *, int n );
+ #endif
diff --git a/devel/libmaa/files/patch-strtol.c b/devel/libmaa/files/patch-strtol.c
new file mode 100644
index 000000000000..646f62676f57
--- /dev/null
+++ b/devel/libmaa/files/patch-strtol.c
@@ -0,0 +1,11 @@
+--- strtol.c.orig 1995-08-25 12:59:08.000000000 +0800
++++ strtol.c 2008-01-26 13:15:27.000000000 +0800
+@@ -25,7 +25,7 @@
+ #include <stdlib.h>
+ #include <errno.h>
+
+-#ifdef __sparc__
++#if defined(__sparc) && !defined(__FreeBSD__)
+ extern int errno;
+ extern int toupper(int);
+ #endif
diff --git a/devel/libmaa/pkg-descr b/devel/libmaa/pkg-descr
new file mode 100644
index 000000000000..07c85b7fb589
--- /dev/null
+++ b/devel/libmaa/pkg-descr
@@ -0,0 +1,11 @@
+The LIBMAA library provides many low-level data structures which are
+helpful for writing compilers, including hash tables, sets, lists,
+debugging support, and memory management. Although LIBMAA was
+designed and implemented as a foundation for the Khepera
+Transformation System, the data structures are generally applicable to
+a wide range of programming problems.
+
+The memory management routines are especially helpful for improving the
+performance of memory-intensive applications.
+
+WWW: http://www.dict.org/
diff --git a/devel/libmaa/pkg-plist b/devel/libmaa/pkg-plist
new file mode 100644
index 000000000000..0415389669f8
--- /dev/null
+++ b/devel/libmaa/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+include/maa.h
+lib/libmaa.la
+lib/libmaa.so.1
+lib/libmaa.so
+lib/libmaa.a
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.LIB
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/libmaa.600dpi.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%