aboutsummaryrefslogtreecommitdiff
path: root/devel/libmatheval
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-07-04 17:58:23 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-07-04 17:58:23 +0000
commit7d34e059f3f9fa91709978bc451f261f90bae511 (patch)
tree36fe42e5ab41285a10e30d18daba3cb1e9ead8f6 /devel/libmatheval
parent0b72cbc739b178dffefdb494ec7858a312030d19 (diff)
downloadports-7d34e059f3f9fa91709978bc451f261f90bae511.tar.gz
ports-7d34e059f3f9fa91709978bc451f261f90bae511.zip
New port: GNU libmatheval.
GNU libmatheval is a library which contains several procedures that make it possible to create an in-memory tree from the string representation of a mathematical function over single or multiple variables. This tree can be used later to evaluate a function for specified variable values, to create a corresponding tree for the function derivative over a specified variable or to write a textual tree representation to a specified string. The library exposes C and Fortran 77 interfaces.
Notes
Notes: svn path=/head/; revision=112915
Diffstat (limited to 'devel/libmatheval')
-rw-r--r--devel/libmatheval/Makefile27
-rw-r--r--devel/libmatheval/distinfo2
-rw-r--r--devel/libmatheval/files/patch-doc-libmatheval.texi14
-rw-r--r--devel/libmatheval/pkg-descr9
-rw-r--r--devel/libmatheval/pkg-plist5
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/libmatheval/Makefile b/devel/libmatheval/Makefile
new file mode 100644
index 000000000000..ea10fcf6288b
--- /dev/null
+++ b/devel/libmatheval/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libmatheval
+# Date created: 4 July 2004
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmatheval
+PORTVERSION= 1.1.0
+CATEGORIES= devel math
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A library of procedures for evaluating mathematical functions
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= MAKEINFO="/usr/bin/makeinfo --no-split"
+INSTALLS_SHLIB= yes
+
+INFO= libmatheval
+
+post-patch:
+ ${RM} ${WRKSRC}/doc/libmatheval.info
+
+.include <bsd.port.mk>
diff --git a/devel/libmatheval/distinfo b/devel/libmatheval/distinfo
new file mode 100644
index 000000000000..8af15753f03a
--- /dev/null
+++ b/devel/libmatheval/distinfo
@@ -0,0 +1,2 @@
+MD5 (libmatheval-1.1.0.tar.gz) = d91f255de761cd8eef285c48d7f42f1b
+SIZE (libmatheval-1.1.0.tar.gz) = 479997
diff --git a/devel/libmatheval/files/patch-doc-libmatheval.texi b/devel/libmatheval/files/patch-doc-libmatheval.texi
new file mode 100644
index 000000000000..665a6fab9898
--- /dev/null
+++ b/devel/libmatheval/files/patch-doc-libmatheval.texi
@@ -0,0 +1,14 @@
+--- doc/libmatheval.texi.orig Sat Jul 3 13:51:10 2004
++++ doc/libmatheval.texi Sun Jul 4 21:45:25 2004
+@@ -9,6 +9,11 @@
+ @include version.texi
+ @syncodeindex fn cp
+
++@dircategory Programming & development tools
++@direntry
++* libmatheval: (libmatheval). A library for evaluating mathematical functions.
++@end direntry
++
+ @ifnottex
+ This file documents GNU @code{libmatheval} library.
+
diff --git a/devel/libmatheval/pkg-descr b/devel/libmatheval/pkg-descr
new file mode 100644
index 000000000000..e371a3dc011e
--- /dev/null
+++ b/devel/libmatheval/pkg-descr
@@ -0,0 +1,9 @@
+GNU libmatheval is a library which contains several procedures that make
+it possible to create an in-memory tree from the string representation
+of a mathematical function over single or multiple variables. This tree
+can be used later to evaluate a function for specified variable values,
+to create a corresponding tree for the function derivative over a
+specified variable or to write a textual tree representation to a
+specified string. The library exposes C and Fortran 77 interfaces.
+
+WWW: http://www.gnu.org/software/libmatheval/
diff --git a/devel/libmatheval/pkg-plist b/devel/libmatheval/pkg-plist
new file mode 100644
index 000000000000..6c8d8a85ffdd
--- /dev/null
+++ b/devel/libmatheval/pkg-plist
@@ -0,0 +1,5 @@
+include/matheval.h
+lib/libmatheval.a
+lib/libmatheval.la
+lib/libmatheval.so
+lib/libmatheval.so.1