aboutsummaryrefslogtreecommitdiff
path: root/devel/libmba
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-24 07:59:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-24 07:59:37 +0000
commit41619882b2fe8406cfbb9fa365b33d7603830957 (patch)
tree4109d3d0cec629e29a55bd25794a9f67ef793d5b /devel/libmba
parent9d8e202f4c69e142a2ef7d4f0d307a540985f77c (diff)
downloadports-41619882b2fe8406cfbb9fa365b33d7603830957.tar.gz
ports-41619882b2fe8406cfbb9fa365b33d7603830957.zip
add libmba 0.3.6
A collection of C modules potentially useful to any project required by textproc/domc 0.6.0 Approved by: kris
Notes
Notes: svn path=/head/; revision=67080
Diffstat (limited to 'devel/libmba')
-rw-r--r--devel/libmba/Makefile35
-rw-r--r--devel/libmba/distinfo1
-rw-r--r--devel/libmba/files/patch-Makefile33
-rw-r--r--devel/libmba/pkg-comment1
-rw-r--r--devel/libmba/pkg-descr7
-rw-r--r--devel/libmba/pkg-plist11
6 files changed, 88 insertions, 0 deletions
diff --git a/devel/libmba/Makefile b/devel/libmba/Makefile
new file mode 100644
index 000000000000..3c37b05f4957
--- /dev/null
+++ b/devel/libmba/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: libmba
+# Date Created: Sep 24, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmba
+PORTVERSION= 0.3.6
+CATEGORIES= devel
+MASTER_SITES= http://users.erols.com/mballen/libmba/src/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
+
+SHLIB_MAJOR= 0
+
+USE_REINPLACE= yes
+CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+MAKE_ENV= SHLIB_MAJOR="${SHLIB_MAJOR}" INSTDIR=${PREFIX}
+ALL_TARGET= # empty
+INSTALLS_SHLIB= yes
+
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+MANCOMPRESSED= yes
+MAN3= domnode.3m hexdump.3m msgno.3m hashmap.3m linkedlist.3m stack.3m
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" \
+ -e "s|gcc|${CC}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libmba/distinfo b/devel/libmba/distinfo
new file mode 100644
index 000000000000..0569961ee958
--- /dev/null
+++ b/devel/libmba/distinfo
@@ -0,0 +1 @@
+MD5 (libmba-0.3.6.tar.gz) = ea368594e410da2ae80b21c805fb8968
diff --git a/devel/libmba/files/patch-Makefile b/devel/libmba/files/patch-Makefile
new file mode 100644
index 000000000000..822390b4fd77
--- /dev/null
+++ b/devel/libmba/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig Fri Mar 29 17:23:23 2002
++++ Makefile Tue Sep 24 15:51:24 2002
+@@ -3,9 +3,9 @@
+ libdir = /usr/lib
+ mandir = /usr/man
+ LIBNAME = mba
+-SONAME = lib$(LIBNAME).so.0.3.6
+-SOVERSION = lib$(LIBNAME).so.0.3
+-CFLAGS = -Wall -DMSGNO $(RPM_OPT_FLAGS)
++SONAME = lib$(LIBNAME).so.${SHLIB_MAJOR}
++SOVERSION = lib$(LIBNAME).so.${SHLIB_MAJOR}
++CFLAGS += -Wall -DMSGNO $(RPM_OPT_FLAGS)
+ OBJS = src/stack.o src/linkedlist.o src/hashmap.o src/profile.o src/hexdump.o src/msgno.o src/domnode.o src/mbs.o
+ HDRS = src/msgno.h src/stack.h src/linkedlist.h src/hashmap.h src/hexdump.h src/domnode.h src/profile.h src/mbs.h
+ MAN = msgno.3m.gz stack.3m.gz linkedlist.3m.gz hashmap.3m.gz hexdump.3m.gz domnode.3m.gz
+@@ -17,13 +17,12 @@
+
+ install: $(SONAME)
+ install -d $(libdir)
+- install -m 755 $(SONAME) $(libdir)
+- cd $(libdir) && ln -sf $(SONAME) $(SOVERSION) && ln -sf $(SONAME) lib$(LIBNAME).so
++ ${BSD_INSTALL_DATA} $(SONAME) $(INSTDIR)/lib
++ cd $(INSTDIR)/lib ; ln -sf $(SONAME) $(INSTDIR)/lib/lib$(LIBNAME).so
+ install -d $(includedir)/mba
+- install -m 444 $(HDRS) $(includedir)/mba
++ ${BSD_INSTALL_DATA} $(HDRS) $(includedir)/mba
+ install -d $(mandir)/man3
+- install -m 444 docs/man/* $(mandir)/man3
+- -/sbin/ldconfig $(libdir)
++ ${BSD_INSTALL_MAN} docs/man/* $(mandir)/man3
+
+ clean:
+ rm -rf $(includedir)/mba
diff --git a/devel/libmba/pkg-comment b/devel/libmba/pkg-comment
new file mode 100644
index 000000000000..9836439bea0f
--- /dev/null
+++ b/devel/libmba/pkg-comment
@@ -0,0 +1 @@
+A collection of C modules potentially useful to any project
diff --git a/devel/libmba/pkg-descr b/devel/libmba/pkg-descr
new file mode 100644
index 000000000000..ba99a1578b4e
--- /dev/null
+++ b/devel/libmba/pkg-descr
@@ -0,0 +1,7 @@
+The libmba package is a collection of mostly independent C modules potentially
+useful to any project. There are hashmap, linkedlist, and stack ADTs, a DOM-
+like interface that can load and store XML files for simple XML processing, a
+module for managing error codes and associated messages across separate C
+libraries, and more.
+
+WWW: http://users.erols.com/mballen/libmba/
diff --git a/devel/libmba/pkg-plist b/devel/libmba/pkg-plist
new file mode 100644
index 000000000000..28caa9babdf8
--- /dev/null
+++ b/devel/libmba/pkg-plist
@@ -0,0 +1,11 @@
+include/mba/domnode.h
+include/mba/hashmap.h
+include/mba/hexdump.h
+include/mba/linkedlist.h
+include/mba/mbs.h
+include/mba/msgno.h
+include/mba/profile.h
+include/mba/stack.h
+@dirrm include/mba
+lib/libmba.so
+lib/libmba.so.%%SHLIB_MAJOR%%