aboutsummaryrefslogtreecommitdiff
path: root/devel/libmsocket
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-15 10:01:56 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-15 10:01:56 +0000
commit4913cc9d6f11018530c8efdcab05741fb90322f7 (patch)
treec05972485168a482eca0e7b3949c9e2317201363 /devel/libmsocket
parent48d90f8ac3b669a83618ab66c99c7b8b764240e0 (diff)
downloadports-4913cc9d6f11018530c8efdcab05741fb90322f7.tar.gz
ports-4913cc9d6f11018530c8efdcab05741fb90322f7.zip
libmsocket is a socket abstraction library for C programmers.
In addition to simple TCP sockets, it is moving towards transparent support for additional abstractions in a seamless manner, such as SSL and Socks5 proxies. WWW: http://sourceforge.net/projects/kageki PR: 128105 Submitted by: Matt Harris <mattdharris at users dot sourceforge dot net>
Notes
Notes: svn path=/head/; revision=221607
Diffstat (limited to 'devel/libmsocket')
-rw-r--r--devel/libmsocket/Makefile40
-rw-r--r--devel/libmsocket/distinfo3
-rw-r--r--devel/libmsocket/pkg-descr7
3 files changed, 50 insertions, 0 deletions
diff --git a/devel/libmsocket/Makefile b/devel/libmsocket/Makefile
new file mode 100644
index 000000000000..503f2c8b66ab
--- /dev/null
+++ b/devel/libmsocket/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: libmsocket
+# Date created: 2008-10-14
+# Whom: Matt Harris <mattdharris@users.sourceforge.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmsocket
+PORTVERSION= 0.4
+CATEGORIES= devel net
+MASTER_SITES= SF/kageki
+
+MAINTAINER= mattdharris@users.sourceforge.net
+COMMENT= A socket abstraction library for C programmers
+
+LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-throttling \
+ --with-libevent=${LOCALBASE}
+
+PLIST_FILES= lib/libmsocket.so \
+ lib/libmsocket.so.0.1 \
+ lib/libmsocket.a \
+ include/msocket.h \
+ include/msocketutils.h
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+CFLAGS+= -fPIC -DPIC
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libmsocket/distinfo b/devel/libmsocket/distinfo
new file mode 100644
index 000000000000..2293fa7e7c74
--- /dev/null
+++ b/devel/libmsocket/distinfo
@@ -0,0 +1,3 @@
+MD5 (libmsocket-0.4.tar.bz2) = 7ce86cfc7ba06ced17719b84018ddef6
+SHA256 (libmsocket-0.4.tar.bz2) = 39b8b7a7e222f87bcebfa28ed053489df810f7f7141bbcb2ae8a1ae0c27406fc
+SIZE (libmsocket-0.4.tar.bz2) = 69281
diff --git a/devel/libmsocket/pkg-descr b/devel/libmsocket/pkg-descr
new file mode 100644
index 000000000000..86be7b280590
--- /dev/null
+++ b/devel/libmsocket/pkg-descr
@@ -0,0 +1,7 @@
+libmsocket is a socket abstraction library for C programmers.
+
+In addition to simple TCP sockets, it is moving towards transparent
+support for additional abstractions in a seamless manner, such as
+SSL and Socks5 proxies.
+
+WWW: http://sourceforge.net/projects/kageki