aboutsummaryrefslogtreecommitdiff
path: root/devel/libnfc
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-09-07 21:33:11 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-09-07 21:33:11 +0000
commitde8aee75a659f5ff743928a93cd4879a29dae764 (patch)
treea4733f7676a0842d0bed9848992cf25f5fa954da /devel/libnfc
parent21cf016d3ec472ad92ea81289c2a395ca90a2826 (diff)
downloadports-de8aee75a659f5ff743928a93cd4879a29dae764.tar.gz
ports-de8aee75a659f5ff743928a93cd4879a29dae764.zip
- Update to 1.3.9.
Notes
Notes: svn path=/head/; revision=260711
Diffstat (limited to 'devel/libnfc')
-rw-r--r--devel/libnfc/Makefile58
-rw-r--r--devel/libnfc/distinfo6
-rw-r--r--devel/libnfc/pkg-plist5
3 files changed, 53 insertions, 16 deletions
diff --git a/devel/libnfc/Makefile b/devel/libnfc/Makefile
index c0326d9f7b90..216acaf7af49 100644
--- a/devel/libnfc/Makefile
+++ b/devel/libnfc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libnfc
-PORTVERSION= 1.3.4
+PORTVERSION= 1.3.9
CATEGORIES= devel
MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
http://romain.blogreen.org/distfiles/
@@ -14,8 +14,12 @@ MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
MAINTAINER= romain@FreeBSD.org
COMMENT= Near Field Communication (NFC) library
-OPTIONS= PCSC "Compile with PC/SC Lite support" on \
- USB "Compile with libusb support" on
+OPTIONS= ACR122 "Enable ACR122 driver" on \
+ ARYGON "Enable Arygon driver" off \
+ PN531USB "Enable PN531 USB driver" on \
+ PN532UART "Enable PN532 UART driver" on \
+ PN533USB "Enable PN533 USB driver" on \
+ SERIALPROBE "Enable serial auto-probe" off
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -23,22 +27,54 @@ USE_LDCONFIG= yes
USE_GNOME= gnomehack
MAN1= nfc-mfclassic.1 nfc-emulate.1 nfc-list.1 nfc-mfultralight.1 \
- nfc-relay.1 nfc-anticol.1
+ nfc-relay.1 nfc-anticol.1 nfc-sam.1
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_PCSC)
-CONFIGURE_ARGS+=--disable-pcsc-lite
+.if !defined(WITHOUT_ACR122)
+ACR122_DRIVER= acr122,
.else
+ACR122_DRIVER=
+.endif
+
+.if defined(WITH_ARYGON)
+ARYGON_DRIVER= arygon,
+.else
+ARYGON_DRIVER=
+.endif
+
+.if !defined(WITHOUT_PN531USB)
+PN531USB_DRIVER=pn531_usb,
+.else
+PN531USB_DRIVER=
+.endif
+
+.if !defined(WITHOUT_PN532UART)
+PN532UART_DRIVER=pn532_uart,
+.else
+PN532UART_DRIVER=
+.endif
+
+.if !defined(WITHOUT_PN533USB)
+PN533USB_DRIVER=pn533_usb,
+.else
+PN533USB_DRIVER=
+.endif
+
+CONFIGURE_ARGS+=--with-drivers="${ACR122_DRIVER}${ARYGON_DRIVER}${PN531USB_DRIVER}${PN532UART_DRIVER}${PN533USB_DRIVER}"
+
+.if defined(WITH_SERIALPROBE)
+CONFIGURE_ARGS+=--enable-serial-autoprobe
+.else
+CONFIGURE_ARGS+=--disable-serial-autoprobe
+.endif
+
+.if defined(WITH_ACR122)
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
RUN_DEPENDS+= RSA_SecurID_getpasswd:${PORTSDIR}/devel/libccid
-CONFIGURE_ARGS+=--enable-pcsc-lite
.endif
-.if defined(WITHOUT_USB)
-CONFIGURE_ARGS+=--disable-libusb
-.else
-CONFIGURE_ARGS+=--enable-libusb
+.if defined(WITH_PN531USB) || defined(WITH_PN533USB)
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
diff --git a/devel/libnfc/distinfo b/devel/libnfc/distinfo
index c9c83b2eb099..1913ca2fc2ab 100644
--- a/devel/libnfc/distinfo
+++ b/devel/libnfc/distinfo
@@ -1,3 +1,3 @@
-MD5 (libnfc-1.3.4.tar.gz) = f89f58e70b72bf4aac0567d0741719c8
-SHA256 (libnfc-1.3.4.tar.gz) = 143266d8a542eedca6f24b7c6d9355e00d541c3914cf941c1be9d5212c764b86
-SIZE (libnfc-1.3.4.tar.gz) = 408328
+MD5 (libnfc-1.3.9.tar.gz) = a47eca9e8ec03ebc0208b2de05da4bfa
+SHA256 (libnfc-1.3.9.tar.gz) = 1a46e639743473a0b801b9cf503d6b9e8c90cfa72d9c139b968b043a69d0622b
+SIZE (libnfc-1.3.9.tar.gz) = 434273
diff --git a/devel/libnfc/pkg-plist b/devel/libnfc/pkg-plist
index 26758a9dffec..d61143781972 100644
--- a/devel/libnfc/pkg-plist
+++ b/devel/libnfc/pkg-plist
@@ -4,11 +4,12 @@ bin/nfc-emulate
bin/nfc-list
bin/nfc-mfclassic
bin/nfc-mfultralight
+bin/nfc-poll
bin/nfc-relay
+bin/nfc-sam
bin/nfcip-initiator
bin/nfcip-target
-include/nfc/mifaretag.h
-include/nfc/mifareultag.h
+bin/pn53x-diagnose
include/nfc/nfc-messages.h
include/nfc/nfc-types.h
include/nfc/nfc.h