aboutsummaryrefslogtreecommitdiff
path: root/devel/liboil/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-10-03 00:26:58 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-10-03 00:26:58 +0000
commit68839a426238a67226019899f4a1ab8fc40534aa (patch)
tree6ffb5d29f032ec48fcb5ad9653d5dd8289c87fe0 /devel/liboil/Makefile
parentec2827e0dbb9af02d3323dc053be7ab4d6a38730 (diff)
downloadports-68839a426238a67226019899f4a1ab8fc40534aa.tar.gz
ports-68839a426238a67226019899f4a1ab8fc40534aa.zip
Don't give the 3dnow gcc 4.0+ option on OSVERSION < 700042 since it includes gcc 4.2.
Notes
Notes: svn path=/head/; revision=200710
Diffstat (limited to 'devel/liboil/Makefile')
-rw-r--r--devel/liboil/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index 7837c1f3dc57..71c16f044b59 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -31,16 +31,15 @@ CC:= gcc34
CXX:= g++34
.endif
-.if defined(WITH_3DNOW_GCC40)
+.if defined(WITH_3DNOW_GCC40) && ${OSVERSION} < 700042
USE_GCC= 4.0+
.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000
-# yeah yeah, I know other stuff will be added that shouldn't...
RUN_DEPENDS+= ${BUILD_DEPENDS}
.endif
.endif
pre-everything::
-.if ${MACHINE_CPU:M3dnow}!=""
+.if ${MACHINE_CPU:M3dnow}!="" && ${OSVERSION} < 700042
.if !defined(WITH_3DNOW_GCC40)
@${ECHO_MSG} "You can enable 3dnow extensions by defining"
@${ECHO_MSG} "WITH_3DNOW_GCC40=yes"