aboutsummaryrefslogtreecommitdiff
path: root/devel/liboil
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-06-07 01:56:19 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-06-07 01:56:19 +0000
commit9d7fe9593c5d888942e5dde047479d1fa7441de9 (patch)
tree8c4d696c3a7d60460199c74338395a786c08d1b0 /devel/liboil
parentc15633ed3e0f637288b6296171fe19dadadbc34e (diff)
downloadports-9d7fe9593c5d888942e5dde047479d1fa7441de9.tar.gz
ports-9d7fe9593c5d888942e5dde047479d1fa7441de9.zip
- Update to 0.3.9
Spotted on: portscout
Notes
Notes: svn path=/head/; revision=164660
Diffstat (limited to 'devel/liboil')
-rw-r--r--devel/liboil/Makefile4
-rw-r--r--devel/liboil/distinfo6
-rw-r--r--devel/liboil/files/patch-configure18
-rw-r--r--devel/liboil/files/patch-liboil_liboilcpu.c108
4 files changed, 6 insertions, 130 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index eb26e7fb33c4..bf70e7e95eae 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= liboil
-PORTVERSION= 0.3.8
+PORTVERSION= 0.3.9
CATEGORIES= devel
MASTER_SITES= http://liboil.freedesktop.org/download/ \
${MASTER_SITE_LOCAL}
@@ -23,6 +23,8 @@ CONFIGURE_ARGS= --disable-gtk-doc
.include <bsd.port.pre.mk>
post-patch:
+ @${REINPLACE_CMD} -e 's|\\$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|<stdint\.h|<inttypes.h|g' \
${WRKSRC}/liboil/liboiltypes.h \
${WRKSRC}/liboil/liboilprofile.h \
diff --git a/devel/liboil/distinfo b/devel/liboil/distinfo
index 8dc9aea910c2..a931c18d0281 100644
--- a/devel/liboil/distinfo
+++ b/devel/liboil/distinfo
@@ -1,3 +1,3 @@
-MD5 (liboil-0.3.8.tar.gz) = a402c4af2603c8fb69b365af0b8ec775
-SHA256 (liboil-0.3.8.tar.gz) = 40fa52503e30c21fd1ae1affcc038ff05af5caf0c77c27630526069ffad804ff
-SIZE (liboil-0.3.8.tar.gz) = 834167
+MD5 (liboil-0.3.9.tar.gz) = 5d139b1fb16f0e93f0c84290ad2aaff8
+SHA256 (liboil-0.3.9.tar.gz) = dd4d680ce95e586a1bbe767e1a7b25e1c53f842b8be6cf4e30e89cfa8232dd90
+SIZE (liboil-0.3.9.tar.gz) = 833083
diff --git a/devel/liboil/files/patch-configure b/devel/liboil/files/patch-configure
deleted file mode 100644
index 63ebd636c1dd..000000000000
--- a/devel/liboil/files/patch-configure
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.orig Fri Sep 30 01:52:47 2005
-+++ configure Fri Oct 21 11:14:15 2005
-@@ -21513,13 +21513,13 @@
-
-
-
--LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_BSD_SOURCE -D_GNU_SOURCE -I\$(top_srcdir) -O2"
-+LIBOIL_CFLAGS="$LIBOIL_CFLAGS -D_BSD_SOURCE -D_GNU_SOURCE -I\$(top_srcdir) $(CFLAGS)"
-
-
- LIBOIL_LIBS="\$(top_builddir)/liboil/liboil-$LIBOIL_MAJORMINOR.la"
-
-
--pkgconfigdir="\$(libdir)/pkgconfig"
-+pkgconfigdir="\$(prefix)/libdata/pkgconfig"
-
-
- #CFLAGS=`echo "$CFLAGS" | sed -e 's/-O[0-9*]//g'`
diff --git a/devel/liboil/files/patch-liboil_liboilcpu.c b/devel/liboil/files/patch-liboil_liboilcpu.c
deleted file mode 100644
index 2a3310378f3c..000000000000
--- a/devel/liboil/files/patch-liboil_liboilcpu.c
+++ /dev/null
@@ -1,108 +0,0 @@
---- liboil/liboilcpu.c.orig Mon Mar 20 22:14:01 2006
-+++ liboil/liboilcpu.c Wed May 17 17:47:44 2006
-@@ -71,7 +71,11 @@
- cpuinfo = malloc(4096);
- if (cpuinfo == NULL) return NULL;
-
-- fd = open("/proc/cpuinfo", O_RDONLY);
-+ #if defined(__FreeBSD__)
-+ fd = open("/var/run/dmesg.boot", O_RDONLY);
-+ #else
-+ fd = open("/proc/cpuinfo", O_RDONLY);
-+ #endif
- if (fd < 0) {
- free (cpuinfo);
- return NULL;
-@@ -104,6 +108,37 @@
- }
-
- flags = strsplit(cpuinfo_flags);
-+#if defined(__FreeBSD__)
-+ for (f = flags; *f; f++) {
-+ if (strcmp (*f, "CMOV") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_CMOV;
-+ }
-+ if (strcmp (*f, "MMX") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_MMX;
-+ }
-+ if (strcmp (*f, "SSE") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_SSE;
-+ }
-+ if (strcmp (*f, "AMIE") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_MMXEXT;
-+ }
-+ if (strcmp (*f, "SSE2") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_SSE2;
-+ }
-+ if (strcmp (*f, "3DNow!") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_3DNOW;
-+ }
-+ if (strcmp (*f, "DSP") == 0) {
-+ OIL_DEBUG ("cpu flag %s", *f);
-+ oil_cpu_flags |= OIL_IMPL_FLAG_3DNOWEXT;
-+ }
-+#else
- for (f = flags; *f; f++) {
- if (strcmp (*f, "cmov") == 0) {
- OIL_DEBUG ("cpu flag %s", *f);
-@@ -134,6 +169,7 @@
- OIL_DEBUG ("cpu flag %s", *f);
- oil_cpu_flags |= OIL_IMPL_FLAG_3DNOWEXT;
- }
-+#endif
-
- free (*f);
- }
-@@ -381,12 +417,22 @@
- char *end;
- char *colon;
-
-+#if defined(__FreeBSD__)
-+ flags = strstr(cpuinfo,"Features");
-+#else
- flags = strstr(cpuinfo,"flags");
-+#endif
- if (flags == NULL) return NULL;
-
-+#if defined(__FreeBSD__)
-+ end = strchr(flags, '>');
-+ if (end == NULL) return NULL;
-+ colon = strchr (flags, '<');
-+#else
- end = strchr(flags, '\n');
- if (end == NULL) return NULL;
- colon = strchr (flags, ':');
-+#endif
- if (colon == NULL) return NULL;
- colon++;
- if(colon >= end) return NULL;
-@@ -402,15 +448,22 @@
- char *tok;
- int n = 0;
-
-+#if !defined(__FreeBSD__)
- while (*s == ' ') s++;
-+#endif
-
- list = malloc (1 * sizeof(char *));
- while (*s) {
- tok = s;
-+#if defined(__FreeBSD__)
-+ while (*s && *s != ',') s++;
-+ list[n] = _strndup (tok, s - tok);
-+ s++;
-+#else
- while (*s && *s != ' ') s++;
--
- list[n] = _strndup (tok, s - tok);
- while (*s && *s == ' ') s++;
-+#endif
- list = realloc (list, (n + 2) * sizeof(char *));
- n++;
- }