aboutsummaryrefslogtreecommitdiff
path: root/devel/libole2
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-11-07 10:09:07 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-11-07 10:09:07 +0000
commita1069ee98dc6d14a702f2df835abc43066f2cd72 (patch)
tree95c87f88fc33ab744bf9b5fdcb4fad6c31e3af20 /devel/libole2
parentc8af4c91abfbdb806bf649152f33b10555c4b1a1 (diff)
downloadports-a1069ee98dc6d14a702f2df835abc43066f2cd72.tar.gz
ports-a1069ee98dc6d14a702f2df835abc43066f2cd72.zip
Update to 0.2.4.
Notes
Notes: svn path=/head/; revision=49727
Diffstat (limited to 'devel/libole2')
-rw-r--r--devel/libole2/Makefile5
-rw-r--r--devel/libole2/distinfo2
-rw-r--r--devel/libole2/files/patch-configure35
-rw-r--r--devel/libole2/files/patch-ltmain.sh28
4 files changed, 32 insertions, 38 deletions
diff --git a/devel/libole2/Makefile b/devel/libole2/Makefile
index ef184653920f..c38053b7bfc7 100644
--- a/devel/libole2/Makefile
+++ b/devel/libole2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libole2
-PORTVERSION= 0.2.3
+PORTVERSION= 0.2.4
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/libole2
@@ -15,7 +15,8 @@ MAINTAINER= gnome@FreeBSD.org
USE_GMAKE= yes
USE_GLIB= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/devel/libole2/distinfo b/devel/libole2/distinfo
index 667f9c031b67..4db3528f67da 100644
--- a/devel/libole2/distinfo
+++ b/devel/libole2/distinfo
@@ -1 +1 @@
-MD5 (libole2-0.2.3.tar.gz) = b9c620d0988ddd1dc786e9306cd454df
+MD5 (libole2-0.2.4.tar.gz) = 87efa01f3e9887ff63497b6616295397
diff --git a/devel/libole2/files/patch-configure b/devel/libole2/files/patch-configure
deleted file mode 100644
index db5d5e1aae9a..000000000000
--- a/devel/libole2/files/patch-configure
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.orig Sat May 19 16:58:34 2001
-+++ configure Mon May 21 10:42:07 2001
-@@ -5128,3 +5128,19 @@
-
-+# Actually configure libtool. ac_aux_dir is where install-sh is found.
-+CC="$CC" CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" \
-+LD="$LD" LDFLAGS="$LDFLAGS" LIBS="$LIBS" \
-+LN_S="$LN_S" NM="$NM" RANLIB="$RANLIB" \
-+DLLTOOL="$DLLTOOL" AS="$AS" OBJDUMP="$OBJDUMP" \
-+${CONFIG_SHELL-/bin/sh} $ac_aux_dir/ltconfig --no-reexec \
-+$libtool_flags $ac_aux_dir/ltmain.sh $lt_target \
-+|| { echo "configure: error: libtool configure failed" 1>&2; exit 1; }
-
-+# Reload cache, that may have been modified by ltconfig
-+if test -r "$cache_file"; then
-+ echo "loading cache $cache_file"
-+ . $cache_file
-+else
-+ echo "creating cache $cache_file"
-+ > $cache_file
-+fi
-
-@@ -5132,3 +5148,3 @@
- # This can be used to rebuild libtool when needed
--LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh"
-
-@@ -5137,3 +5153,6 @@
-
--# Prevent multiple expansion
-+
-+# Redirect the config.log output again, so that the ltconfig log is not
-+# clobbered by the next message.
-+exec 5>>./config.log
-
diff --git a/devel/libole2/files/patch-ltmain.sh b/devel/libole2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..98cb05e4ddb3
--- /dev/null
+++ b/devel/libole2/files/patch-ltmain.sh
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"