aboutsummaryrefslogtreecommitdiff
path: root/devel/liboobs
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /devel/liboobs
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Notes
Notes: svn path=/head/; revision=209647
Diffstat (limited to 'devel/liboobs')
-rw-r--r--devel/liboobs/Makefile12
-rw-r--r--devel/liboobs/distinfo6
-rw-r--r--devel/liboobs/files/patch-src_oobs-user.c28
-rw-r--r--devel/liboobs/pkg-plist10
4 files changed, 35 insertions, 21 deletions
diff --git a/devel/liboobs/Makefile b/devel/liboobs/Makefile
index b9f987d7cd72..836643c0a7cb 100644
--- a/devel/liboobs/Makefile
+++ b/devel/liboobs/Makefile
@@ -3,20 +3,21 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/liboobs/Makefile,v 1.23 2007/09/16 16:45:35 ahze Exp $
+# $MCom: ports/devel/liboobs/Makefile,v 1.35 2008/03/09 18:52:59 mezz Exp $
#
PORTNAME= liboobs
-PORTVERSION= 2.20.0
+PORTVERSION= 2.22.0
CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Wrapping library to the System Tools Backends
BUILD_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ hal.1:${PORTSDIR}/sysutils/hal
RUN_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
USE_BZIP2= yes
@@ -24,5 +25,6 @@ GNU_CONFIGURE= yes
USE_GNOME= gnomehack glib20
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
.include <bsd.port.mk>
diff --git a/devel/liboobs/distinfo b/devel/liboobs/distinfo
index de4bba60f2af..b1099f55b21a 100644
--- a/devel/liboobs/distinfo
+++ b/devel/liboobs/distinfo
@@ -1,3 +1,3 @@
-MD5 (liboobs-2.20.0.tar.bz2) = c0562e115af4777da471182b9d462b40
-SHA256 (liboobs-2.20.0.tar.bz2) = 45a3cd562ac6d0002dc5c5972e1b4ec7fe611fe7ed9d0d8da9dbaaffd1c04623
-SIZE (liboobs-2.20.0.tar.bz2) = 331456
+MD5 (gnome2/liboobs-2.22.0.tar.bz2) = 1b090ecd6c0df58b131795ff9a5c9057
+SHA256 (gnome2/liboobs-2.22.0.tar.bz2) = b35760855d7d1def532e9e808cecde29b75cec455b238590072abf4a8206536e
+SIZE (gnome2/liboobs-2.22.0.tar.bz2) = 340348
diff --git a/devel/liboobs/files/patch-src_oobs-user.c b/devel/liboobs/files/patch-src_oobs-user.c
index e571a363fdb0..484b86f32e64 100644
--- a/devel/liboobs/files/patch-src_oobs-user.c
+++ b/devel/liboobs/files/patch-src_oobs-user.c
@@ -1,6 +1,6 @@
---- oobs/oobs-user.c.orig Fri Sep 15 19:16:41 2006
-+++ oobs/oobs-user.c Tue Oct 31 23:12:29 2006
-@@ -18,6 +18,10 @@
+--- oobs/oobs-user.c.orig 2007-10-30 09:16:53.406333206 -0400
++++ oobs/oobs-user.c 2007-10-30 09:40:02.560797530 -0400
+@@ -18,12 +18,18 @@
* Authors: Carlos Garnacho Parro <carlosg@gnome.org>
*/
@@ -11,13 +11,25 @@
#include <glib-object.h>
#include <sys/types.h>
#include <unistd.h>
-@@ -30,7 +34,9 @@
- #include "oobs-group.h"
- #include "oobs-defines.h"
- #include "utils.h"
+ #include <stdlib.h>
+ #include <string.h>
+#ifdef HAVE_CRYPT_H
#include <crypt.h>
+#endif
+ #include <utmp.h>
- #define OOBS_USER_GET_PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), OOBS_TYPE_USER, OobsUserPrivate))
+ #include "oobs-usersconfig.h"
+@@ -852,6 +858,7 @@
+ login = oobs_user_get_login_name (user);
+
++#if 0 /* FreeBSD does not have ut_type in utmp */
+ while (!match && (entry = getutent ()) != NULL)
+ {
+ match = (entry->ut_type == USER_PROCESS &&
+@@ -862,4 +869,5 @@
+ endutent ();
+
+ return match;
++#endif
+ }
diff --git a/devel/liboobs/pkg-plist b/devel/liboobs/pkg-plist
index a36b53d54b73..f6cb6c5e0d11 100644
--- a/devel/liboobs/pkg-plist
+++ b/devel/liboobs/pkg-plist
@@ -3,9 +3,8 @@ include/liboobs-1.0/oobs/oobs-groupsconfig.h
include/liboobs-1.0/oobs/oobs-hostsconfig.h
include/liboobs-1.0/oobs/oobs-iface-ethernet.h
include/liboobs-1.0/oobs/oobs-iface-irlan.h
-include/liboobs-1.0/oobs/oobs-iface-isdn.h
-include/liboobs-1.0/oobs/oobs-iface-modem.h
include/liboobs-1.0/oobs/oobs-iface-plip.h
+include/liboobs-1.0/oobs/oobs-iface-ppp.h
include/liboobs-1.0/oobs/oobs-iface-wireless.h
include/liboobs-1.0/oobs/oobs-iface.h
include/liboobs-1.0/oobs/oobs-ifacesconfig.h
@@ -15,6 +14,7 @@ include/liboobs-1.0/oobs/oobs-ntpconfig.h
include/liboobs-1.0/oobs/oobs-ntpserver.h
include/liboobs-1.0/oobs/oobs-object.h
include/liboobs-1.0/oobs/oobs-result.h
+include/liboobs-1.0/oobs/oobs-selfconfig.h
include/liboobs-1.0/oobs/oobs-service.h
include/liboobs-1.0/oobs/oobs-servicesconfig.h
include/liboobs-1.0/oobs/oobs-session.h
@@ -30,15 +30,13 @@ include/liboobs-1.0/oobs/oobs.h
lib/liboobs-1.a
lib/liboobs-1.la
lib/liboobs-1.so
-lib/liboobs-1.so.3
+lib/liboobs-1.so.4
libdata/pkgconfig/liboobs-1.pc
%%DOCSDIR%%/OobsGroup.html
%%DOCSDIR%%/OobsGroupsConfig.html
%%DOCSDIR%%/OobsIface.html
%%DOCSDIR%%/OobsIfaceEthernet.html
%%DOCSDIR%%/OobsIfaceIRLan.html
-%%DOCSDIR%%/OobsIfaceISDN.html
-%%DOCSDIR%%/OobsIfaceModem.html
%%DOCSDIR%%/OobsIfacePlip.html
%%DOCSDIR%%/OobsIfaceWireless.html
%%DOCSDIR%%/OobsIfacesConfig.html
@@ -70,6 +68,8 @@ libdata/pkgconfig/liboobs-1.pc
%%DOCSDIR%%/index.sgml
%%DOCSDIR%%/left.png
%%DOCSDIR%%/liboobs-OobsHostsConfig.html
+%%DOCSDIR%%/liboobs-OobsIfaceISDN.html
+%%DOCSDIR%%/liboobs-OobsIfaceModem.html
%%DOCSDIR%%/liboobs-OobsNTPServer.html
%%DOCSDIR%%/liboobs.devhelp
%%DOCSDIR%%/liboobs.devhelp2