aboutsummaryrefslogtreecommitdiff
path: root/devel/liboobs
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /devel/liboobs
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Notes
Notes: svn path=/head/; revision=254099
Diffstat (limited to 'devel/liboobs')
-rw-r--r--devel/liboobs/Makefile19
-rw-r--r--devel/liboobs/distinfo6
-rw-r--r--devel/liboobs/files/patch-src_oobs-group.c27
-rw-r--r--devel/liboobs/files/patch-src_oobs-user.c42
-rw-r--r--devel/liboobs/pkg-plist48
5 files changed, 84 insertions, 58 deletions
diff --git a/devel/liboobs/Makefile b/devel/liboobs/Makefile
index 5e775e6678a1..6219641f4493 100644
--- a/devel/liboobs/Makefile
+++ b/devel/liboobs/Makefile
@@ -3,11 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/liboobs/Makefile,v 1.38 2009/11/28 05:59:00 mezz Exp $
+# $MCom: ports/devel/liboobs/Makefile,v 1.46 2010/04/01 22:27:34 kwm Exp $
#
PORTNAME= liboobs
-PORTVERSION= 2.22.2
+PORTVERSION= 2.30.0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -21,10 +21,21 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
RUN_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/org.freedesktop.SystemToolsBackends.conf:${PORTSDIR}/sysutils/system-tools-backends
USE_BZIP2= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack glib20
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc --with-hal
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# disable utmpx detection on early 9.x and below.
+# We still have only utmp there
+post-patch:
+.if ${OSVERSION} < 900007
+ @${REINPLACE_CMD} -e 's|utmpx|utmp|g' \
+ ${WRKSRC}/configure
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/liboobs/distinfo b/devel/liboobs/distinfo
index 7521018e6f82..9fc0f08d30b4 100644
--- a/devel/liboobs/distinfo
+++ b/devel/liboobs/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/liboobs-2.22.2.tar.bz2) = 84d20702942635e3bebc0c1c35bdad43
-SHA256 (gnome2/liboobs-2.22.2.tar.bz2) = 34a972fab68255902d4c1f82ba16dfbf673f9933f78c68b4551883b63984c58b
-SIZE (gnome2/liboobs-2.22.2.tar.bz2) = 364260
+MD5 (gnome2/liboobs-2.30.0.tar.bz2) = 69ee6d329cd919c69aae3dae7302b796
+SHA256 (gnome2/liboobs-2.30.0.tar.bz2) = b0c18e038a6c1eba15c68a8e9fabfc21144c9240c17f3bd19042bae1ea04a5ce
+SIZE (gnome2/liboobs-2.30.0.tar.bz2) = 369402
diff --git a/devel/liboobs/files/patch-src_oobs-group.c b/devel/liboobs/files/patch-src_oobs-group.c
index 6abd8b711ddc..0a7384b90d9c 100644
--- a/devel/liboobs/files/patch-src_oobs-group.c
+++ b/devel/liboobs/files/patch-src_oobs-group.c
@@ -1,25 +1,10 @@
---- oobs/oobs-group.c.orig Fri Sep 15 18:41:04 2006
-+++ oobs/oobs-group.c Tue Oct 31 23:12:40 2006
-@@ -18,7 +18,12 @@
- * Authors: Carlos Garnacho Parro <carlosg@gnome.org>
- */
+--- oobs/oobs-group.c.orig 2010-01-11 13:34:52.000000000 -0500
++++ oobs/oobs-group.c 2010-01-18 02:04:34.000000000 -0500
+@@ -21,6 +21,7 @@
-+#if defined(HAVE_CONFIG_H)
-+#include <config.h>
-+#endif
-+
+ #include <string.h>
#include <glib-object.h>
+#include <unistd.h>
- #include "oobs-session.h"
- #include "oobs-group.h"
- #include "oobs-user.h"
-@@ -27,7 +32,9 @@
- #include "oobs-groupsconfig-private.h"
- #include "oobs-defines.h"
- #include "utils.h"
-+#ifdef HAVE_CRYPT_H
- #include <crypt.h>
-+#endif
-
- #define OOBS_GROUP_GET_PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), OOBS_TYPE_GROUP, OobsGroupPrivate))
+ #include <dbus/dbus.h>
+ #include "oobs-object-private.h"
diff --git a/devel/liboobs/files/patch-src_oobs-user.c b/devel/liboobs/files/patch-src_oobs-user.c
index 2096814ee3a6..a7215c4effbb 100644
--- a/devel/liboobs/files/patch-src_oobs-user.c
+++ b/devel/liboobs/files/patch-src_oobs-user.c
@@ -1,13 +1,9 @@
---- oobs/oobs-user.c
-+++ oobs/oobs-user.c
-@@ -18,13 +18,28 @@
- * Authors: Carlos Garnacho Parro <carlosg@gnome.org>
+--- oobs/oobs-user.c.orig 2010-01-31 17:36:52.000000000 +0000
++++ oobs/oobs-user.c 2010-01-31 17:40:21.000000000 +0000
+@@ -19,13 +19,24 @@
+ * Milan Bouchet-Valat <nalimilan@club.fr>.
*/
-+#if defined(HAVE_CONFIG_H)
-+#include <config.h>
-+#endif
-+
+#ifdef __FreeBSD__
+# include <sys/param.h>
+# if __FreeBSD_version >= 900007
@@ -22,42 +18,28 @@
#include <string.h>
+#ifdef HAVE_CRYPT_H
#include <crypt.h>
--#include <utmp.h>
+#endif
+#ifdef HAVE_UTMPX_H
-+#include <utmpx.h>
+ #include <utmpx.h>
+#endif
+ #include "oobs-object-private.h"
#include "oobs-usersconfig.h"
- #include "oobs-user.h"
-@@ -811,7 +826,8 @@
+@@ -1252,6 +1263,7 @@ oobs_user_set_locale (OobsUser *user, co
gboolean
oobs_user_get_active (OobsUser *user)
{
-- struct utmp *entry;
+#ifdef HAVE_UTMPX_H
-+ struct utmpx *entry;
+ struct utmpx *entry;
const gchar *login;
gboolean match = FALSE;
-
-@@ -819,14 +835,18 @@
-
- login = oobs_user_get_login_name (user);
-
-- while (!match && (entry = getutent ()) != NULL)
-+ setutxent ();
-+ while (!match && (entry = getutxent ()) != NULL)
- {
- match = (entry->ut_type == USER_PROCESS &&
- strcmp (entry->ut_user, login) == 0);
- }
-
- /* close utmp */
-- endutent ();
-+ endutxent ();
+@@ -1272,6 +1284,9 @@ oobs_user_get_active (OobsUser *user)
+ endutxent ();
return match;
+#else
+ return FALSE;
+#endif
}
+
+ /**
diff --git a/devel/liboobs/pkg-plist b/devel/liboobs/pkg-plist
index 11e1ab182ef1..0b3354023c23 100644
--- a/devel/liboobs/pkg-plist
+++ b/devel/liboobs/pkg-plist
@@ -1,3 +1,6 @@
+include/liboobs-1.0/oobs/oobs-defines.h
+include/liboobs-1.0/oobs/oobs-enum-types.h
+include/liboobs-1.0/oobs/oobs-error.h
include/liboobs-1.0/oobs/oobs-group.h
include/liboobs-1.0/oobs/oobs-groupsconfig.h
include/liboobs-1.0/oobs/oobs-hostsconfig.h
@@ -32,5 +35,50 @@ lib/liboobs-1.la
lib/liboobs-1.so
lib/liboobs-1.so.4
libdata/pkgconfig/liboobs-1.pc
+%%DOCSDIR%%/OobsGroup.html
+%%DOCSDIR%%/OobsGroupsConfig.html
+%%DOCSDIR%%/OobsHostsConfig.html
+%%DOCSDIR%%/OobsIface.html
+%%DOCSDIR%%/OobsIfaceEthernet.html
+%%DOCSDIR%%/OobsIfaceIRLan.html
+%%DOCSDIR%%/OobsIfacePPP.html
+%%DOCSDIR%%/OobsIfacePlip.html
+%%DOCSDIR%%/OobsIfaceWireless.html
+%%DOCSDIR%%/OobsIfacesConfig.html
+%%DOCSDIR%%/OobsList.html
+%%DOCSDIR%%/OobsNFSConfig.html
+%%DOCSDIR%%/OobsNTPConfig.html
+%%DOCSDIR%%/OobsNTPServer.html
+%%DOCSDIR%%/OobsObject.html
+%%DOCSDIR%%/OobsSMBConfig.html
+%%DOCSDIR%%/OobsSelfConfig.html
+%%DOCSDIR%%/OobsService.html
+%%DOCSDIR%%/OobsServicesConfig.html
+%%DOCSDIR%%/OobsSession.html
+%%DOCSDIR%%/OobsShare.html
+%%DOCSDIR%%/OobsShareNFS.html
+%%DOCSDIR%%/OobsShareSMB.html
+%%DOCSDIR%%/OobsStaticHost.html
+%%DOCSDIR%%/OobsTimeConfig.html
+%%DOCSDIR%%/OobsUser.html
+%%DOCSDIR%%/OobsUsersConfig.html
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/ch03.html
+%%DOCSDIR%%/ch04.html
+%%DOCSDIR%%/ch05.html
+%%DOCSDIR%%/ch06.html
+%%DOCSDIR%%/ch07.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/liboobs-OobsError.html
+%%DOCSDIR%%/liboobs.devhelp
+%%DOCSDIR%%/liboobs.devhelp2
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+@dirrm %%DOCSDIR%%
@dirrm include/liboobs-1.0/oobs
@dirrm include/liboobs-1.0