aboutsummaryrefslogtreecommitdiff
path: root/devel/libopkele
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-14 11:28:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-14 11:28:47 +0000
commita7a74e97535c21b58aaf16a6f0e3840526a8bb2a (patch)
tree9d10fadc6609076775e5fd65f38c63421ab20378 /devel/libopkele
parent25e7a0db9d9f1e79ecd661fcccaedc2e6c162d55 (diff)
downloadports-a7a74e97535c21b58aaf16a6f0e3840526a8bb2a.tar.gz
ports-a7a74e97535c21b58aaf16a6f0e3840526a8bb2a.zip
libopkele is a c++ implementation of an OpenID decentralized identity
system. It provides OpenID protocol handling, leaving authentication and user interaction to the implementor. WWW: http://kin.klever.net/libopkele/ PR: ports/119628 Submitted by: Sutra Zhou <zhoushuqun at gmail.com>
Notes
Notes: svn path=/head/; revision=205637
Diffstat (limited to 'devel/libopkele')
-rw-r--r--devel/libopkele/Makefile34
-rw-r--r--devel/libopkele/distinfo3
-rw-r--r--devel/libopkele/files/patch-test_Makefile.am10
-rw-r--r--devel/libopkele/pkg-descr5
-rw-r--r--devel/libopkele/pkg-plist18
5 files changed, 70 insertions, 0 deletions
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
new file mode 100644
index 000000000000..ae9f1e333809
--- /dev/null
+++ b/devel/libopkele/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libopkele
+# Date created: 28 November 2007
+# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopkele
+PORTVERSION= 0.3.2
+CATEGORIES= devel
+MASTER_SITES= http://kin.klever.net/dist/
+
+MAINTAINER= zhoushuqun@gmail.com
+COMMENT= A c++ implementation of an OpenID decentralized identity system
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ pcre.0:${PORTSDIR}/devel/pcre
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= "OPENSSL_CFLAGS=${CFLAGS} -l${OPENSSLINC}" \
+ OPENSSL_LIBS=-L${OPENSSLLIB}
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS= "-L${LOCALBASE}/lib"
+
+post-patch:
+ @ ${REINPLACE_CMD} -e "s|pkgconfigdir =.*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|g" \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/devel/libopkele/distinfo b/devel/libopkele/distinfo
new file mode 100644
index 000000000000..702c8ff5d8b8
--- /dev/null
+++ b/devel/libopkele/distinfo
@@ -0,0 +1,3 @@
+MD5 (libopkele-0.3.2.tar.gz) = 26dbbbaacb09d7df4e11f259ec9693d5
+SHA256 (libopkele-0.3.2.tar.gz) = 8b59b81d12f6e29367cc706b3417467ad7a8d3c7fb411be2a973be3324ce78d1
+SIZE (libopkele-0.3.2.tar.gz) = 359729
diff --git a/devel/libopkele/files/patch-test_Makefile.am b/devel/libopkele/files/patch-test_Makefile.am
new file mode 100644
index 000000000000..6ab91c7853ee
--- /dev/null
+++ b/devel/libopkele/files/patch-test_Makefile.am
@@ -0,0 +1,10 @@
+--- test/Makefile.am.orgi 2008-01-13 18:11:54.000000000 +0100
++++ test/Makefile.am 2008-01-13 18:12:43.000000000 +0100
+@@ -1,6 +1,6 @@
+ noinst_PROGRAMS = test
+
+-INCLUDES = -I${top_srcdir}/include/ ${KONFORKA_CFLAGS}
++INCLUDES = -I${top_srcdir}/include/ ${KONFORKA_CFLAGS} ${LIBCURL_CPPFLAGS}
+
+ test_SOURCES = test.cc
+ test_LDADD = ${top_builddir}/lib/libopkele.la
diff --git a/devel/libopkele/pkg-descr b/devel/libopkele/pkg-descr
new file mode 100644
index 000000000000..7d03b17a5a7f
--- /dev/null
+++ b/devel/libopkele/pkg-descr
@@ -0,0 +1,5 @@
+libopkele is a c++ implementation of an OpenID decentralized identity
+system. It provides OpenID protocol handling, leaving authentication
+and user interaction to the implementor.
+
+WWW: http://kin.klever.net/libopkele/
diff --git a/devel/libopkele/pkg-plist b/devel/libopkele/pkg-plist
new file mode 100644
index 000000000000..644cb84460fc
--- /dev/null
+++ b/devel/libopkele/pkg-plist
@@ -0,0 +1,18 @@
+include/opkele/acconfig.h
+include/opkele/association.h
+include/opkele/consumer.h
+include/opkele/exception.h
+include/opkele/extension.h
+include/opkele/extension_chain.h
+include/opkele/opkele-config.h
+include/opkele/server.h
+include/opkele/sreg.h
+include/opkele/types.h
+include/opkele/xconsumer.h
+include/opkele/xserver.h
+lib/libopkele.a
+lib/libopkele.la
+lib/libopkele.so
+lib/libopkele.so.2
+libdata/pkgconfig/libopkele.pc
+@dirrm include/opkele