aboutsummaryrefslogtreecommitdiff
path: root/devel/libpciaccess
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2009-01-29 18:50:48 +0000
committerRobert Noland <rnoland@FreeBSD.org>2009-01-29 18:50:48 +0000
commit87cc1411172a5baea4ed85cecc909c8a25e2776b (patch)
tree731c92672122e2e6147b2a74f3426a549ac18601 /devel/libpciaccess
parent6dd998ee983ee922b053ce164d082ad28cbd48a1 (diff)
downloadports-87cc1411172a5baea4ed85cecc909c8a25e2776b.tar.gz
ports-87cc1411172a5baea4ed85cecc909c8a25e2776b.zip
Some drivers depend on pci chip revision id to function properly. We
had the info, but we weren't populating the field. Do that now. This fixes at least mga, possibly other drivers. Reported by: Mark Knight <markk@knigma.org> Tested by: Mark Knight <markk@knigma.org>, Warren Block <wblock@wonkity.com>
Notes
Notes: svn path=/head/; revision=227100
Diffstat (limited to 'devel/libpciaccess')
-rw-r--r--devel/libpciaccess/Makefile2
-rw-r--r--devel/libpciaccess/files/patch-src-freebsd_pci.c12
2 files changed, 11 insertions, 3 deletions
diff --git a/devel/libpciaccess/Makefile b/devel/libpciaccess/Makefile
index 19b6bc7b26d2..9746b4e14cb1 100644
--- a/devel/libpciaccess/Makefile
+++ b/devel/libpciaccess/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libpciaccess
PORTVERSION= 0.10.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= x11@FreeBSD.org
diff --git a/devel/libpciaccess/files/patch-src-freebsd_pci.c b/devel/libpciaccess/files/patch-src-freebsd_pci.c
index a75b49b64453..0bad1b303fcc 100644
--- a/devel/libpciaccess/files/patch-src-freebsd_pci.c
+++ b/devel/libpciaccess/files/patch-src-freebsd_pci.c
@@ -1,5 +1,5 @@
---- src/freebsd_pci.c.orig 2009-01-25 11:53:11.000000000 -0500
-+++ src/freebsd_pci.c 2009-01-25 11:53:26.000000000 -0500
+--- src/freebsd_pci.c.orig 2008-10-31 11:40:09.000000000 -0400
++++ src/freebsd_pci.c 2009-01-29 12:34:31.000000000 -0500
@@ -53,6 +53,17 @@
#define PCIS_DISPLAY_3D 0x02
#define PCIS_DISPLAY_OTHER 0x80
@@ -96,3 +96,11 @@
if (addr & 0x01)
dev->regions[region].is_IO = 1;
+@@ -495,6 +527,7 @@
+ pci_sys->devices[ i ].base.device_id = p->pc_device;
+ pci_sys->devices[ i ].base.subvendor_id = p->pc_subvendor;
+ pci_sys->devices[ i ].base.subdevice_id = p->pc_subdevice;
++ pci_sys->devices[ i ].base.revision = p->pc_revid;
+ pci_sys->devices[ i ].base.device_class = (uint32_t)p->pc_class << 16 |
+ (uint32_t)p->pc_subclass << 8 | (uint32_t)p->pc_progif;
+ }