aboutsummaryrefslogtreecommitdiff
path: root/devel/libpff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-10-02 18:25:44 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-10-02 18:25:44 +0000
commitb2db6bf8a58748d35ec8774eb3c1641867aa149f (patch)
treecc910a51d33756aee4175b114075bc6fb5cf733d /devel/libpff
parent0156b55fba62fc2d63fc804b3a4fa60139bd9e9b (diff)
downloadports-b2db6bf8a58748d35ec8774eb3c1641867aa149f.tar.gz
ports-b2db6bf8a58748d35ec8774eb3c1641867aa149f.zip
Convert to STAGEDIR
Notes
Notes: svn path=/head/; revision=329091
Diffstat (limited to 'devel/libpff')
-rw-r--r--devel/libpff/Makefile20
-rw-r--r--devel/libpff/pkg-plist3
2 files changed, 11 insertions, 12 deletions
diff --git a/devel/libpff/Makefile b/devel/libpff/Makefile
index 177e9017ac29..e5ecd6700677 100644
--- a/devel/libpff/Makefile
+++ b/devel/libpff/Makefile
@@ -13,34 +13,30 @@ COMMENT= Library and tools to access the PFF and the OFF formats
LICENSE= LGPL3
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-python
+CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE} ${ICONV_CONFIGURE_ARG}
USES= gettext iconv pathfix
USE_PYTHON= -2.7
USE_LDCONFIG= yes
-
+# Remove when configure gets LDFLAGS for python correctly
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
-MAN1= pffexport.1 pffinfo.1
-MAN3= libpff.3
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
PORTDOCS= AUTHORS ChangeLog
PORTEXAMPLES= *
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/${PORTNAME}/* \
- ${WRKSRC}/examples/${PORTNAME:S,lib,py,}/* ${EXAMPLESDIR}
+ ${WRKSRC}/examples/${PORTNAME:S,lib,py,}/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/libpff/pkg-plist b/devel/libpff/pkg-plist
index a87dc593f194..818ba11c7943 100644
--- a/devel/libpff/pkg-plist
+++ b/devel/libpff/pkg-plist
@@ -16,4 +16,7 @@ lib/libpff.so.1
%%PYTHON_SITELIBDIR%%/pypff.la
%%PYTHON_SITELIBDIR%%/pypff.so
libdata/pkgconfig/libpff.pc
+man/man1/pffexport.1.gz
+man/man1/pffinfo.1.gz
+man/man3/libpff.3.gz
@dirrm include/libpff