aboutsummaryrefslogtreecommitdiff
path: root/devel/libtar
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-10 19:40:15 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-10 19:40:15 +0000
commit30ca9191d0ad9703bb9f01268084988b066ac6df (patch)
treec3cbf8e3709316bdbdea0b1af9ca0511e7246033 /devel/libtar
parentff049e43e41fa444ef0d5c27a750e9df6975a1f3 (diff)
downloadports-30ca9191d0ad9703bb9f01268084988b066ac6df.tar.gz
ports-30ca9191d0ad9703bb9f01268084988b066ac6df.zip
Add libtar 1.2, a library for manipulating POSIX and GNU tar files.
PR: 24114 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Notes
Notes: svn path=/head/; revision=39456
Diffstat (limited to 'devel/libtar')
-rw-r--r--devel/libtar/Makefile22
-rw-r--r--devel/libtar/distinfo1
-rw-r--r--devel/libtar/files/manpages59
-rw-r--r--devel/libtar/files/patch-doc::Makefile.in72
-rw-r--r--devel/libtar/files/patch-lib::append.c10
-rw-r--r--devel/libtar/files/patch-lib::encode.c10
-rw-r--r--devel/libtar/files/patch-lib::extract.c10
-rw-r--r--devel/libtar/pkg-comment1
-rw-r--r--devel/libtar/pkg-descr6
-rw-r--r--devel/libtar/pkg-plist4
10 files changed, 195 insertions, 0 deletions
diff --git a/devel/libtar/Makefile b/devel/libtar/Makefile
new file mode 100644
index 000000000000..d40a7bf64f4c
--- /dev/null
+++ b/devel/libtar/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: libtar
+# Date created: 06 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtar
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp-dev.cso.uiuc.edu/pub/libtar/
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include "files/manpages"
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libtar/distinfo b/devel/libtar/distinfo
new file mode 100644
index 000000000000..899c471955fb
--- /dev/null
+++ b/devel/libtar/distinfo
@@ -0,0 +1 @@
+MD5 (libtar-1.2.tar.gz) = ad926b68bcf279a0d5e8ae656dc6a612
diff --git a/devel/libtar/files/manpages b/devel/libtar/files/manpages
new file mode 100644
index 000000000000..c1f9d123695e
--- /dev/null
+++ b/devel/libtar/files/manpages
@@ -0,0 +1,59 @@
+MAN3= TH_ISBLK.3 \
+TH_ISCHR.3 \
+TH_ISDIR.3 \
+TH_ISFIFO.3 \
+TH_ISLNK.3 \
+TH_ISLONGLINK.3 \
+TH_ISLONGNAME.3 \
+TH_ISREG.3 \
+TH_ISSYM.3 \
+libtar_hash_delete.3 \
+libtar_hash_insert.3 \
+libtar_hash_kill.3 \
+libtar_hash_read.3 \
+libtar_hash_read_reset.3 \
+libtar_hash_value.3 \
+libtar_list_add.3 \
+libtar_list_del.3 \
+libtar_list_kill.3 \
+libtar_list_match.3 \
+libtar_list_read.3 \
+libtar_list_read_reset.3 \
+libtar_list_reverse_read.3 \
+libtar_list_reverse_read_reset.3 \
+tar_append_eof.3 \
+tar_append_regfile.3 \
+tar_append_tree.3 \
+tar_block_write.3 \
+tar_close.3 \
+tar_extract_blockdev.3 \
+tar_extract_chardev.3 \
+tar_extract_dir.3 \
+tar_extract_fifo.3 \
+tar_extract_glob.3 \
+tar_extract_hardlink.3 \
+tar_extract_regfile.3 \
+tar_extract_symlink.3 \
+tar_fd.3 \
+tar_fdopen.3 \
+tar_set_file_perms.3 \
+tar_skip_regfile.3 \
+th_finish.3 \
+th_get_crc.3 \
+th_get_devmajor.3 \
+th_get_devminor.3 \
+th_get_gid.3 \
+th_get_linkname.3 \
+th_get_mode.3 \
+th_get_mtime.3 \
+th_get_size.3 \
+th_get_uid.3 \
+th_print.3 \
+th_set_device.3 \
+th_set_group.3 \
+th_set_link.3 \
+th_set_mode.3 \
+th_set_path.3 \
+th_set_type.3 \
+th_set_user.3 \
+th_write.3
diff --git a/devel/libtar/files/patch-doc::Makefile.in b/devel/libtar/files/patch-doc::Makefile.in
new file mode 100644
index 000000000000..56f440f2e841
--- /dev/null
+++ b/devel/libtar/files/patch-doc::Makefile.in
@@ -0,0 +1,72 @@
+--- doc/Makefile.in.orig Sat Nov 25 01:44:57 2000
++++ doc/Makefile.in Sat Jan 6 19:00:35 2001
+@@ -67,46 +67,57 @@
+ $(MKDIR) $(DESTDIR)$(mandir)/man3
+ $(INSTALL_DATA) $(srcdir)/tar_open.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TAR_OPEN_SO); do \
+- echo ".so man3/tar_open.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
+- done
++ $(LN_S) $(DESTDIR)$(mandir)/man3/tar_open.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ done
+ $(INSTALL_DATA) $(srcdir)/tar_append_file.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TAR_APPEND_FILE_SO); do \
+- echo ".so man3/tar_append_file.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/tar_append_file.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/tar_block_read.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TAR_BLOCK_READ_SO); do \
+- echo ".so man3/tar_block_read.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/tar_block_read.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/th_read.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TH_READ_SO); do \
+- echo ".so man3/th_read.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/th_read.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/th_set_from_stat.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TH_SET_FROM_STAT_SO); do \
+- echo ".so man3/th_set_from_stat.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/th_set_from_stat.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/tar_extract_file.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TAR_EXTRACT_FILE_SO); do \
+- echo ".so man3/tar_extract_file.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/tar_extract_file.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/th_get_pathname.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TH_GET_PATHNAME_SO); do \
+- echo ".so man3/th_get_pathname.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/th_get_pathname.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/th_print_long_ls.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TH_PRINT_LONG_LS_SO); do \
+- echo ".so man3/th_print_long_ls.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/th_print_long_ls.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) $(srcdir)/tar_extract_all.3 $(DESTDIR)$(mandir)/man3
+ for i in $(TAR_EXTRACT_ALL_SO); do \
+- echo ".so man3/tar_extract_all.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/tar_extract_all.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) @LHPKG@_hash_new.3 $(DESTDIR)$(mandir)/man3
+ for i in $(@LHPKG@_HASH_NEW_SO); do \
+- echo ".so man3/@LHPKG@_hash_new.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/@LHPKG@_hash_new.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+ $(INSTALL_DATA) @LHPKG@_list_new.3 $(DESTDIR)$(mandir)/man3
+ for i in $(@LHPKG@_LIST_NEW_SO); do \
+- echo ".so man3/@LHPKG@_list_new.3" > $(DESTDIR)$(mandir)/man3/$${i}.3; \
++ $(LN_S) $(DESTDIR)$(mandir)/man3/@LHPKG@_list_new.3 \
++ $(DESTDIR)$(mandir)/man3/$${i}.3; \
+ done
+
diff --git a/devel/libtar/files/patch-lib::append.c b/devel/libtar/files/patch-lib::append.c
new file mode 100644
index 000000000000..f97a560934ec
--- /dev/null
+++ b/devel/libtar/files/patch-lib::append.c
@@ -0,0 +1,10 @@
+--- lib/append.c.orig Sat Jan 6 17:47:16 2001
++++ lib/append.c Sat Jan 6 17:47:40 2001
+@@ -16,7 +16,6 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <sys/param.h>
+-#include <sys/sysmacros.h>
+
+ #include <compat.h>
+
diff --git a/devel/libtar/files/patch-lib::encode.c b/devel/libtar/files/patch-lib::encode.c
new file mode 100644
index 000000000000..51baeaf7b335
--- /dev/null
+++ b/devel/libtar/files/patch-lib::encode.c
@@ -0,0 +1,10 @@
+--- lib/encode.c.orig Sat Jan 6 17:47:54 2001
++++ lib/encode.c Sat Jan 6 17:47:59 2001
+@@ -15,7 +15,6 @@
+
+ #include <pwd.h>
+ #include <grp.h>
+-#include <sys/sysmacros.h>
+
+ #ifdef STDC_HEADERS
+ # include <string.h>
diff --git a/devel/libtar/files/patch-lib::extract.c b/devel/libtar/files/patch-lib::extract.c
new file mode 100644
index 000000000000..7c7afb5ca6f4
--- /dev/null
+++ b/devel/libtar/files/patch-lib::extract.c
@@ -0,0 +1,10 @@
+--- lib/extract.c.orig Sat Jan 6 17:48:06 2001
++++ lib/extract.c Sat Jan 6 17:48:12 2001
+@@ -15,7 +15,6 @@
+
+ #include <stdio.h>
+ #include <sys/param.h>
+-#include <sys/sysmacros.h>
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <utime.h>
diff --git a/devel/libtar/pkg-comment b/devel/libtar/pkg-comment
new file mode 100644
index 000000000000..0aaba00969cb
--- /dev/null
+++ b/devel/libtar/pkg-comment
@@ -0,0 +1 @@
+A library for manipulating POSIX and GNU tar files
diff --git a/devel/libtar/pkg-descr b/devel/libtar/pkg-descr
new file mode 100644
index 000000000000..3e005fb7e0e4
--- /dev/null
+++ b/devel/libtar/pkg-descr
@@ -0,0 +1,6 @@
+libtar is a C library for manipulating tar archives. It supports both
+the strict POSIX tar format and many of the commonly-used GNU
+extensions.
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/devel/libtar/pkg-plist b/devel/libtar/pkg-plist
new file mode 100644
index 000000000000..96d7233acfa5
--- /dev/null
+++ b/devel/libtar/pkg-plist
@@ -0,0 +1,4 @@
+bin/libtar
+include/libtar.h
+include/libtar_listhash.h
+lib/libtar.a