aboutsummaryrefslogtreecommitdiff
path: root/devel/libtifiles
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 10:55:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 10:55:05 +0000
commit0a8169aade48999993d8aff95df7d80729779c6a (patch)
tree45e5c5ad888fae6fc24d2211cb1dba86f495df6a /devel/libtifiles
parent84844a75580499aafec4baab0f7cb7bd5f5255c9 (diff)
downloadports-0a8169aade48999993d8aff95df7d80729779c6a.tar.gz
ports-0a8169aade48999993d8aff95df7d80729779c6a.zip
[new port] libtifiles: handle TI calculator files
Libtifiles is a part of TiLP, a program to link TI calculators to a computer. It is used to handle all file types. PR: ports/56135 Submitted by: Tijl Coosemans <tijl@ulyssis.org>
Notes
Notes: svn path=/head/; revision=88787
Diffstat (limited to 'devel/libtifiles')
-rw-r--r--devel/libtifiles/Makefile31
-rw-r--r--devel/libtifiles/distinfo1
-rw-r--r--devel/libtifiles/pkg-descr10
-rw-r--r--devel/libtifiles/pkg-plist30
4 files changed, 72 insertions, 0 deletions
diff --git a/devel/libtifiles/Makefile b/devel/libtifiles/Makefile
new file mode 100644
index 000000000000..be36ea20fc52
--- /dev/null
+++ b/devel/libtifiles/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libtifiles
+# Date created: 27 August 2003
+# Whom: Tijl Coosemans <tijl@ulyssis.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtifiles
+PORTVERSION= 0.5.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tilp
+
+MAINTAINER= tijl@ulyssis.org
+COMMENT= TI calculator file types library
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= tifiles-config.1
+
+.include <bsd.port.mk>
diff --git a/devel/libtifiles/distinfo b/devel/libtifiles/distinfo
new file mode 100644
index 000000000000..59effcf61ce9
--- /dev/null
+++ b/devel/libtifiles/distinfo
@@ -0,0 +1 @@
+MD5 (libtifiles-0.5.7.tar.gz) = b368e11b9a0f5ec9abab5ab312a44e55
diff --git a/devel/libtifiles/pkg-descr b/devel/libtifiles/pkg-descr
new file mode 100644
index 000000000000..9d8c7a047d8c
--- /dev/null
+++ b/devel/libtifiles/pkg-descr
@@ -0,0 +1,10 @@
+The tifiles library is a multi-platform library which handles the
+various
+Texas Instruments calculator file formats through a set of functions
+which
+constitutes a common API.
+
+WWW: http://tilp.info/
+
+- Tijl Coosemans
+tijl@ulyssis.org
diff --git a/devel/libtifiles/pkg-plist b/devel/libtifiles/pkg-plist
new file mode 100644
index 000000000000..df321996ee19
--- /dev/null
+++ b/devel/libtifiles/pkg-plist
@@ -0,0 +1,30 @@
+bin/tifiles-config
+include/tilp/file_def.h
+include/tilp/file_err.h
+include/tilp/file_int.h
+include/tilp/file_ver.h
+include/tilp/files8x.h
+include/tilp/files9x.h
+include/tilp/filesxx.h
+include/tilp/grp_ops.h
+include/tilp/macros.h
+include/tilp/stdints.h
+include/tilp/tifiles.h
+include/tilp/types73.h
+include/tilp/types82.h
+include/tilp/types83.h
+include/tilp/types83p.h
+include/tilp/types85.h
+include/tilp/types86.h
+include/tilp/types89.h
+include/tilp/types92.h
+include/tilp/types92p.h
+include/tilp/typesv2.h
+include/tilp/typesxx.h
+lib/libtifiles.la
+lib/libtifiles.so
+lib/libtifiles.so.5
+libdata/pkgconfig/tifiles.pc
+share/aclocal/tifiles.m4
+share/locale/fr/LC_MESSAGES/libtifiles.mo
+@unexec rmdir %D/include/tilp 2>/dev/null || true