aboutsummaryrefslogtreecommitdiff
path: root/devel/libtool15/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
committerAde Lovett <ade@FreeBSD.org>2006-02-23 10:40:44 +0000
commit8503536d3896846d823f7f76be54e0a99da8d8b6 (patch)
tree1a89e4038216ead71b008f2a5091474964e1c341 /devel/libtool15/Makefile
parentc20d04e3929dbe1763fc1dfaaa677c2353cd7883 (diff)
downloadports-8503536d3896846d823f7f76be54e0a99da8d8b6.tar.gz
ports-8503536d3896846d823f7f76be54e0a99da8d8b6.zip
Conversion to a single libtool environment.
Approved by: portmgr (kris)
Notes
Notes: svn path=/head/; revision=156749
Diffstat (limited to 'devel/libtool15/Makefile')
-rw-r--r--devel/libtool15/Makefile35
1 files changed, 5 insertions, 30 deletions
diff --git a/devel/libtool15/Makefile b/devel/libtool15/Makefile
index f4797adffba4..85675bdd9a03 100644
--- a/devel/libtool15/Makefile
+++ b/devel/libtool15/Makefile
@@ -7,46 +7,21 @@
PORTNAME?= libtool
PORTVERSION= 1.5.22
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
-COMMENT?= Generic shared library support script (1.5)
+COMMENT?= Generic shared library support script
-BUILD_VERSION= 15
-LATEST_LINK?= libtool${BUILD_VERSION}
-PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
-CONFIGURE_ARGS+= --program-suffix=${BUILD_VERSION} --infodir=${PREFIX}/info
-CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
+CONFIGURE_ARGS+= --infodir=${PREFIX}/info
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
-
-.if ${PORTNAME} == "libtool"
-INFO= libtool${BUILD_VERSION}
-.endif
-
-post-patch:
- @(cd ${WRKSRC}/doc && \
- ${RM} -f *.info* && \
- ${MV} libtool.texi libtool${BUILD_VERSION}.texi && \
- ${REINPLACE_CMD} -E 's,(libtool|libtoolize)\),\1${BUILDVERSION}\),g' libtool${BUILD_VERSION}.texi)
- @${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool${BUILD_VERSION}.m4
- @${MV} -f ${WRKSRC}/ltdl.m4 ${WRKSRC}/ltdl${BUILD_VERSION}.m4
- @${REINPLACE_CMD} -e 's|libtool.m4|libtool${BUILD_VERSION}.m4|g' \
- -e 's|ltdl.m4|ltdl${BUILD_VERSION}.m4|g' ${WRKSRC}/Makefile.in
-
-.if ${PORTNAME} == "libtool"
-post-install:
- @-${RM} -fr ${PREFIX}/libexec/libtool${BUILD_VERSION}
- @${MKDIR} ${PREFIX}/libexec/libtool${BUILD_VERSION}
-.for i in libtool libtoolize
- @${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} ${PREFIX}/libexec/libtool${BUILD_VERSION}/${i}
-.endfor
-.endif
+INFO?= libtool
.include <bsd.port.mk>